Closed Bug 1865267 Opened 8 months ago Closed 6 months ago

Intermittent /css/css-contain/content-visibility/content-visibility-vs-scrollIntoView-003.html on Linux

Categories

(Core :: Layout, defect)

defect

Tracking

()

RESOLVED FIXED
123 Branch
Tracking Status
firefox-esr115 --- unaffected
firefox119 --- unaffected
firefox120 --- unaffected
firefox121 --- wontfix
firefox122 --- wontfix
firefox123 --- fixed

People

(Reporter: fredw, Assigned: fredw)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: intermittent-failure, regression, test-verify-fail)

Attachments

(3 files)

+++ This bug was initially created as a clone of Bug #1862447 +++

With https://phabricator.services.mozilla.com/D193800 and a debug linux build I can reproduce the failure with

$ ./mach wpt --rerun 20 --repeat 5  /css/css-contain/content-visibility/content-visibility-vs-scrollIntoView-003.html
 0:40.58 TEST_START: /css/css-contain/content-visibility/content-visibility-vs-scrollIntoView-003.html
 0:40.58 INFO Run 0/20
 0:40.75 INFO Setting pref dom.animations-api.compositing.enabled to true
 0:40.79 pid:60086 ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to /tmp/tmp0p62z7nk/runtests_leaks_59925_tab_pid60343.log
 0:41.23 INFO Setting pref layout.css.content-visibility.enabled to true
 0:41.76 INFO Setting pref layout.css.contain-intrinsic-size.enabled to true
 0:46.26 TEST_END: Test OK. Subtests passed 1/1. Unexpected 0
 0:46.26 TEST_START: /css/css-contain/content-visibility/content-visibility-vs-scrollIntoView-003.html
 0:46.26 INFO Run 1/20
 0:46.29 INFO Closing window 5c8001ea-69cc-4e6a-b602-74819f720394
 0:47.47 pid:60086 [Child 60269, Main Thread] WARNING: '!IsActive()', file /home/fred/src-obj/mozilla-unified/dom/base/Document.cpp:16438
 0:47.47 pid:60086 [Child 60269, Main Thread] WARNING: '!IsActive()', file /home/fred/src-obj/mozilla-unified/dom/base/Document.cpp:16438
 0:49.68 pid:60086 [Child 60209, Main Thread] WARNING: IPC message 'PContent::Msg_CleanupPendingLoadState' discarded: actor cannot send: file /home/fred/src-obj/mozilla-unified/ipc/glue/ProtocolUtils.cpp:545
 0:50.37 TEST_END: Test OK. Subtests passed 1/1. Unexpected 0
 0:50.37 TEST_START: /css/css-contain/content-visibility/content-visibility-vs-scrollIntoView-003.html
 0:50.37 INFO Run 2/20
 0:50.39 INFO Closing window 6b536571-3037-45be-b179-7d45a8e2f980
 0:52.46 pid:60086 [Child 60269, Main Thread] WARNING: '!IsActive()', file /home/fred/src-obj/mozilla-unified/dom/base/Document.cpp:16438
 0:52.46 pid:60086 [Child 60269, Main Thread] WARNING: '!IsActive()', file /home/fred/src-obj/mozilla-unified/dom/base/Document.cpp:16438
 0:52.54 TEST_END: Test OK. Subtests passed 1/1. Unexpected 0
 0:52.54 TEST_START: /css/css-contain/content-visibility/content-visibility-vs-scrollIntoView-003.html
 0:52.54 INFO Run 3/20
 0:52.56 INFO Closing window a5900b49-b129-48f7-b030-25038360c27c
 0:54.99 TEST_END: Test OK. Subtests passed 1/1. Unexpected 0
 0:54.99 TEST_START: /css/css-contain/content-visibility/content-visibility-vs-scrollIntoView-003.html
 0:54.99 INFO Run 4/20
 0:55.18 INFO Closing window b237b827-28c6-4701-9619-a93652ebd0d4
 0:56.85 pid:60086 [Child 60269, Main Thread] WARNING: '!IsActive()', file /home/fred/src-obj/mozilla-unified/dom/base/Document.cpp:16438
 0:56.85 pid:60086 [Child 60269, Main Thread] WARNING: '!IsActive()', file /home/fred/src-obj/mozilla-unified/dom/base/Document.cpp:16438
 0:56.85 pid:60086 [Child 60269, Main Thread] WARNING: '!IsActive()', file /home/fred/src-obj/mozilla-unified/dom/base/Document.cpp:16438
 0:56.85 pid:60086 [Child 60269, Main Thread] WARNING: '!IsActive()', file /home/fred/src-obj/mozilla-unified/dom/base/Document.cpp:16438
 0:58.10 pid:60086 [Child 60269, Main Thread] WARNING: IPC message 'PSessionStore::Msg_SessionStoreUpdate' discarded: actor cannot send: file /home/fred/src-obj/mozilla-unified/ipc/glue/ProtocolUtils.cpp:545
 0:58.50 pid:60086 JavaScript error: http://web-platform.test:8000/resources/testharness.js, line 1452: uncaught exception: Error: assert_equals: the first event should be generated by visible expected false but got true
 0:58.52 pid:60086 JavaScript error: http://web-platform.test:8000/resources/testharness.js, line 1452: uncaught exception: Error: assert_equals: the second event should be generated by hidden expected true but got false
 0:58.53 pid:60086 JavaScript error: http://web-platform.test:8000/resources/testharness.js, line 1452: uncaught exception: Error: assert_equals: There should be two contentvisibilityautostatechange events. expected 2 but got 3
 1:00.96 pid:60086 [Parent 60086, Main Thread] WARNING: NS_ENSURE_TRUE(parentPresShell) failed: file /home/fred/src-obj/mozilla-unified/layout/base/PresShell.cpp:6665
 1:02.31 pid:60086 [Child 60269, Main Thread] WARNING: IPC message 'PSessionStore::Msg_SessionStoreUpdate' discarded: actor cannot send: file /home/fred/src-obj/mozilla-unified/ipc/glue/ProtocolUtils.cpp:545
 1:06.07 pid:60086 [Child 60269, Main Thread] WARNING: IPC message 'PSessionStore::Msg_SessionStoreUpdate' discarded: actor cannot send: file /home/fred/src-obj/mozilla-unified/ipc/glue/ProtocolUtils.cpp:545
 1:08.80 pid:60086 [Child 60269, Main Thread] WARNING: IPC message 'PSessionStore::Msg_SessionStoreUpdate' discarded: actor cannot send: file /home/fred/src-obj/mozilla-unified/ipc/glue/ProtocolUtils.cpp:545
 1:10.92 pid:60086 [Child 60269, Main Thread] WARNING: IPC message 'PSessionStore::Msg_SessionStoreUpdate' discarded: actor cannot send: file /home/fred/src-obj/mozilla-unified/ipc/glue/ProtocolUtils.cpp:545
 1:28.85 TEST_END: Test ERROR, expected OK. Subtests passed 0/1. Unexpected 1
TIMEOUT ContentVisibilityAutoStateChange fires twice when `scrollIntoView` a descendant of `content-visibility:auto` which is hidden after scrolling - Test timed outERROR /css/css-contain/content-visibility/content-visibility-vs-scrollIntoView-003.html - uncaught exception: Error: assert_equals: There should be two contentvisibilityautostatechange events. expected 2 but got 3
@http://web-platform.test:8000/css/css-contain/content-visibility/content-visibility-vs-scrollIntoView-003.html:77:22

Current timing patch from bug 1807253 does not seem to help.

Set release status flags based on info from the regressing bug 1668136

I can reproduce the issue that way on Linux with a --disable-optimize --disable-debug build:

$ ./mach wpt  --rerun 100 --verify-chaos-mode --pause-on-unexpected --debugger=rr  /css/css-contain/content-visibility/content-visibility-vs-scrollIntoView-003.html
 0:43.49 TEST_START: /css/css-contain/content-visibility/content-visibility-vs-scrollIntoView-003.html
 0:43.49 INFO Run 0/100
 0:43.76 INFO Setting pref dom.animations-api.compositing.enabled to true
 0:44.37 INFO Setting pref layout.css.content-visibility.enabled to true
 0:45.95 INFO Setting pref layout.css.contain-intrinsic-size.enabled to true
 0:51.06 TEST_END: Test OK. Subtests passed 1/1. Unexpected 0
 0:51.06 TEST_START: /css/css-contain/content-visibility/content-visibility-vs-scrollIntoView-003.html
 0:51.06 INFO Run 1/100
 0:51.33 INFO Closing window 1ec32c8d-a5d2-4feb-ad0b-e9c5f4d5b0f9
 0:54.48 TEST_END: Test OK. Subtests passed 1/1. Unexpected 0
 0:54.48 TEST_START: /css/css-contain/content-visibility/content-visibility-vs-scrollIntoView-003.html
 0:54.48 INFO Run 2/100
 0:54.60 INFO Closing window ba67b776-7ba2-41b1-a670-a4b2d9d866f2
 0:57.76 TEST_END: Test OK. Subtests passed 1/1. Unexpected 0
 0:57.76 TEST_START: /css/css-contain/content-visibility/content-visibility-vs-scrollIntoView-003.html
 0:57.76 INFO Run 3/100
 0:58.20 INFO Closing window a8f14c52-f978-4b91-8701-f7df913b7572
 1:01.13 TEST_END: Test OK. Subtests passed 1/1. Unexpected 0
 1:01.13 TEST_START: /css/css-contain/content-visibility/content-visibility-vs-scrollIntoView-003.html
 1:01.13 INFO Run 4/100
 1:01.23 INFO Closing window 5da0b6a6-a786-4cda-bdd6-6d7dec8e8fdb
 1:03.67 pid:56929 JavaScript error: http://web-platform.test:8000/resources/testharness.js, line 1452: uncaught exception: Error: assert_equals: the first event should be generated by visible expected false but got true
 1:03.67 pid:56929 JavaScript error: http://web-platform.test:8000/resources/testharness.js, line 1452: uncaught exception: Error: assert_equals: the second event should be generated by hidden expected true but got false
 1:03.79 pid:56929 JavaScript error: http://web-platform.test:8000/resources/testharness.js, line 1452: uncaught exception: Error: assert_equals: There should be two contentvisibilityautostatechange events. expected 2 but got 3
Severity: -- → S3

Set release status flags based on info from the regressing bug 1668136

Attachment #9364681 - Attachment description: WIP: Bug 1865267 - remove flaky expectation for content-visibility-vs-scrollIntoView-003.html, r=emilio → Bug 1865267 - Do not timeout when content-visibility-vs-scrollIntoView-003.html event count fails r=cathiechen

After recent changes landed in autoland, I cannot reproduce the failure as in comment 2. I can still reproduce the failure on debug as in comment 0.

In any case, there is something wrong in the way the test is written, when the final assertion fails we are just timing out instead of rejecting the promise immediately. I've updated the patch to fix that, which makes the test intermittent failure rather than an intermittent timeout.

Keywords: leave-open
Pushed by fred.wang@free.fr:
https://hg.mozilla.org/integration/autoland/rev/860c977a6f70
Do not timeout when content-visibility-vs-scrollIntoView-003.html event count fails r=cathiechen
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/43418 for changes under testing/web-platform/tests
Upstream PR merged by moz-wptsync-bot
Duplicate of this bug: 1865820

Just to be explicit, the patch I landed fixed the timeout issue, converting it to a failure only.

As I said in comment 5, I cannot reproduce the failure with a release build using the command of comment 2.

And now, I can no longer reproduce the failure with a debug build using comment of comment 0.

Current annotation is for Linux and Android:
https://searchfox.org/mozilla-central/rev/1a63fee6c2a8ea6846f6f16b85edeb6d19fc9f23/testing/web-platform/meta/css/css-contain/content-visibility/content-visibility-vs-scrollIntoView-003.html.ini

I would remove the ones for Android, it used to be timeout before my patch and I believe that's just bug 1798871.

And I would remove the ones for Linux, since I can't reproduce anymore. Then we can see if that starts happening again.

(In reply to Frédéric Wang from comment #11)

As I said in comment 5, I cannot reproduce the failure with a release build using the command of comment 2.

And now, I can no longer reproduce the failure with a debug build using comment of comment 0.

I stand corrected. I can reproduce locally with a non-optimized release build with

./mach wpt --rerun 10 --verify-chaos-mode --pause-on-unexpected --debugger=rr /css/css-contain/content-visibility/content-visibility-auto-relevancy-updates.html /css/css-contain/content-visibility/content-visibility-vs-scrollIntoView-003.html /css/css-contain/content-visibility/content-visibility-vs-scrollIntoView-002.html /css/css-contain/content-visibility/animation-display-lock.html /css/css-contain/content-visibility/slot-content-visibility-8-crash.html /css/css-contain/content-visibility/content-visibility-resize-observer-no-error.html

and with a debug build with too with

./mach wpt --rerun 10 /css/css-contain/content-visibility/content-visibility-auto-relevancy-updates.html /css/css-contain/content-visibility/content-visibility-vs-scrollIntoView-003.html /css/css-contain/content-visibility/content-visibility-vs-scrollIntoView-002.html /css/css-contain/content-visibility/animation-display-lock.html /css/css-contain/content-visibility/slot-content-visibility-8-crash.html /css/css-contain/content-visibility/content-visibility-resize-observer-no-error.html

Pushed by cathiechen@igalia.com:
https://hg.mozilla.org/integration/autoland/rev/e0102888f147
Intermittent /css/css-contain/content-visibility/content-visibility-vs-scrollIntoView-003.html, r=emilio
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/43816 for changes under testing/web-platform/tests
Upstream PR merged by moz-wptsync-bot
Pushed by cathiechen@igalia.com:
https://hg.mozilla.org/integration/autoland/rev/5c1396046f09
Intermittent /css/css-contain/content-visibility/content-visibility-vs-scrollIntoView-003.html, r=fredw
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/43975 for changes under testing/web-platform/tests
Upstream PR merged by moz-wptsync-bot

Should be fixed by Cathie's patches.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 123 Branch
Flags: in-testsuite+

The patch landed in nightly and beta is affected.
:fredw, is this bug important enough to require an uplift?

  • If yes, please nominate the patch for beta approval.
  • If no, please set status-firefox122 to wontfix.

For more information, please visit BugBot documentation.

Flags: needinfo?(fwang)
Flags: needinfo?(fwang)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: