Closed Bug 1869557 Opened 3 months ago Closed 2 months ago

Switching to the thread pane of a folder by keyboard should focus the top visible message.

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 115
Desktop
Unspecified
defect

Tracking

(thunderbird_esr115? fixed, thunderbird122? fixed)

RESOLVED FIXED
123 Branch
Tracking Status
thunderbird_esr115 ? fixed
thunderbird122 ? fixed

People

(Reporter: welpy-cw, Assigned: welpy-cw)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Steps to reproduce:

  1. Select a folder containing messages sorted by date in ascending order, none of which have been selected previously.
  2. Press F6 to switch to the thread pane.

Actual result:

The view scrolls all the way to the top and the first row is selected.

Expected result:

The last row, which has been scrolled into view, should be focused, but not selected (with the current index as indicated by the dotted border)

The expected result is similar to the behavior of Thunderbird 102, where the topmost visible message is focused.

Please note that it's not always the last message which is needed when focusing to message list - pre-Supernova versions restored the last message position well even if that was somewhere in the middle.

Assignee: nobody → h.w.forms
Status: NEW → ASSIGNED

(In reply to thedonpedro from comment #1)

Please note that it's not always the last message which is needed when focusing to message list - pre-Supernova versions restored the last message position well even if that was somewhere in the middle.

Yes, I'm aware of that. This isn't meant to be a fix for bug 1864911, but it should at least improve the situation there for now. Unfortunately, completely fixing the related bug is much more complicated.

Attachment #9368205 - Attachment is obsolete: true

When a tree view (thread pane or address book's cards pane) without any previous selections
receives focus by pressing F6 or Tab, this sets focus to the first visible row, instead of
selecting the first row of all as before.

There were several problems with the approach used in my first patch, so I abandoned it. The new patch changes the way TreeView reacts on receiving the F6 or Tab key when no rows have focus/are selected yet. Instead of selecting the first row, the top visible row is focused, but not selected. This solves the problem described in the first comment and matches the behavior of Thunderbird 102 as far as the thread pane is concerned. Switching to the cards pane in the address book also only gives focus to the first card, not a selection. This seems to be handled differently in earlier Thunderbird ESRs.

What are these changes from an ARIA perspective? The guidelines seem to support this behavior, but I don't know if this is the way Thunderbird is supposed to work.

Flags: needinfo?(elizabeth)

(In reply to Hartmut Welpmann [:welpy-cw] from comment #5)

Hi. Thanks for your work on this. I will test this and let you know the impact.

Summary: Switching to the thread pane of a folder by keyboard should focus the latest message. → Switching to the thread pane of a folder by keyboard should focus the top visible message.
Target Milestone: --- → 123 Branch

Pushed by alessandro@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/bc10b7559d18
Focus (not select) row when tree view gets focus by keyboard. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Flags: needinfo?(elizabeth)

Comment on attachment 9369005 [details]
Bug 1869557 - Focus (not select) row when tree view gets focus by keyboard. r=#thunderbird-front-end-reviewers

[Approval Request Comment]
User impact if declined: Switching to the thread pane by F6 may cause unwanted scrolling.
Testing completed (on c-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9369005 - Flags: approval-comm-beta?

Comment on attachment 9369005 [details]
Bug 1869557 - Focus (not select) row when tree view gets focus by keyboard. r=#thunderbird-front-end-reviewers

[Triage Comment]
Approved for beta

Attachment #9369005 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9369005 [details]
Bug 1869557 - Focus (not select) row when tree view gets focus by keyboard. r=#thunderbird-front-end-reviewers

[Approval Request Comment]
User impact if declined: Switching to the thread pane by F6 may cause unwanted scrolling.
Testing completed (on c-c, etc.): c-c and beta
Risk to taking this patch (and alternatives if risky): very low

Attachment #9369005 - Flags: approval-comm-esr115?

Comment on attachment 9369005 [details]
Bug 1869557 - Focus (not select) row when tree view gets focus by keyboard. r=#thunderbird-front-end-reviewers

[Triage Comment]
Approved for esr115

Attachment #9369005 - Flags: approval-comm-esr115? → approval-comm-esr115+
You need to log in before you can comment on or make changes to this bug.