Closed Bug 1865548 Opened 5 months ago Closed 5 months ago

Collapsing a thread with selections may not set currentIndex correctly

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 115
Desktop
Unspecified
defect

Tracking

(thunderbird_esr115? fixed, thunderbird121? fixed)

RESOLVED FIXED
122 Branch
Tracking Status
thunderbird_esr115 ? fixed
thunderbird121 ? fixed

People

(Reporter: welpy-cw, Assigned: welpy-cw)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [TM:115.6.1])

Attachments

(1 file)

Steps to reproduce:

  1. Enter a threaded view.
  2. Select the first and at least one other message of an expanded thread, making sure that the last single selected message (current index as indicated by the dotted border) was not the root message.
  3. Collapse the thread
  4. Press up/down arrow key.

Actual result:

The view scrolls all the way to the top and the first/second row is selected.

Expected result:

The row immediately above/below the collapsed one is selected.

Assignee: nobody → h.w.forms
Status: NEW → ASSIGNED

This is also the cause of gDBView.hdrForFirstSelectedMessage behaving incorrectly, as reported in bug 1864339.

Severity: -- → S4
Keywords: regression
Regressed by: 1733887
See Also: → 1864339
Target Milestone: --- → 122 Branch

Pushed by benc@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/ea6fd54640d0
Ensure currentIndex is set when collapsing a thread with selections. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED

FYI if this is wanted on nightly for a day or two before beta, then this will make 121.0b6 next week, and then 115.6.0 in two weeks.

Attachment #9364368 - Flags: approval-comm-esr115?
Attachment #9364368 - Flags: approval-comm-beta?

Not a 115 regression, so opting to hold this to next week's beta.

Comment on attachment 9364368 [details]
Bug 1865548 - Ensure currentIndex is set when collapsing a thread with selections. r=#thunderbird-front-end-reviewers

[Triage Comment]
Approved for beta

Attachment #9364368 - Flags: approval-comm-beta? → approval-comm-beta+
See Also: → 1869557
Whiteboard: [TM:115.6.0]
Whiteboard: [TM:115.6.0] → [TM:115.6.1]

Comment on attachment 9364368 [details]
Bug 1865548 - Ensure currentIndex is set when collapsing a thread with selections. r=#thunderbird-front-end-reviewers

[Triage Comment]
Approved for esr115

Attachment #9364368 - Flags: approval-comm-esr115? → approval-comm-esr115+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: