Closed Bug 1871963 Opened 6 months ago Closed 2 months ago

Implement zstd content-encoding support

Categories

(Core :: Networking: HTTP, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
126 Branch
Tracking Status
relnote-firefox --- 126+
firefox126 --- fixed

People

(Reporter: jesup, Assigned: jesup)

References

(Blocks 1 open bug)

Details

(Keywords: dev-doc-complete, Whiteboard: [necko-triaged])

Attachments

(3 files)

No description provided.
Severity: -- → S3
Priority: -- → P2
Whiteboard: [necko-triaged]
Blocks: 1884305
No longer blocks: zstd, 1477516
Attachment #9370275 - Attachment description: WIP: Bug 1871963: Import of zstd → Bug 1871963: Import of zstd library r=#necko-reviewers!,sylvestre!
Pushed by rjesup@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9fb8ccb2f305
Import of zstd library r=sylvestre,necko-reviewers,valentin
https://hg.mozilla.org/integration/autoland/rev/dc2ad0369b86
Implement zstd content-encoding support r=necko-reviewers,valentin
https://hg.mozilla.org/integration/autoland/rev/94e286542c9d
Mark fetch zstd wpt tests as passing r=necko-reviewers,valentin

Backed out for causing for causing dt failures on browser_net_copy_as_powershell.js

Flags: needinfo?(rjesup)

Trivial fix; just needs ", zstd" added to some canned response headers it compares to

Flags: needinfo?(rjesup)
Pushed by rjesup@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/68f119112940
Import of zstd library r=sylvestre,necko-reviewers,valentin
https://hg.mozilla.org/integration/autoland/rev/99e71b905661
Implement zstd content-encoding support r=necko-reviewers,valentin,devtools-reviewers
https://hg.mozilla.org/integration/autoland/rev/ac55c45e0d0f
Mark fetch zstd wpt tests as passing r=necko-reviewers,valentin
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 126 Branch

:jesup could you consider nominating this for a release note? (Process info)

Flags: needinfo?(rjesup)
Blocks: 1891610

FF126 MDN docs for this can be tracked in https://github.com/mdn/content/issues/33086.

As far as I can tell this is just a BCD entry in Content-Encoding (done) and a release note.

Is only Content-Encoding affected? I mean is zstd used for anything else? What about Accept-Encoding (my assumption is that this is set by the browser, and you normally wouldn't get back zstd if you had not set this?)

Note, have marked as dev-doc-complete on assumption there is nothing else to say.

Regressions: 1891666

Release Note Request (optional, but appreciated)
[Why is this notable]: Significant change in what types of compression we support, impacts websites
[Affects Firefox for Android]: yes
[Suggested wording]: Firefox 126 supports Content-encoding: zstd (zstandard compression). This is an alternative to broti and gzip compression for web content, and can provide higher compression levels for the same CPU used, or conversely lower server CPU use to get the same compression. This is heavily used on sites such as Facebook. It shipped in Chrome 123 recently.
[Links (documentation, blog post, etc)]: RFC 8878, http://facebook.github.io/zstd/

relnote-firefox: --- → ?
Flags: needinfo?(rjesup)
Duplicate of this bug: 1477516
Blocks: 1879030
See Also: 1893113
Regressions: 1900339
Component: Networking → Networking: HTTP
Summary: Import zstd library → Implement zstd content-encoding support

Renamed so it's clear that the actual support landed in this bug.

You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: