Closed Bug 1872239 Opened 2 months ago Closed 1 month ago

Enter key repeats Delete rather than opening message

Categories

(Thunderbird :: Mail Window Front End, defect)

Thunderbird 115
defect

Tracking

(thunderbird_esr115? fixed)

RESOLVED FIXED
123 Branch
Tracking Status
thunderbird_esr115 ? fixed

People

(Reporter: sinclairs, Assigned: welpy-cw)

References

(Regression)

Details

(Keywords: regression, triaged)

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:120.0) Gecko/20100101 Firefox/120.0

Steps to reproduce:

Using Thunderbird 115.4.1 under Ubuntu 20.04.6.
Viewing list of emails in Inbox, select one by clicking on it, click on Delete button in the Unified Toolbar. The entry disappears as desired. With the next email in the list now highlighted, press Enter key. Instead of viewing this email, it too disappears.
If, instead of using the Delete button in the Unified Toolbar, the Delete key on the keyboard is used, then the repeated deletion from Enter does NOT occur.

Actual results:

The messages that disappeared can be found in the Deleted folder, and restored by dragging back to Inbox.

Expected results:

From a list of emails I expect Enter key always to open the selected email for viewing. This was what happened in previous Thunderbird releases.

Hi, thank you for reporting on this! I'm able to reproduce it on Windows and macOs however the results are slightly different:

Steps to reproduce:

  1. Start on any folder where you have emails to delete
  2. Ensure in the Unified Toolbar you have the Delete button
  3. Delete email by clicking the Unified Toolbar button
  4. The entry disappears as desired
    Here is where things change depending of the OS
  • *On Thunderbird 123 (Daily) Windows 10 as well as on Thunderbird 115.4.1. Ubuntu 20.04.6 VM *
    5. The next message in the list now shown as selected but not focused (gray background instead of the blue that represents active)
    6. Press Enter Key
    7. The selected but not focused message has now been deleted
  • On Thunderbird 115.6.1 (ESR) macOS Sonoma 14.2.1
    5. The next message in the list now shown as focused and selected (blue background)
    6. Press Enter Key
    7. Nothing happens

Actual results:

  • Windows and Ubuntu
    8. The messages that disappeared can be found in the Deleted folder, and restored by dragging back to Inbox.

  • macOS
    8. Nothing happens

Expected results:

  • From a list of emails user expects the Enter key always to open the selected email for viewing. This was what happened in previous Thunderbird releases.

Confirming Bug exists and flagging it as S3 but that might change. I will ping someone with Ubuntu to test it out too as the mac and windows errors are different.

Severity: -- → S3
Keywords: triaged
Status: UNCONFIRMED → NEW
Ever confirmed: true

I have reproduced this exactly with an Ubuntu 20.04.6 VM and Thunderbird 115.4.1. It also happens with the 115.6.0 that is by default installed

Attached video ubuntu-reproduced.webm

Adding a screencast of the reproduced issue on the Ubuntu 20.04.6 VM with thunderbird 115.4.1

By the way, this is also problematic for the Archive button. The following patch provides a possible solution.

Assignee: nobody → h.w.forms
Status: NEW → ASSIGNED

Hartmut, thank you so much for taking time to improve Thunderbird by submitting a patch to fix this issue :)

Pushed by john@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/d8f17473d39b
Prevent mail tab specific unified toolbar buttons from getting focus. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 123 Branch
Keywords: regression
Regressed by: sn-utb-rebuild

Comment on attachment 9372637 [details]
Bug 1872239 - Prevent mail tab specific unified toolbar buttons from getting focus. r=#thunderbird-reviewers

[Approval Request Comment]
Regression caused by (bug #): sn-utb-rebuild
User impact if declined: User may accidentally delete messages just by pressing Enter.
Testing completed (on c-c, etc.): c-c and beta
Risk to taking this patch (and alternatives if risky): very low

Attachment #9372637 - Flags: approval-comm-esr115?

Comment on attachment 9372637 [details]
Bug 1872239 - Prevent mail tab specific unified toolbar buttons from getting focus. r=#thunderbird-reviewers

[Triage Comment]
Approved for esr115

Attachment #9372637 - Flags: approval-comm-esr115? → approval-comm-esr115+
You need to log in before you can comment on or make changes to this bug.