[junk][mailviews] View -> People I know filter does not work with "Additional Email" address in address book

VERIFIED FIXED in mozilla1.5alpha

Status

defect
VERIFIED FIXED
17 years ago
15 years ago

People

(Reporter: dan, Assigned: sspitzer)

Tracking

Trunk
mozilla1.5alpha
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

17 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212

If a contact has two email addresses, the addressbook allows you to store one
address as the primary email and the second as the additional email.  

When using the View dropdown in the main mail window to look for only emails
from people I know (i.e. Sender is contained in Personal address book), any
email received from the contact's "additional email" address is not recognised
as an email from a person I know

Reproducible: Always

Steps to Reproduce:
1.  Create a contact in the addressbook with two addresses (primary:
contactaddr1@bla.com, additional: contactaddr2@bla.com)
2.  Send yourself an email from primary address
3.  Choose View -> People I know.  The email will show up.
4.  Send yourself an email from additional address
5.  Choose View -> All.  The second email shows up
6.  Choose View -> People I know.  Only the first email shows up

Actual Results:  
In step 3, the first email shows up
In step 5, both emails are displayed
In step 6, the second email disappears

Expected Results:  
In step 6, both the first and second email should be displayed, as the second
email was sent from the "additional address" of a contact in your personal
address book.

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Comment 1

16 years ago
As far as i can tell, this also affects junk mail fiters
Summary: View -> People I know filter does not work with additional email address in address book → [junk] View -> People I know filter does not work with additional email address in address book

Updated

16 years ago
Summary: [junk] View -> People I know filter does not work with additional email address in address book → [junk][mailviews] View -> People I know filter does not work with additional email address in address book

Updated

16 years ago
Blocks: spamfe

Comment 2

16 years ago
it's true also in build 20030310, Win2000. Tested it by copying fist address to
second address and then using some capital letters in the first email address. 
Result -> mails are not visible
Exchanging addresses -> mails are visible 
yes, I can see why this happens.

but not immediate plans to fix, maybe 1.5
Assignee: racham → sspitzer
Target Milestone: --- → mozilla1.5alpha
but I can fix part of it, soon.

the reason it happens, is that we search on kLowerCasePrimaryEmail column.

for 1.4 beta, we could also search on other email columns.

but you'd the interCaps issue of bug #196777, since we don't have a
kLowerCaseSecondaryEmail column

but that's better than nothing.
Status: NEW → ASSIGNED
here's the fix for this, but it will suffer from bug #196777

NS_IMETHODIMP nsAbMDBDirectory::HasCardForEmailAddress(const char *
aEmailAddress, PRBool * aCardExists)
{
  nsresult rv = NS_OK;
  *aCardExists = PR_FALSE;

  if (!mDatabase)
    rv = GetAbDatabase();
  NS_ENSURE_SUCCESS(rv, rv);

  nsCOMPtr<nsIAbCard> card; 
  mDatabase->GetCardFromAttribute(this, kLowerPriEmailColumn /* see #196777 */,
aEmailAddress, PR_TRUE /* caseInsensitive, see bug #191798 */,
getter_AddRefs(card));
  if (card)
    *aCardExists = PR_TRUE;
  else 
  {
    // fix for bug #187239
    // didn't find it as the primary email?  try again, with k2ndEmailColumn
("Additional Email")
    // unlike the kPriEmailColumn, we don't have kLower2ndEmailColumn
    // so we will suffer from bug #196777
    mDatabase->GetCardFromAttribute(this, k2ndEmailColumn, aEmailAddress,
PR_TRUE /* caseInsensitive, see bug #191798 */, getter_AddRefs(card));
    if (card)
      *aCardExists = PR_TRUE;
  }
  return NS_OK;
}
my fix for #198303 will have this patch.
Depends on: 198303
Summary: [junk][mailviews] View -> People I know filter does not work with additional email address in address book → [junk][mailviews] View -> People I know filter does not work with "Additional Email" address in address book

Comment 7

16 years ago
per comment 4: for that should we reopen bug #196777 and/or file a different bug
for not having a kLowerCaseSecondaryEmail and add a dependency to bug #196777?
fixed.

bug #198731 filed for the case insensitivity issue of "additional email"
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 9

16 years ago
Trunk build 2003-03-25: Mac 10.1.5, WinME, Linux RH 8
Fixed for the MailViews scenarios.

Reassigning this bug to Esther to check the Junk Mail scenarios.
Status: RESOLVED → VERIFIED
QA Contact: nbaca → esther

Comment 10

16 years ago
Using trunk build 20030324 on winxp, macosx and linux this is fixed for Junk
Mail Controls. 
Card has a secondary email address.  Mail from the secondary email address is
correctly listed as not junk when it comes in.

Verifying since the mailviews portion has already been verfied
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.