If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[mailviews] [junk] primary email ddresses with capital letters do not appear after selecting the "People I Know" view

VERIFIED FIXED in mozilla1.4beta

Status

SeaMonkey
MailNews: Message Display
VERIFIED FIXED
15 years ago
13 years ago

People

(Reporter: Ninoschka Baca, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
mozilla1.4beta
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2])

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
Trunk build 2003-03-10: Mac 10.1.5
Can't try windows due to bug# 196755.

Overview: Addresses with capital letters do not appear after selecting the
"People I Know" view. This problem occurs with any view where the Sender points
to an address book.

Steps to reproduce:
1. Add a card to the Personal Address Book where the email address includes
atleast one capital letter (i.e. Smith@test.com)
2. Select the "People I Know" view, 
(People I Know = "Sender" "is in my address book" "Personal Address Book")

Actual Results: Entries with capital letters in the email address do not appear.
If I change the email address to include only lower case letters then it works.

Expected Results: All entries should appear including email addresses that have
capital letters.
(Reporter)

Comment 1

15 years ago
Marking nsbeta1. Users are very likely to experience this problem since many
addresses have capital letters (i.e. AOL accounts).
Keywords: nsbeta1
QA Contact: esther → nbaca

Comment 2

15 years ago
also on XP Pro SP1 platform & OS -> ALL
OS: MacOS X → All
Hardware: Macintosh → All

Comment 3

15 years ago
This also effects the junk mail filters
Summary: [mailviews] Addresses with capital letters do not appear after selecting the "People I Know" view → [mailviews] [junk] Addresses with capital letters do not appear after selecting the "People I Know" view

Comment 4

15 years ago
*** Bug 196689 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Blocks: 169638

Comment 5

15 years ago
Mail triage team: nsbeta1+/adt2
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt2]
this is the hard part of bug #191798
Status: NEW → ASSIGNED
Depends on: 191798
Target Milestone: --- → mozilla1.4beta
actually, the fix might be simple, if I can use kLowerPriEmailColumn
Created attachment 117578 [details] [diff] [review]
patch

this trick might be useful for our other case sensitivity problems, like with
address collection, etc.

I'll get a review from cavin.
Attachment #117578 - Flags: review?(cavin)

Comment 9

15 years ago
Comment on attachment 117578 [details] [diff] [review]
patch

r=cavin.
Attachment #117578 - Flags: review?(cavin) → review+
fixed.  after all my red flag raising, the fix was simple.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 11

15 years ago
Verified for mailviews. But i don't know how i can verify this for JUNK as i
don't know how to track why a message is flagged JUNK or not.

Thanks Seth for fixing this one! On to bug 187239 ;)
Blocks: 198731
Summary: [mailviews] [junk] Addresses with capital letters do not appear after selecting the "People I Know" view → [mailviews] [junk] primary email ddresses with capital letters do not appear after selecting the "People I Know" view
(Reporter)

Comment 12

15 years ago
Trunk build 2003-03-25: Mac 10.1.5, WinME, Linux RH 8
Fixed for the MailViews scenarios.

Reassigning to Esther to check the Junk Mail scenarios.
QA Contact: nbaca → esther

Comment 13

15 years ago
Using trunk build 20030324 on winxp, macosx and linux this is fixed for Junk
Mail Controls. 
Card has all lower case, sender has mix of upper case and lower case in email
address. Mail is correctly listed as not junk when it comes in. 
Card has mixture of lower case and upper case, email address has only lower case
in email address.  Mail is correctly listed as not junk when it comes in. 
Verifying since the mailviews portion has already been verfied
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.