Closed Bug 1873023 Opened 7 months ago Closed 7 months ago

Attachments handling/adding problem if the attachment has the same filename as temp file already opened

Categories

(Thunderbird :: Message Compose Window, defect)

Thunderbird 115
defect

Tracking

(thunderbird_esr115 fixed, thunderbird122 wontfix)

RESOLVED FIXED
123 Branch
Tracking Status
thunderbird_esr115 --- fixed
thunderbird122 --- wontfix

People

(Reporter: blaz4net, Assigned: mkmelin)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [TM 115.8.0])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:121.0) Gecko/20100101 Firefox/121.0

Steps to reproduce:

That bug is extremely critical, please repair that major error as soon as possible.

For example you have two e-mails in inbox folder and that two e-mails have attachment with the same name (Invoice.pdf), but the invoices are different ones.
You stand on e-mail1 with attachment Invoice.pdf which you open and close (the Invoice.pdf is stored temporary in C:\Users\User1\AppData\Local\Temp\pid-xxxxx as Invoice.pdf).
Than you open e-mail2 and open there another attachment with the same filename Invoice.pdf and close it (the Invoice.pdf is stored temporary in C:\Users\User1\AppData\Local\Temp\pid-xxxxx as Invoice-1.pdf).
Now you want to compose new e-mail and drag and drop Invoice.pdf from second, third or XX opened e-mail with the same attachments name. The filesize and name of attached file is shown right at bottom of the window, but if you open or send that attachment, the Thunderbird opens (and also send) the wrong attachment -> the attachment which you opened first and is stored as Invoice.pdf in temp folder.

I am using Thunderbird for more than 15 years and trusted it. Before 115 version I didn't meet that problem. But I don't know if I upgraded in November23 from version 102... or 91...
I checked that problem on 4 different computers with Windows 10 and Windows 11. The same problem occurs.

Actual results:

If the attachments which you move from another e-mails have the same filenames, the handling and adding from temporary folder is wrong and you easily sent wrong attachment to wrong recipient if you don't check what is added!
That bug is extremely critical and something like that should not happened!

Expected results:

When moving/attaching attachments from another E-mails to compose window, the right attachment must be added, not the wrong one from temporary folder!
That must be repaired immediately.

Can someone please let me know how to include supporter/programmer/developer, because that bug is very dangerous in the way of sending wrong attachments to wrong people.

I found also similar bug reported, maybe the problem is the same. Check: https://bugzilla.mozilla.org/show_bug.cgi?id=1863033

Flags: needinfo?(mkmelin+mozilla)
Flags: needinfo?(el)
Duplicate of this bug: 1863033

Testing on linux daily, I can't reproduce sending the wrong file - on drop the file to use gets removed.
The underlying problem should be the same though.

Assignee: nobody → mkmelin+mozilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(mkmelin+mozilla)
Flags: needinfo?(el)
Keywords: regression
Regressed by: 1760025
See Also: → 413848
Summary: Attachments handling/adding problem if the attachment has the same filename. → Attachments handling/adding problem if the attachment has the same filename as temp file already opened
No longer duplicate of this bug: 1863033
Target Milestone: --- → 123 Branch

Pushed by john@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/e560e091dbef
Ensure added/dropped attachment does not get confused with temp file in the folder. r=john.bieling

Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED

Comment on attachment 9371251 [details]
Bug 1873023 - Ensure added/dropped attachment does not get confused with temp file in the folder. r=john.bieling

[Approval Request Comment]
Regression caused by (bug #): bug 1760025
User impact if declined: can send wrong attachment
Testing completed (on c-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): fairly safe

Attachment #9371251 - Flags: approval-comm-esr115?
Whiteboard: [TM 115.7.1]

Comment on attachment 9371251 [details]
Bug 1873023 - Ensure added/dropped attachment does not get confused with temp file in the folder. r=john.bieling

[Triage Comment]
Approved for esr115

Attachment #9371251 - Flags: approval-comm-esr115? → approval-comm-esr115+
Whiteboard: [TM 115.7.1] → [TM 115.8.0]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: