From-field when replying to message in "local folders" should be "To"-field of original

RESOLVED DUPLICATE of bug 18906

Status

MailNews Core
Composition
--
enhancement
RESOLVED DUPLICATE of bug 18906
15 years ago
9 years ago

People

(Reporter: Bart Mortelmans, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021123
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021123




Reproducible: Always

Steps to Reproduce:
1. Make sure you've got a couple of e-mail accounts installed
2. File a message in the "local folders" and press "reply"

Actual Results:  
The From field contains the first e-mail address in the list of accounts (this
isn't necessarily the same as the first one in the drop-down)


Expected Results:  
If the To-field (or CC) of the original message contains an e-mail address
that's the address of one of your accounts, then this address should be
automaticly selected in the From-field of your reply.

Comment 1

15 years ago
This works for me with trunk build 2003010205 on Windows 2000.

I sent myself a couple of emails from different adresses (some of which I don't
have an email account for) and did what you explained. Everything worked like it
should.
(Reporter)

Comment 2

15 years ago
I just checked this with the latest nightly (sorry, thought I did so before
posting but messed up the upgrade) and still see this problem.

Maybe I should explain more clearly what I see:
1. I send a message to reg@bim.be
2. Once received and read I move this message to a folder I once created as a
subfolder of "Local Folders" called "personal".
3. I open the message in the folder "personal" and click reply.
4. I would like the from-field to automaticly be "reg@bim.be", but it isn't
because reg@bim.be just doesn't happen to be the first e-mail address in my
list. I have to manually select reg@bim.be from the dropdown.

Comment 3

15 years ago
I see this behavior.  But replying to a message in the local folders uses your
default account, not simply the first in the list.  It sounds like the request
is for some intelligence in choosing which From: address to use, beyond just
picking the default.  I couldn't find any duplicates.
(Reporter)

Comment 4

15 years ago
"some intelligence in choosing which From: address to use" probably is the best
way to point out what I'm after. My suggestion would be something like this:

- If you reply to a message stored in the inbox of a mailaccount then the
from-field should be the e-mail address of that account
- If you reply to a message stored somewhere else, check To and CC-fields for
e-mail addresses for which an account is installed in Mozilla. 
  - If one is found, use it as the From-address.
  - Else, use the default e-mail account for the from-address.

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

15 years ago
Not sure if this can be the same bug, but the same might apply to what happens
when you right-click an e-mail address in the headers of an e-mail and choose
"Compose Mail To" and maybe even also when you click on an e-mail address in the
body of an e-mail.
Or am I just asking for too much?

Summary of this bug should probably be updated if this can be the same bug. Feel
free to do so.

Comment 6

15 years ago
*** Bug 194527 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
*** Bug 196864 has been marked as a duplicate of this bug. ***

Comment 8

15 years ago
An alternative:  allow a default 'from:' mail account to be set for each folder
under Local.

Comment 9

15 years ago
> allow a default 'from:' mail account to be set for each folder under Local.

this is bug 166293

Comment 10

15 years ago
*** Bug 208904 has been marked as a duplicate of this bug. ***

Comment 11

14 years ago
*** Bug 220453 has been marked as a duplicate of this bug. ***

Comment 12

14 years ago
*** Bug 228194 has been marked as a duplicate of this bug. ***

Comment 13

14 years ago
noticed bug 18906 when a fix was checked in...  See also followup bug 228980.

*** This bug has been marked as a duplicate of 18906 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
*** Bug 262613 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.