Closed Bug 1877196 Opened 3 months ago Closed 3 months ago

Move more ASRouter modules to browser/components/asrouter

Categories

(Firefox :: Messaging System, task, P2)

task
Points:
5

Tracking

()

RESOLVED FIXED
124 Branch
Iteration:
124.2 - Feb 4 - Feb 16
Tracking Status
firefox124 --- fixed

People

(Reporter: mconley, Assigned: mconley)

References

(Blocks 1 open bug)

Details

Attachments

(11 files)

48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review

In bug 1868838, I missed a few modules:

  • Spotlight: "resource://activity-stream/lib/Spotlight.jsm"
  • ToastNotification: "resource://activity-stream/lib/ToastNotification.jsm"
  • ToolbarBadgeHub: "resource://activity-stream/lib/ToolbarBadgeHub.jsm"
  • ToolbarPanelHub: "resource://activity-stream/lib/ToolbarPanelHub.jsm"
  • MomentsPageHub: "resource://activity-stream/lib/MomentsPageHub.jsm"
  • InfoBar: "resource://activity-stream/lib/InfoBar.jsm"
  • ActorConstants: "resource://activity-stream/common/ActorConstants.sys.mjs" (see this comment)
  • InflightAssetsMessageProvider: "resource://testing-common/InflightAssetsMessageProvider.sys.mjs" (see this comment)

If I discover more, I'll update the above list.

Blocks: fxms-infra
Iteration: --- → 124.1 - Jan 22 - Feb 2
Priority: -- → P2

All of the browser_asrouter tests under browser/components/newtab/test/browser also need to be moved.

Assignee: nobody → mconley

We import the ActorConstants into the ASRouter unit-entry.js script because
ASRouterChild.sys.mjs loads ActorConstants.sys.mjs, and the ResourceUriPlugin
that does the rewriting for the Karma tests doesn't understand how to do
remapping outside of the newtab folder.

So instead of trying to hack that capability into ResourceUriPlugin, we
just import the ActorConstants into the Karma global scope.

Duplicate of this bug: 1878161

I think the following modules in newtab/lib should be in the asrouter or aboutwelcome directory:

FeatureCalloutBroker.sys.mjs
FeatureCalloutMessages.sys.mjs
PageEventManager.sys.mjs

We can also move FeatureCallout.sys.mjs from browser/modules to asrouter now. The reason we put it there previously was because we didn't want to add more stuff to the newtab directory that had nothing to do with newtab. But now that we have our own directories, it makes sense to keep all the Feature Callout files together.

We can move styles from browser/components/newtab/content-src/styles to asrouter as well:

_feature-callout-theme.scss
_feature-callout.scss
_shopping.scss
Attachment #9377275 - Attachment description: Bug 1877196 - Move Spotlight.jsm to browser/components/asrouter. r?pdahiya! → Bug 1877196 - Move Spotlight.sys.mjs to browser/components/asrouter. r?pdahiya!
Attachment #9377276 - Attachment description: Bug 1877196 - Move ToastNotification.jsm to browser/components/asrouter. r?pdahiya! → Bug 1877196 - Move ToastNotification.sys.mjs to browser/components/asrouter. r?pdahiya!
Attachment #9377279 - Attachment description: Bug 1877196 - Move MomentsPageHub.jsm to browser/components/asrouter. r?pdahiya! → Bug 1877196 - Move MomentsPageHub.sys.mjs to browser/components/asrouter. r?pdahiya!
Attachment #9377280 - Attachment description: Bug 1877196 - Move InfoBar.jsm to browser/components/asrouter. r?pdahiya! → Bug 1877196 - Move InfoBar.sys.mjs to browser/components/asrouter. r?pdahiya!
Iteration: 124.1 - Jan 22 - Feb 2 → 124.2 - Feb 4 - Feb 16
Blocks: 1878731
Points: --- → 5
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d7e0311ce3a3
Move Spotlight.sys.mjs to browser/components/asrouter. r=pdahiya,omc-reviewers
https://hg.mozilla.org/integration/autoland/rev/41e516a4f474
Move ToastNotification.sys.mjs to browser/components/asrouter. r=pdahiya,omc-reviewers
https://hg.mozilla.org/integration/autoland/rev/a2a5866599fd
Move ToolbarBadgeHub.jsm to browser/components/asrouter. r=pdahiya,omc-reviewers
https://hg.mozilla.org/integration/autoland/rev/c88a794e2c4a
Move ToolbarPanelHub.jsm to browser/components/asrouter. r=pdahiya,omc-reviewers
https://hg.mozilla.org/integration/autoland/rev/3a82add91978
Move MomentsPageHub.sys.mjs to browser/components/asrouter. r=pdahiya,omc-reviewers
https://hg.mozilla.org/integration/autoland/rev/212cdeb74d29
Move InfoBar.sys.mjs to browser/components/asrouter. r=pdahiya,omc-reviewers
https://hg.mozilla.org/integration/autoland/rev/8264fa2061de
Move InflightAssetsMessageProvider.sys.mjs to browser/components/asrouter. r=pdahiya,omc-reviewers
https://hg.mozilla.org/integration/autoland/rev/7e7b0e89be14
Move browser_asrouter tests to browser/components/asrouter. r=pdahiya,omc-reviewers
https://hg.mozilla.org/integration/autoland/rev/6d8e81032058
Move ActorConstants.sys.mjs to browser/components/asrouter. r=pdahiya,omc-reviewers
https://hg.mozilla.org/integration/autoland/rev/575a584147b1
Move FeatureCallout modules and styles to browser/components/asrouter. r=fxview-reviewers,omc-reviewers,sclements,aminomancer
https://hg.mozilla.org/integration/autoland/rev/885e7a23a077
Move PageEventManager.sys.mjs to browser/components/asrouter. r=pdahiya,omc-reviewers,aminomancer
Regressions: 1880677
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: