Closed Bug 1878190 Opened 3 months ago Closed 3 months ago

The weather current conditions box isn't vertically centered anymore

Categories

(Firefox :: Address Bar, defect, P1)

defect

Tracking

()

VERIFIED FIXED
124 Branch
Tracking Status
firefox-esr115 --- unaffected
firefox122 --- unaffected
firefox123 --- wontfix
firefox124 --- verified
firefox125 --- verified
firefox126 --- verified

People

(Reporter: adw, Assigned: adw)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image screenshot

Bug 1851481 removed align-items: start for .urlbarView-row-inner, which the weather row was relying on to center the current conditions box. We'll need to add a rule specifically for weather. I noticed the quick suggest contextual opt-in (also a dynamic result type) has such a rule already.

Set release status flags based on info from the regressing bug 1851481

Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/33122afe888d
Center-align the weather row in the urlbar view. r=dao,desktop-theme-reviewers
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 124 Branch

The patch landed in nightly and beta is affected.
:adw, is this bug important enough to require an uplift?

  • If yes, please nominate the patch for beta approval.
  • If no, please set status-firefox123 to wontfix.

For more information, please visit BugBot documentation.

Flags: needinfo?(adw)

Weather won't be enabled in 123, no need to uplift.

Flags: needinfo?(adw)
Flags: qe-verify+

I've attempted to replicate this issue in Nightly 124.0a1 on Windows 10 x64 without success.
To enable the weather information widget, I've flipped following prefs in about:config:
quicksuggest.enabled
browser.urlbar.suggest.weather
browser.urlbar.weather.featureGate

Despite this, the weather information widget is not displayed.
Could you provide additional details or insights to facilitate the replication of this issue? Thanks

Flags: needinfo?(adw)

Hi Ina, those prefs are correct, right. (The first pref you mentioned is actually browser.urlbar.quicksuggest.enabled, just to be safe.)

Assuming you're using a VPN to enable Firefox Suggest, you'll also need to set browser.urlbar.weather.ignoreVPN = true. Normally Firefox won't show a weather suggestion if it detects you're on a VPN. The browser.urlbar.weather.ignoreVPN pref will bypass that detection and show the suggestion anyway.

To add more details, actually VPN detection only works on Windows, so really that pref is necessary only on Windows. On Mac and Linux, the suggestion should be shown even if you're on a VPN. But it doesn't hurt to set the pref anyway.

Flags: needinfo?(adw)

I've tested this by enabling the following prefs and using a US-based VPN:
browser.urlbar.quicksuggest.enabled
browser.urlbar.suggest.weather
browser.urlbar.weather.featureGate
browser.urlbar.weather.ignoreVPN

I've manage to replicate the issue solely on macOS using Nightly versions older than 15.02.2024. Subsequently, the Weather information widget is no longer displayed in Nightly, including the latest version 125.0a1.
However, the issue can not be replicated on Windows 10 x64 across the same Nightly versions; in these instances, the text alignment within the weather information widget remained proper. Regardless of the Nightly versions used, the Weather information widget is not displayed on Ubuntu 22.04.
It appears that there are some particularities here that I might be missing.
Please advise if there are any specific steps to follow in order to test this thoroughly. Thanks

Flags: needinfo?(adw)

Weather keywords are stored in remote settings, and if keywords can't be synced, then the weather suggestion can't be triggered. Maybe there's a problem syncing with remote settings? Please try this:

  1. New profile
  2. Set browser.urlbar.loglevel = Debug
  3. Restart
  4. Type weather

And then could you copy-paste the logs from the browser console please? They might be able to tell us what's happening.

Flags: needinfo?(adw)

I suspect that the weather was not triggered in Ina's case because when we are using a VPN client connected to US, sometimes the browser.search.region is not set to US, so we need to manually set the pref.

However, I have managed to trigger the weather results and verified the bug on Firefox 124.0 Release (Build ID: 20240311145044), Beta 125.0b1 (Build ID: 20240318085508) and Nightly 126.0a1 (Build ID: 20240319215652) on Windows 10 x64, macOS 13.1 and Linux Ubuntu 20.04 x64,

Here are the results:

  • If the browser is resized and the weather content is displayed on 5 rows, everything seems to be centered.
  • If the browser is resized and the weather content is displayed on 4 rows + "Feedback" button, the content doesn't seem to be centered.
  • If the weather content is displayed on 3 rows, everything seems to be centered.

Here is a screenshot with the scenarios mentioned above: screenshot link.

@Drew, is there a limitation for the content displayed on 4 rows? Or should we log a separate issue for it and mark this one as verified fixed?

Flags: needinfo?(adw)

Thanks Cosmin! Looks like there's still a bug here then. Could you file a new one, mark it as a see-also of this one, and mark this one as verified please?

Flags: needinfo?(adw)

Thanks Drew!

I have logged Bug 1886694 to track the issue.
Based on this, I will mark this one as Verified - Fixed, and will track the other issue in the new logged bug.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: