Closed Bug 1878457 Opened 3 months ago Closed 2 months ago

ESMify performance-new modules

Categories

(DevTools :: Performance Tools (Profiler/Timeline), task)

task

Tracking

(firefox124 fixed)

RESOLVED FIXED
124 Branch
Tracking Status
firefox124 --- fixed

People

(Reporter: arai, Assigned: arai)

References

Details

(Whiteboard: [esmification-timeline])

Attachments

(3 files)

https://searchfox.org/mozilla-central/search?q=EXPORTED_SYMBOLS&path=performance-new&case=false&regexp=false

Those modules had been overlooked by the are-we-esmified-yet script because they've been using .jsm.js extension and indirect var EXPORTED_SYMBOLS = Object.keys(module.exports); syntax, which doesn't match the pattern.

so far I don't see anything blocks converting them to ESM, so I'll give it a try and submit patches once I confirmed fix.

Whiteboard: [esmification-timeline]
Depends on: 1878467
Depends on: 1878512
Pushed by arai_a@mac.com:
https://hg.mozilla.org/integration/autoland/rev/c2b811f0f8d8
Part 1: ESMify performance-new modules. r=julienw,profiler-reviewers
https://hg.mozilla.org/integration/autoland/rev/247e7e28d7cc
Part 2: ESMify consumers of performance-new modules. r=julienw,profiler-reviewers
https://hg.mozilla.org/integration/autoland/rev/9f16b642b137
Part 3: Remove JSM section from performance-new README. r=julienw,profiler-reviewers
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 124 Branch
Blocks: 1878848
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: