Cannot save image from the "save image as" context menu

VERIFIED FIXED

Status

()

Toolkit
Downloads API
VERIFIED FIXED
15 years ago
10 years ago

People

(Reporter: Dai Toyama, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20030108 Phoenix/0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20030110 Phoenix/0.5

When attempting to save an image on the Web page, one right-clicks the image,
selects "Save Image As" and click OK on the "save picture" dialog.  Then the
image will be saved.  However, the last procedure (of saving the image) never
takes place, leaving the progress indicator box open.

Reproducible: Always

Steps to Reproduce:
1.  Go to www.redhat.com
2.  Right-click the headline picture and choose "Save Image As"
3.  Click "Save" on the "save picture" dialog

Actual Results:  
The save progress box pops up and stays there, without doing anything.

Expected Results:  
It should have saved the selected picture, and the progress box should show the
progress of the process of saving.

Comment 1

15 years ago
DUPE bug #188497

Comment 2

15 years ago
Confirming on windows 2002011015
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

15 years ago
*** Bug 188497 has been marked as a duplicate of this bug. ***

Comment 4

15 years ago
-->Component is Downloading, not General

I'd love to know how this was broken as not much is being done right now. Is
this maybe Mozilla-wide?
Component: General → Downloading

Comment 5

15 years ago
Created attachment 111274 [details] [diff] [review]
Fix Save Image As and Save Link As...

This was broken by the Jan 8 15:53 check-in for bug #170722 - specifically, the
additional of new arguments to nsIWebBrowserPersist::saveURI().  

I have attached the fix for Phoenix...is anyone home to check it in?

Comment 6

15 years ago
"Save Page As..." is also brocken, if using the option "Web Page, html only" on
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20030110 Phoenix/0.5.

Comment 7

15 years ago
Comment on attachment 111274 [details] [diff] [review]
Fix Save Image As and Save Link As...

It would appear (?) that some of the elements of the patch for bug #170722 were
incorporated by default into Phoenix and others, such as that contained within
attachment 111274 [details] [diff] [review] were not?

Anyway, patch 111274 fixes the context-menu image save as problem.

-->Set flag to review by Blake

(Jeff, I think that you can do this yourself in the future if you have triage
powers)
Attachment #111274 - Flags: review?(blaker)

Comment 8

15 years ago
> It would appear (?) that some of the elements of the patch 
> for bug #170722 were incorporated by default into Phoenix and 
> others, such as that contained within attachment 111274 [details] [diff] [review] were not?

The change associated with bug #170722 affected both Phoenix and Mozilla, due to
the largely shared code base.  The only part that is separate, wrt to the
change, is contentAreaUtils.js.  

The person making the change updated Mozilla's contentAreaUtils.js in xpfe/, but
since Phoenix uses its own version, located in browser/, and because that person
doesn't have authority to change Phoenix code, Phoenix's contentAreaUtils.js was
not updated.  That is why this broke on Phoenix and not on Mozilla.

Phoenix is falling behind the progress in xpfe/ - unless someone keeps Phoenix
up to date, it is only a matter of time before something like this occurs again...
   


> -->Set flag to review by Blake
> 
> (Jeff, I think that you can do this yourself in the future if you 
> have triage powers)

Yes, I am able to set the review flag.  AFAIK, review + super review isn't
required for Phoenix, and in my experience, setting the review flag gets about
as much attention as voting (i.e. none).

Comment 9

15 years ago
*** Bug 188674 has been marked as a duplicate of this bug. ***
Comment on attachment 111274 [details] [diff] [review]
Fix Save Image As and Save Link As...

r=me (and checked in)
Attachment #111274 - Flags: review?(blaker) → review+

Comment 11

15 years ago
Thanks!
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 12

15 years ago
*** Bug 188915 has been marked as a duplicate of this bug. ***

Comment 13

15 years ago
There appears to have been a mix-up while checking in the patch...

Phoenix's contentAreaUtils.js v1.10 (after bryner's check-in):
 persist.saveURI(source, null, null, persistArgs.postData, persistArgs.target);

while in my patch and Mozilla's contentAreaUtils.js:
 persist.saveURI(source, null, null, persistArgs.postData, null,
persistArgs.target);


Note the missing 4th argument in saveURI, after "persistArgs.postData", in
Phoenix's contentAreaUtils.js.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 14

15 years ago
This is broken on Mozilla for MacOSX in 2003010808 build.
I do not understand why it is discussed as if Mozilla is not affected.
The only difference I notice is that in Mozilla, "Saving File" window does not
come up after Save File As dialog is OK'ed.
i'm still seeing this bug as well..

there's two contentAreaUtils.js, one in comm.jar and the other in browser.jar.

the one in comm.jar has been updated, the one in browser hasn't.  when i applied
the patch manually to the contentAreaUtils.js which lives in browser.jar, the
issue was resolved.

i hope this helps.

Comment 16

15 years ago
bug 181374 may be what I have been experiencing with Mozilla for MacOSX.
The problem is dependent on Progress dialog. If Open download manager is
selected for Pref|Downloads, it works.
ok, I fixed it for real now (that's what I get for applying the fix by hand).
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED

Comment 18

15 years ago
*** Bug 189209 has been marked as a duplicate of this bug. ***

Comment 19

15 years ago
*** Bug 189209 has been marked as a duplicate of this bug. ***
Verified
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.