launch.com Media Player & Browser Manipulation

RESOLVED DUPLICATE of bug 131426

Status

RESOLVED DUPLICATE of bug 131426
16 years ago
14 years ago

People

(Reporter: monedora, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)
Build Identifier: 

First of all, you may not consider these as bugs. My apology for being so short 
on describing, cause I'm sure you know what I mean :-)

I see that there's a Windows Media Player plug-in. But when I opened 
www.launch.com and attempted to play a video, the website refused and asked me 
to download the latest WMP. Is the "problem" in the latest build also??

I also want to suggest Mozilla adds a "browser-type manipulation" like Opera 
does. I've heard that several sites "stupidly" refuse to load on non-IE (though 
they mayn't be using ActiveX).

Reproducible: Didn't try

Steps to Reproduce:
<just see the above desciptions>

Comment 1

16 years ago
Confirm with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b)
Gecko/20030110. There is pop-up window with message:

"To use this application with Netscape, you must use a 4.7x version. Download now." 

Comment 2

16 years ago
Reporter, do the following:

- Give build ID
- Try to reproduce the bug
- Don't use one bug report to suggest several things

I consider this bug report as invalid for obvious reasons.

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 131426 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Summary: Media Player & Browser Manipulation → launch.com Media Player & Browser Manipulation
(Reporter)

Comment 4

16 years ago
Arman (reporter) said:
"But when I opened www.launch.com and attempted to play a video, the website 
refused and asked me to download the latest WMP."

Ruslan then replied on comment 1 (http://bugzilla.mozilla.org/show_bug.cgi?
id=188691#c1).

Thanks Ruslan. I'm sorry. The request to download the latest WMP is when I use 
Opera. I was testing both browsers and got mixed-up. Sorry.
I'm just adding a little that the complete message is:
"To use this application with Netscape, you must use a 4.7x version. <a 
href="http://wp.netscape.com/download/archive/client_archive47x.html">Download 
now</a>." This happens after you click on a video to stream.

--------------------
To address Benedikt:
It's Mozilla 1.1b >> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) 
Gecko/20020721.
But from Ruslan comment, I think it happens also on his browser.

I just tried to reproduce it and the same happened.

Sorry for the last thing. As I stated earlier, this may or may not be a bug. 
In addition, when I suggested adding browser manipulation feature to Mozilla, 
of course this cannot be called a bug. I don't know where to post suggestion, 
so I posted here.

-------------------
To address Olivier,
Thank you. It appears that launch.com blocks Mozilla.
I tried rollingstone.com and can play its Windows Media video.
And that supports my suggestion to add "browser camouflage" like Opera does...

--------
Finally, I want to ask 1 more question:
When I click Help | About Plug-ins, there're:
  <b><center>Windows Media Player Plug-in Dynamic Link Library</center></b>
  File name: npdsplay.dll
and
  <b><center>Microsoft® Windows Media Services</center></b>
  File name: npwmsdrm.dll
What's the differences between those 2???
OS: Windows XP → All
Hardware: PC → All

Comment 5

16 years ago
Arman,

see http://plugindoc.mozdev.org/windows.html#WMP

"Scriptability" is the term used to describe the invoking of Plugin methods via
Web-delivered JavaScript, and vice-versa — the Plugin's ability to access the
DOM and invoke client JavaScript methods. 

This is supported by WMP on NS4.x, not on Moz/NS7 because the API has changed.
(Reporter)

Comment 6

16 years ago
Thanks so much for the info. However, you should've addressed this to bug 
#121832, since I asked the question there.

BTW, you instead forgot to answer my real question in this report (see the 
last lines of comment #4).

Comment 7

16 years ago
I guess the first DLL handles the display, the other one the DRM (digital rights
management) stuff.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.