yahoo.com - cannot use radio or video services

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
P1
major
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: Jeremiah Nelson, Unassigned)

Tracking

({top100, top500})

Details

(Whiteboard: [deny], URL)

Attachments

(2 attachments)

104 bytes, application/octet-stream
Details
104 bytes, application/octet-stream
Details
(Reporter)

Description

17 years ago
visit launch.yahoo.com, click listen to your station now link. expect to hear
good music.. instead get sad message saying netscape 6 is not supported. :(

Updated

17 years ago
Keywords: evang500
Summary: cannot use radio service → yahoo.com - cannot use radio service

Updated

17 years ago
Blocks: 121228

Comment 1

17 years ago
confirmed
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
taking
Assignee: doronr → bclary

Comment 3

17 years ago
I'm in contact w/them. Assigning to me.
Assignee: bclary → susiew

Comment 4

17 years ago
*** Bug 123112 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
*** Bug 138999 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
Note that both dupes refer to http://launch.yahoo.com/musicvideos/ too

Comment 7

17 years ago
*** Bug 138999 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
Robert from bug 121832 says :

"I did get a different responce from what the other peson did.
I got a new window saying you need to upgrade your version of netscape
navigator. Not a window that says it does not support Netscape 6."

for the musicvideos/ section.

Comment 9

16 years ago
*** Bug 142352 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
modifying summary
Summary: yahoo.com - cannot use radio service → yahoo.com - cannot use radio or video services

Comment 11

16 years ago
This is also the case for the Yahoo News! site dependent on mediaframe.yahoo.com

Symptoms: when you view this page, it can display the windows media logo and
"opening" and then the frame disappears and you are back at the Yahoo News!
site. If this is a seperate bug, please contact me (mozilla@paperlessconscience.com)
Sam

Comment 12

16 years ago
Sam, please open a new bug for whatever you're talking about.

This bug has to do with the fact that launch.yahoo.com does not support Gecko
due to lack of Windows Media Player scriptability in the product, not related to
any other technical problem. Thanks.
Status: NEW → ASSIGNED

Comment 13

16 years ago
Confirmed. I reset Mozilla's UA string = "Mozilla/4.0 (compatible; MSIE 5.5;
Windows 98)" and was able to proceed beyond the check for NS6. It correctly was
able to open the "test" I-HEAR-IT song but could not operate correctly once it
reached the actual LaunchPlayer screen. Checking the Javascript console reveals:

Error: mPlayerObj has no properties
Source File:
http://launchcast.launch.yahoo.com/radio/player/hit_title.asp?clientID=1&userID=4310840&isMember=1&memberName=ssheth&pr=&browserType=Microsoft&browserVersion=5.5&browserPlatform=Windows%209x&clientStationID=0&p=0&m=0&d=0&stationName=You&volume=50&linkTarget=LaunchRadioTarget&hostName=launchcast.launch.yahoo.com&targetServer=http://launch.yahoo.com&env=&tf=0&sf=1&af=&bandwidth=96&format=1&appmode=
Line: 345

Comment 14

16 years ago
http://news.com.com/2100-1023-939405.html?tag=fd_top
radio dead but launch still alive
OS: Windows XP → All
Priority: -- → P1
Hardware: PC → All
Whiteboard: [deny]
*** Bug 159472 has been marked as a duplicate of this bug. ***

Comment 16

16 years ago
I am removing CC due to spam concerns.. although this may not be directly due to
bugzilla as I have put my e-mail directly on the comments page. I will then
disable mozilla@paperlessconscience.com. If any admins exist who can edit
comments, this one is for you. Sorry for being off-topic.

Comment 17

16 years ago
This bug still exists in Win98 1.3 alpha. It gives the message, "Sorry, we do
not support Netscape version 6." 

Comment 18

16 years ago
For simplicity I will mark this WON'T FIX.
Until Windows Media Player supports scriptability on Gecko browsers this will
not be fixed as far as I know. It has nothing to do with your Mozilla version.
Please email me directly if you have any questions.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 19

16 years ago
wmp9 still isn't scriptable, however, why is this bug not dupe of bug 131426 ?

Comment 20

16 years ago
Quote from Susie:
>>For simplicity I will mark this WON'T FIX.
Until Windows Media Player supports scriptability on Gecko browsers this will
not be fixed as far as I know. It has nothing to do with your Mozilla version.
Please email me directly if you have any questions.<<

I do not understand what is "scriptability" (Mozilla has got "Windows Media 
Player Plug-in Dynamic Link Library" and "Microsoft® Windows Media Services" 
plug-ins, anyway).

But I tried opening a streaming Windows Media video on rollingstone.com and it 
worked fine. With Mozilla I got "To use this application with Netscape, you 
must use a 4.7x version. <a 
href="http://wp.netscape.com/download/archive/client_archive47x.html">Download 
now</a>." message.

So I guess it's not a problem on WMP, but on Yahoo. Any officials having the 
*power* should try contacting Yahoo/Launch for this. They may ignore normal 
folks...


PS:
Susie, How do you assign yourself? In comment 3 you said:
>>I'm in contact w/them. Assigning to me.<<

Comment 21

16 years ago
The *best* way to change their mind is to complain to them as a customer.
Complain, get your mother, father, sister, brother, aunt, uncle, dog, cat and
tweety bird to complain. Customer dissatifaction gets businesses attention.

Comment 22

16 years ago
*** Bug 131426 has been marked as a duplicate of this bug. ***

Comment 23

16 years ago
screw Yahoo, I say.   The site's "Feedback" button just goes to a discussion
forum.  The Help option requires you to create a Yahoo user-account.  I already
dropped their email service because I never ever ever got a real-person response
to any of my tech-support or pre-sales questions (I was trying to decide if it
was worth paying for their 'premium' email service; it wasn't).

Comment 24

16 years ago
Go to:
http://add.yahoo.com/fast/help/us/launch/cgi_feedback?from_url=http%3A%2F%2Fhelp%2Eyahoo%2Ecom%2Fhelp%2Fus%2Flaunch%2Fcast%2Fcast%2D01%2Ehtml

You should submit your comments there. Suprisingly on the page that you get to
the link from the required browser is:

Internet Explorer, Netscape, or AOL browser, all at 4.0 or higher

Yet the responses I got in email from them say Netscape 4.7.

Comment 25

16 years ago
In general Yahoo does support Mozilla but see comment #12 regarding why Launch
doesn't work. But it's still good for them to hear from customers so thanks.

Comment 26

16 years ago
Probably should always mention Netscape 7 doesn't work and not Mozilla as it
carries more weight and a "they're a major player, so we should support Netscape
but not this Mozilla thing" (even if they are essentially the same thing) IMHO.
*** Bug 204043 has been marked as a duplicate of this bug. ***

Comment 28

15 years ago
*** Bug 207135 has been marked as a duplicate of this bug. ***

Comment 29

15 years ago
*** Bug 214092 has been marked as a duplicate of this bug. ***

Comment 30

15 years ago
*** Bug 225403 has been marked as a duplicate of this bug. ***

Comment 31

15 years ago
*** Bug 238933 has been marked as a duplicate of this bug. ***

Comment 32

14 years ago
*** Bug 192413 has been marked as a duplicate of this bug. ***

Comment 33

14 years ago
*** Bug 228427 has been marked as a duplicate of this bug. ***

Comment 34

14 years ago
*** Bug 248770 has been marked as a duplicate of this bug. ***

Comment 35

14 years ago
*** Bug 252036 has been marked as a duplicate of this bug. ***

Comment 36

14 years ago
I don't know if this bug should be WONTFIX anymore, because of two bugs bringing
WMP scripting into Mozilla (bug 215823) and Firefox (bug 247980).

Since the scripting is definately going into Firefox, maybe this bug should be
made dependent upon it and reopened once scripting goes in?

Comment 37

14 years ago
*** Bug 252551 has been marked as a duplicate of this bug. ***
It's not enough to enable ActiveX scriptability for WMP, sites need to be
evangelized not to user-agent- or object-detect against Mozilla.  That seems
unlikely to happen, especially if this evang bug remains WONTFIXed since 2002.

/be

Comment 39

14 years ago
Lets see if we can make any progress on this. Lots has changed since '02.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 40

14 years ago
-> default owner.
Assignee: susiew → english-us
Status: REOPENED → NEW
QA Contact: zach → english-us

Comment 41

14 years ago
Note that http://launch.yahoo.com/musicvideos/lists/top.asp uses NS7.1's ActiveX
support. 
*** Bug 246501 has been marked as a duplicate of this bug. ***
*** Bug 252558 has been marked as a duplicate of this bug. ***

Comment 44

14 years ago
*** Bug 260351 has been marked as a duplicate of this bug. ***

Comment 45

14 years ago
*** Bug 260760 has been marked as a duplicate of this bug. ***

Comment 46

14 years ago
*** Bug 262204 has been marked as a duplicate of this bug. ***
*** Bug 262703 has been marked as a duplicate of this bug. ***
*** Bug 256307 has been marked as a duplicate of this bug. ***

Comment 49

14 years ago
Current state of visiting video pages at launch.com:
"To use this application with Netscape, you must use a 4.7x or 7.1 version.
Download now.

Please use the following error code when writing to Yahoo! Help. (Error Code: 12)"

And the link goes to "hhttp://channels.netscape.com/ns/browsers/download.jsp"
Note the extra H.

Incorrect assumptions
a) this browser is netscape - should either not assume netscape, or correctly
identify mozilla/firefox
b) (implied) this browser is not advanced enough
*** Bug 267545 has been marked as a duplicate of this bug. ***
*** Bug 262910 has been marked as a duplicate of this bug. ***

Comment 52

14 years ago
*** Bug 276820 has been marked as a duplicate of this bug. ***
*** Bug 276864 has been marked as a duplicate of this bug. ***
*** Bug 277812 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Keywords: top500

Updated

14 years ago
Keywords: top100

Comment 55

14 years ago
*** Bug 277325 has been marked as a duplicate of this bug. ***

Comment 56

14 years ago
BC says evang500 is dead.
Keywords: evang500

Comment 57

14 years ago
i cant use launch by yahoo and view videos and radio i need or want 

Comment 58

14 years ago
(In reply to comment #57)
> i cant use launch by yahoo and view videos and radio i need or want 

When trying to use Yahoo! LaunchCast in Firefox (http://launch.yahoo.com/),
clicking on the "Listen" button in the Radio section titled "Listen to your
station now!", the LaunchCast player window opens with the following error:

***
Error

Sorry, we do not support Netscape on the
Windows platform.

	"Error Code: 25 - 0"
***

I e-mailed Yahoo about this on Jan. 28, 2005, they responded the next day with:
"Hello, 

Thank you for writing to Yahoo! Launch.

LAUNCHcast requires the following in order to properly stream media 
content:

PC 

* Windows 95, 98, ME, NT 4.0, 2000 Professional, XP Home, or 
Professional
* Pentium II, 233MHz or faster
* at least 64MB RAM
* Internet Explorer 5.0 or higher
* Windows Media Player 6.4 or higher
* Macromedia Flash 4.0 or higher


Macintosh

* Mac OS 8.5 or higher
* 200MHz PowerPC (iMac OK)
* at least 64MB RAM
* Netscape 4.5 - 4.79
* Windows Media Player 7.01 or higher
* Macromedia Flash 4.0 or higher

Thank you again for contacting Yahoo! Customer Care.

Regards,

Raul

Yahoo! Customer Care"

Comment 59

14 years ago
There is nothing more we can do on our side regarding this. The only options you
have are a) complain to Yahoo! b) use another service. Sorry.
*** Bug 280468 has been marked as a duplicate of this bug. ***

Comment 61

14 years ago
*** Bug 282666 has been marked as a duplicate of this bug. ***

Comment 62

14 years ago
*** Bug 280107 has been marked as a duplicate of this bug. ***

Comment 63

14 years ago
*** Bug 276922 has been marked as a duplicate of this bug. ***

Comment 64

14 years ago
*** Bug 282347 has been marked as a duplicate of this bug. ***

Comment 65

14 years ago
*** Bug 286767 has been marked as a duplicate of this bug. ***
*** Bug 287937 has been marked as a duplicate of this bug. ***

Comment 67

14 years ago
*** Bug 289648 has been marked as a duplicate of this bug. ***

Comment 68

13 years ago
*** Bug 290008 has been marked as a duplicate of this bug. ***

Comment 69

13 years ago
*** Bug 290008 has been marked as a duplicate of this bug. ***

Comment 70

13 years ago
Current problem seems to be:

Error: formElements.elements has no properties
Source File: http://launch.yahoo.com/launchcast/setup.asp
Line: 607

On their main select artists preference screen.

Comment 71

13 years ago
For those interested, a workaround to get launch.yahoo content without using IE.
http://www.osnews.com/story.php?news_id=10609

Comment 72

13 years ago
*** Bug 301461 has been marked as a duplicate of this bug. ***
*** Bug 301461 has been marked as a duplicate of this bug. ***

Comment 74

13 years ago
Re: comment 70, the javascript elements error is bug 207161, which is
independent from this bug.
Severity: normal → major

Comment 75

13 years ago
BTW, here's the latest reply from Yahoo Feedback:
http://add.yahoo.com/fast/help/us/launch/cgi_feedback


Hello, 

Thank you for writing to Yahoo! Music.

Unfortunately LAUNCHcast is not currently compatible with the Mozilla, Firefox,
Safari and Netscape 6-7 browsers.  At this time there is no estimated date as to
when this service may be available using these applications.

However, LAUNCHcast requires the following in order to properly stream media
content:

PC 

* Windows 95, 98, ME, NT 4.0, 2000 Professional, XP Home, or Professional
* Pentium II, 233MHz or faster
* at least 64MB RAM
* Internet Explorer 5.0 or higher
* Windows Media Player 6.4 or higher
* Macromedia Flash 4.0 or higher

Macintosh

* Mac OS 8.5 or higher
* 200MHz PowerPC (iMac OK)
* at least 64MB RAM
* Netscape 4.5 - 4.79
* Windows Media Player 7.01 or higher
* Macromedia Flash 4.0 or higher

Thank you again for contacting Yahoo! Customer Care.

*****

Everyone who wants this bug fixed needs to drive a major letter-writing campaign
to Yahoo Feedback and change their mind.
*** Bug 304097 has been marked as a duplicate of this bug. ***
*** Bug 304628 has been marked as a duplicate of this bug. ***

Comment 78

13 years ago
(In reply to comment #77)
> *** Bug 304628 has been marked as a duplicate of this bug. ***

As Yahoo will not fix this bug in near future. I have a workaround
or call it an other way to hear digital music via Yahoo LaunchCast.
I would like to share the following solution with you all.

Instead of launching Yahoo Launchcast via (within) FireFox window.
Launch Yahoo Messenger and then launch Yahoo LaunchCast within YM.

Happy listning.
mjawaid1022@msn.com
*** Bug 309825 has been marked as a duplicate of this bug. ***

Comment 80

13 years ago
(In reply to comment #0)
> visit launch.yahoo.com, click listen to your station now link. expect to hear
> good music.. instead get sad message saying netscape 6 is not supported. :(

It happened to me to.

Comment 81

13 years ago
Attempting to launch a music video in SeaMonkey on Linux or OS/2 or Firefox on Linux brings up error page saying "To use this application with Netscape, you must use version 7.1 or above." It also says to use error code 12 if writing to Yahoo for help.
*** Bug 357447 has been marked as a duplicate of this bug. ***

Comment 83

11 years ago
Created attachment 265205 [details]
Yahoo Radio wont work

Comment 84

11 years ago
Created attachment 265206 [details]
Yahoo Radio wont work

Comment 85

10 years ago
Yahoo Videos now work fine in FF 3.0 on Windows
http://new.music.yahoo.com/videos/

Launchcast still reports
Error 31
Sorry, we do not support the Firefox browser at this time. Click here for a list of supported browsers.

Comment 86

10 years ago
I am not asking Yahoo to support the Firefox browser. I am asking Yahoo to write standards-compliant code, instead of coding to IE, which is /not/ standards compliant.

Comment 87

9 years ago
works fine for me

Comment 88

9 years ago
I'm resolving this FIXED based on comment 87 and my own experiences over there. I can't really tell what, if anything, is still broken about the original report, but I do know that keeping a six-year-old bug with all these dupes open for it is probably not useful.

As far as I can tell, the latest STR *should* be something like this:

1) Go to Yahoo.com.
2) Click "Music" in the nav bar (currently on the left-hand side of the page most of the way down). That takes you to http://new.music.yahoo.com/ .
3) Mouse over the "Radio" tab at the top and click "Radio Station Guide".
4) On the left side of the resulting page, you'll see some text:

"Radio on Yahoo! Music is all new!

Now you can listen to over 250 radio stations from any browser on both PC and Mac."

Click the "Start Listening" button and you get the following URL in a popup window:

http://player.play.it/player/yahooplayer.html?v=4.7.124&ur=1&us=1&id=

That works just fine in a Camino nightly, and has for ages (it's Flash-based).

If anyone still has issues with this, file a new bug.
Status: NEW → RESOLVED
Last Resolved: 16 years ago9 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.