Closed Bug 1890632 Opened 3 months ago Closed 2 months ago

Cannot post a NNTP message to a newsgroup

Categories

(Thunderbird :: Mail Window Front End, defect)

defect

Tracking

(thunderbird_esr115 unaffected, thunderbird125 unaffected)

RESOLVED FIXED
126 Branch
Tracking Status
thunderbird_esr115 --- unaffected
thunderbird125 --- unaffected

People

(Reporter: infofrommozilla, Assigned: mkmelin)

References

Details

(Keywords: regression)

Attachments

(2 files)

Daily claims, "No recipients were specified. Please enter a recipient or newsgroup..."
However, a group has been entered.
With an additional e-mail address in the To: the message then goes out.

Error log:

GenericSendMessage FAILED: [Exception... "compose-send-message prevented"  nsresult: "0x80004004 (NS_ERROR_ABORT)"  location: "JS frame :: chrome://messenger/content/messengercompose/MsgComposeCommands.js :: CompleteGenericSendMessage :: line 6376"  data: no] MsgComposeCommands.js:6428:13
NS_ERROR_ABORT: compose-send-message prevented
    CompleteGenericSendMessage chrome://messenger/content/messengercompose/MsgComposeCommands.js:6376
    GenericSendMessage chrome://messenger/content/messengercompose/MsgComposeCommands.js:6336
    SendMessage chrome://messenger/content/messengercompose/MsgComposeCommands.js:6948
    doCommand chrome://messenger/content/messengercompose/MsgComposeCommands.js:1063
    doCommand chrome://messenger/content/messengercompose/MsgComposeCommands.js:1241
    goDoCommand chrome://messenger/content/globalOverlay.js:99
    oncommand chrome://messenger/content/messengercompose/messengercompose.xhtml:1
MsgComposeCommands.js:6339:13

I suspect the 2nd patch from Bug 1886132 (Attachment #9391968 [details] D205038) is missing.

BuildID=20240404102537 was still okay.

Summary: Cannot post a NNTP Message to an Newsgroup → Cannot post a NNTP Message to a Newsgroup
Summary: Cannot post a NNTP Message to a Newsgroup → Cannot post a NNTP message to a newsgroup

(In reply to Alfred Peters [:infofrommozilla] from comment #0)

Created attachment 9395854 [details]
Screenshot 2024-04-09 203645.png

Daily claims, "No recipients were specified. Please enter a recipient or newsgroup..."
However, a group has been entered.
With an additional e-mail address in the To: the message then goes out.

Error log:

GenericSendMessage FAILED: [Exception... "compose-send-message prevented"  nsresult: "0x80004004 (NS_ERROR_ABORT)"  location: "JS frame :: chrome://messenger/content/messengercompose/MsgComposeCommands.js :: CompleteGenericSendMessage :: line 6376"  data: no] MsgComposeCommands.js:6428:13
NS_ERROR_ABORT: compose-send-message prevented
    CompleteGenericSendMessage chrome://messenger/content/messengercompose/MsgComposeCommands.js:6376
    GenericSendMessage chrome://messenger/content/messengercompose/MsgComposeCommands.js:6336
    SendMessage chrome://messenger/content/messengercompose/MsgComposeCommands.js:6948
    doCommand chrome://messenger/content/messengercompose/MsgComposeCommands.js:1063
    doCommand chrome://messenger/content/messengercompose/MsgComposeCommands.js:1241
    goDoCommand chrome://messenger/content/globalOverlay.js:99
    oncommand chrome://messenger/content/messengercompose/messengercompose.xhtml:1
MsgComposeCommands.js:6339:13

I cannot reproduce this in a Daily build with all the patches up to 2024-04-08 22:08 +0000. Do you use message encryption in your Daily profile? This push from bug 1814893 may have some connection to the shown exception, but that's just a hunch. Maybe Magnus could take a quick look.

I suspect the 2nd patch from Bug 1886132 (Attachment #9391968 [details] D205038) is missing.

I integrated this second patch into the revision that has landed.

Flags: needinfo?(mkmelin+mozilla)
See Also: → 1814893

Thanks, the newsgroup check should not have been removed. Or well, it should, but more...

Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Flags: needinfo?(mkmelin+mozilla)

We don't support encrypting to newsgroups. For other messages, you cannot send before
recipients have been set: the whole check is therefore pointless.

A lot of other things to clean up here as well... e.g. aliasing of functions of members
is certainly a bit unusual, and splitRecipients does not have a third arguments since many years,
but I guess it wasn't noticed due to the above...

Target Milestone: --- → 126 Branch

Pushed by john@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/6d4706f66fc9
Cannot post a NNTP message to a newsgroup. r=kaie

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: