Closed Bug 1886132 Opened 3 months ago Closed 3 months ago

news: message URIs do not work anymore.

Categories

(Thunderbird :: Mail Window Front End, defect)

Thunderbird 115
defect

Tracking

(thunderbird_esr115 affected)

RESOLVED FIXED
126 Branch
Tracking Status
thunderbird_esr115 --- affected

People

(Reporter: welpy-cw, Assigned: welpy-cw)

References

(Blocks 1 open bug, Regression, )

Details

(Keywords: regression)

Attachments

(1 file, 2 obsolete files)

Steps to reproduce:

  1. Create a message that contains a news: URI such as
    news://news.eternal-september.org/u9bk2v$h4v$1@nnrp.usenet.blueworldhosting.com.
    Save it as draft and open it in the message pane.
  2. Click the link.

Alternatively, start Thunderbird from the command line with the news: URI as argument.

Expected result:

A message window opens into which the message identified by the message-id is loaded from the server into.

Actual result:

Just a blank message window opens. Error console shows

Uncaught TypeError: gMessage is null
    displayMessage chrome://messenger/content/aboutMessage.js:171
    actuallyLoadMessage chrome://messenger/content/messageWindow.js:173
aboutMessage.js:171:3
Assignee: nobody → h.w.forms
Status: NEW → ASSIGNED
  • Enable opening news: URIs that do not specify a host by using the first NNTP server found.
  • Open newsgroups identified by a URI directly without opening an empty message window.

Depends on D205037

Blocks: 108948
See Also: → 617287, 108877, 1785790
Summary: news: URIs do not work anymore. → news: message URIs do not work anymore.
Attachment #9391967 - Attachment is obsolete: true
Version: unspecified → Thunderbird 115

I have already tested the two patches. I already like it very much.
However, I have noticed two small things:

  1. The link should be percent-decoded before processing.
    <news://news.solani.org:119/871q9ajpqx.fsf_-@usenet.ankman.de> works
    <news://news.solani.org:119/871q9ajpqx.fsf
    -_%40usenet.ankman.de> does not

  2. The context menu does not match the link type.

(In reply to Alfred Peters [:infofrommozilla] from comment #4)

I have already tested the two patches. I already like it very much.

Thank you for your valuable feedback.

However, I have noticed two small things:

  1. The link should be percent-decoded before processing.
    <news://news.solani.org:119/871q9ajpqx.fsf_-@usenet.ankman.de> works
    <news://news.solani.org:119/871q9ajpqx.fsf
    -_%40usenet.ankman.de> does not

Good catch, this should work now.

  1. The context menu does not match the link type.

Yeah, as in many other cases in Thunderbird, the default action is not represented in the context menu. Maybe something for another bug?

(In reply to Hartmut Welpmann [:welpy-cw] from comment #5)

Good catch, this should work now.

Yes it works now.

Thank.

See Also: → 745856
Attachment #9391966 - Attachment description: Bug 1886132 - Restore functionality to open news: URIs. r=mkmelin → Bug 1886132 - Restore and improve functionality to open 'news' URIs. r=mkmelin
Attachment #9391968 - Attachment is obsolete: true
Target Milestone: --- → 126 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/5dd5a6026384
Restore and improve functionality to open 'news' URIs. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Duplicate of this bug: 745856
See Also: 745856
Duplicate of this bug: 108877
See Also: 1088771756126
See Also: → 1890632
See Also: → 167991
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: