Closed Bug 1893793 Opened 1 month ago Closed 17 days ago

Message list may be unsorted in unified folder after changing to unthreaded view

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 115
defect

Tracking

(thunderbird_esr115 wontfix)

RESOLVED FIXED
127 Branch
Tracking Status
thunderbird_esr115 --- wontfix

People

(Reporter: welpy-cw, Assigned: welpy-cw)

References

Details

Attachments

(1 file)

Steps to reproduce:

  1. Create a new saved search covering at least two folders.
  2. Select "Sort by" -> "Unthreaded".

Expected result:
The message list appears unthreaded and sorted by the current sort order.

Actual result:
The message list appears unthreaded and unsorted.

As soon as another sort order is chosen in that saved search the bug seems to be gone, so apparently a set secondary sort makes a difference:

Setting the view flags issues a resort in DBViewWrapper which isn't performed by nsMsgDBView if a secondary sort isn't set yet. This is only visible when changing to unthreaded, since rebuilding the view threaded or grouped automatically ensures the right order. So the resort invoked by DBViewWrapper isn't only unnecessary in theses case, it also leads to rebuilding the view for a second time.

Resorting the messages is only necessary when changing from threaded or grouped to unthreaded.

Assignee: nobody → h.w.forms
Status: NEW → ASSIGNED
See Also: → 1860023
Depends on: 1894896, 1895097
Attachment #9398989 - Attachment description: Bug 1893793 - Fix setting view flags for cross-folder search views. r=#thunderbird-reviewers → Bug 1893793 - Fix setting view flags for cross-folder/synthetic search views. r=#thunderbird-reviewers

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/f1893dbe22c4
Fix setting view flags for cross-folder/synthetic search views. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 17 days ago
Resolution: --- → FIXED
Target Milestone: --- → 128 Branch
Target Milestone: 128 Branch → 127 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: