Closed Bug 189654 Opened 17 years ago Closed 12 years ago

Ctrl+Shift+C does not work if ICQ is installed

Categories

(SeaMonkey :: MailNews: Message Display, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: bamm, Unassigned)

Details

Pressing Ctrl+Shift+C to mark all messages as read does not work if ICQ is
installed and running in the tray, even if the Mozilla MailNews window is the
currently active window (I even tried clicking on the MailNews window first to
make sure it is in focus).

Instead, the ICQ email accounts preferences window is launched. I see that ICQ
also uses this combination, but I expect that if Mozilla is in focus, then it
should have priority in receiving keyboard presses.
It's a known issue that ICQ might steal keyboard bindings from Mozilla, though I
am unable to find something about this in Bugzilla. Maybe someone else does?
Related: Bug 66681 (i did a search on the MailNews Product with Boolean Chart
"Comment"->"contains ony of the strings"->"ICQ")
you can configure icq not to use ctrl-shift-c.

*** This bug has been marked as a duplicate of 66681 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
This bug is a request for mailnews to prevent other applications from steal its
keyboard bindings. It is not a request to change any of the shortcuts. Reopening.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Product: Browser → Seamonkey
Assignee: sspitzer → mail
Status: REOPENED → NEW
(In reply to comment #4)
> This bug is a request for mailnews to prevent other applications from steal its
> keyboard bindings. It is not a request to change any of the shortcuts. Reopening.

Karsten is that realistic, i.e. possible?  I wouldn't think so.  invalid?
QA Contact: laurel
We can't hinder the OS(!) to _not_ pass us the key combinations we need, and it's extremely annoying if programs like ICQ grab those keys. You should redefine your global hotkeys to something sane...
Status: NEW → RESOLVED
Closed: 17 years ago12 years ago
Resolution: --- → INVALID
No longer blocks: tb-keyboard-tracker
You need to log in before you can comment on or make changes to this bug.