Closed Bug 1897214 Opened 1 month ago Closed 1 month ago

mach build fails with unable to rename ChannelPrefs.framework

Categories

(Thunderbird :: Build Config, defect)

x86_64
macOS
defect

Tracking

(thunderbird_esr115 wontfix)

RESOLVED FIXED
128 Branch
Tracking Status
thunderbird_esr115 --- wontfix

People

(Reporter: clokep, Assigned: rjl)

References

Details

Attachments

(1 file)

During the second time I run mach build I get the following error:

mv: rename ../../../dist/Thunderbird Daily.app/Contents/Resources/ChannelPrefs.framework to ../../../dist/Thunderbird Daily.app/Contents/Frameworks/ChannelPrefs.framework: Directory not empty

I can rm the file (rm -r <objdir>/dist/Thunderbird\ Daily.app/Contents/Frameworks/ChannelPrefs.framework) and re-run and it works fine, but this is quite annoying.

rjl suggested this might be a regression from the new updater.

I'm able to reproduce. It's likely happening when cross-compiling as well, but CI always does a clobber build so it's not happening there.

Need to port bug 1882228.

Assignee: nobody → rob
Status: NEW → ASSIGNED
See Also: → 1882228

Pushed by alessandro@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/b34bbcd9fd15
Port bug 1882228: Prevent errors during incremental macOS build due to directories not being empty. r=clokep,arschmitz

Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 128 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: