Closed Bug 1902611 Opened 1 month ago Closed 1 month ago

Corrupt chat buddy list breaks account manager

Categories

(Thunderbird :: Instant Messaging, defect)

Thunderbird 127
Desktop
All
defect

Tracking

(thunderbird128? fixed, thunderbird129 fixed)

RESOLVED FIXED
129 Branch
Tracking Status
thunderbird128 ? fixed
thunderbird129 --- fixed

People

(Reporter: freaktechnik, Assigned: freaktechnik)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

STR:

  • Have a corrupted chat buddy list
  • Open the account manager

Expected result: all accounts are displayed, and actions like removing accounts works

Actual result: Chat accounts are completely broken, and can't be removed.

Also impacts about:support.

Target Milestone: --- → 129 Branch
Blocks: tb128found

Pushed by alessandro@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/e00bafb28c98
Improve resiliency with corrupted chat buddy list. r=vineet

Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED

Comment on attachment 9407495 [details]
Bug 1902611 - Improve resiliency with corrupted chat buddy list. r=#thunderbird-reviewers

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined: Account manager and about:support can break if the chat buddy list becomes corrupted
Testing completed (on c-c, etc.): Tested during review
Risk to taking this patch (and alternatives if risky): Low risk, small changes to add safeguards to make errors less catastrophic in account manager and about:support.

Attachment #9407495 - Flags: approval-comm-beta?

Comment on attachment 9407495 [details]
Bug 1902611 - Improve resiliency with corrupted chat buddy list. r=#thunderbird-reviewers

[Triage Comment]
Approved for beta

Attachment #9407495 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: