Closed Bug 191824 Opened 20 years ago Closed 14 years ago

Allow all day for default event length

Categories

(Calendar :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 304919

People

(Reporter: bruppel1, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030202
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030202

The majority of my events in calandar are all-day affairs (ie: rent due today).
 I think it should be possible to make this the default event length.  Right now
the options in preferences does not allow this.

Reproducible: Always

Steps to Reproduce:
1.go to edit>preferences>calendar

Actual Results:  
default event length box only allows minutes input

Expected Results:  
somehow all day should be allowed.  it might not be a bad idea to stick a full
blown time-chooser widget in there.
This is fixed in the latest XPIs.
If you make a new event all day, the next time you make a new event, it will be
an all day event.
This was done a little while ago.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
well, while it is true that there is a way to make all day the default,
shouldn't this be reflected in the preferences?
This seems to be broken in the June 22 2004 build for thunderbird.  Objections
to me reopening?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I've got some time off for the holidays.  Would there be an objection to me
adding a little switch so that if the input eventlength = 0 or -1, calendar uses
"all day"?  Right now if I put in -1 for my event length, the event dialog
accepts an event that ends before it starts.  I'm not a pro mozilla programmer
but I think I could handle this if I could find the right part of code.
QA Contact: gurganbl → general
Blocks: 312073
Depends on: 298102
Assignee: mikeypotter → nobody
Status: REOPENED → NEW
OS: Windows XP → All
Hardware: PC → All
Summary: should allow all day for default event length → Allow all day for default event length
Flags: wanted-calendar0.9?
When I set a new event to "all day event," it does not default to "all day event" for the next event.  I have to manually set it to "all day event" every time, which is a pain.  I wish there was a way to set "all day event" to default.
Agreed. I also voted for this enhancement but it lies dormant.
(In reply to comment #1)
> This is fixed in the latest XPIs.
> If you make a new event all day, the next time you make a new event, it will be
> an all day event.
> This was done a little while ago.

I wish this was the case, but it is not true of Sunbird 0.8
Flags: wanted-calendar0.9? → wanted-calendar0.9-
No longer blocks: 312073
Status: NEW → RESOLVED
Closed: 20 years ago14 years ago
No longer depends on: 298102
Resolution: --- → DUPLICATE
Duplicate of bug: 304919
You need to log in before you can comment on or make changes to this bug.