Bookmarks menu shows no bookmarks when no unminimized windows are open

VERIFIED FIXED

Status

SeaMonkey
Bookmarks & History
VERIFIED FIXED
15 years ago
14 years ago

People

(Reporter: Thomas Lewis, Assigned: janv)

Tracking

Trunk
PowerPC
Mac OS X
Bug Flags:
blocking1.4a -
blocking1.4b -
blocking1.4 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

2.86 KB, patch
Pierre Chanial
: review+
jag (Peter Annema)
: superreview+
(not reading, please use seth@sspitzer.org instead)
: approval1.4b+
Details | Diff | Splinter Review
(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2.1) Gecko/20021130

If the appearance preferences are set to not open navigator on startup then the
bookmarks menu will be empty below "Manage Bookmarks..." until the first
navigator window is opened.  Since "Manage bookmarks..." is able to access
bookmarks they should be displayed in Bookmarks menu as well. 

Reproducible: Always

Steps to Reproduce:
1. Set "When mozilla starts up, open:" Navigator to off.
2. Quit and restart Mozilla
3. Look at Bookmarks menu: It only displays up to "Manage Bookmarks..."


Actual Results:  
Bookmarks don't display in bookmarks menu.

Expected Results:  
Bookmarks are displayed below "Manage Bookmarks..."
(Reporter)

Comment 1

15 years ago
"When Mozilla starts up, open: Mail & Newsgroups" in the Appearance preferences
must be set to On in order for the problem to appear.  Once the Mail window is
closed then the bookmarks menu is available, but empty.

Comment 2

15 years ago
Confirmed using FizzillaMach/2003022103.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Bookmarks menu empty if preferences set to not open navigator on startup → Bookmarks menu empty if preferences set to not open Navigator on start-up

Comment 3

15 years ago
*** Bug 199409 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Flags: blocking1.4a?
Summary: Bookmarks menu empty if preferences set to not open Navigator on start-up → Bookmarks menu shows no bookmarks when no unminimized windows are open

Updated

15 years ago
Flags: blocking1.4a? → blocking1.4a-

Updated

15 years ago
QA Contact: kasumi → petersen

Comment 4

15 years ago
*** Bug 200414 has been marked as a duplicate of this bug. ***
->jan.

chris, do you think this is a dup of bug 199178?
Assignee: ben → varga

Updated

15 years ago
Flags: blocking1.4b?
(Assignee)

Comment 6

15 years ago
I don't think it's related to bug 199178.
The problem here is that bookmarks are loaded only by calling readBookmarks()
when a new navigator window is opened.

Comment 7

15 years ago
*** Bug 201113 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Flags: blocking1.4b?
Flags: blocking1.4b-
Flags: blocking1.4+
(Assignee)

Comment 8

15 years ago
Created attachment 122043 [details] [diff] [review]
patch
(Assignee)

Updated

15 years ago
Attachment #122043 - Flags: superreview?(jaggernaut)
Attachment #122043 - Flags: review?(chanial)

Updated

15 years ago
Attachment #122043 - Flags: review?(chanial) → review+

Comment 9

15 years ago
Comment on attachment 122043 [details] [diff] [review]
patch

Could you indent the next lines of |disabledItems| to match up with the array
like it did before?

Thanks for adding AddBookmarkAs and AddGroupmarkAs.

sr=jag with my nit fixed.

/me wonders if we could move the hiddenWindow code out into hiddenWindow.js

Updated

15 years ago
Attachment #122043 - Flags: superreview?(jaggernaut)
Attachment #122043 - Flags: superreview+
Attachment #122043 - Flags: approval1.4b?
Comment on attachment 122043 [details] [diff] [review]
patch

a=sspitzer
Attachment #122043 - Flags: approval1.4b? → approval1.4b+
(Assignee)

Comment 11

15 years ago
checked in
I hope this won't regress Txul on Mac.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 12

15 years ago
Still not working for Mac X on build 2003042908.
(Assignee)

Comment 13

15 years ago
yeah, it doesn't work in that build, the patch has been checked in only few mins ago
*** Bug 200026 has been marked as a duplicate of this bug. ***

Comment 15

15 years ago
Could this have caused bug 204022?

Comment 16

15 years ago
Verified on the 2003-05-02-08 Macho trunk build
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.