Applying for a CVS write access - Philip Zhao

RESOLVED FIXED

Status

mozilla.org
Repository Account Requests
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: philip zhao, Assigned: marcia)

Tracking

(Depends on: 3 bugs)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.2.1) Gecko/20030107
Build Identifier: Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.2.1) Gecko/20030107

I have worked on mozilla for several months most interested in mailnews project.
After being acquainted with mozilla code and the architectures used in mozilla,I
have added some patch whose check-in always needs other's help. 

Now I think I'm familiar with mailnews related code and othe mozilla code which
might affect with my work and all the ordinary rules to write a patch, check-in,
build mozilla and other related processes, and I have produced a good coding
practices. So I need a CVS write access for further work. I list the bugs I
worked on in the past below,some of which need your r&sr.

1. bug 148083 : reviewer: bienvenu, superreviewer: Henry Jia. checked in trunk.
2. bug 120188 : reviewer: Henry Jia, superreviewer:sspitzer. checked in.
sspitzer updated it when check-in.
3. bug 160586 : reviewer: bienvenu, superreviewer: Henry Jia. Wanting for check-in.
4. bug 166603 : sr=?
5. bug 154778 : s=?&sr=?
6. bug 71383 :  s=?&sr=?
7. bug 160291 : s=?&sr=?

The CVS write access will make me more convenient in future work. Thanks.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Assignee)

Comment 1

16 years ago
Philip:  First step is to fill out the form (located at
http://www.mozilla.org/hacking/form.html) and get it back to me.  You will need
a voucher to post in the bug as well as 3 SRs. 
Status: NEW → ASSIGNED
(Reporter)

Comment 2

16 years ago
Hi,Marcia Knous,
I've faxed the CVS Contributor Form of mozilla.org to you. Thanks.
-philip

Comment 3

16 years ago
philip did lots of good&hard work for mozilla.
I will vouch him, for sure!

Comment 4

16 years ago
I'll vouch for phillip.
(Assignee)

Comment 5

16 years ago
form received. 

Comment 6

16 years ago
Philip did a good job in his work on Mozilla. He mainly focuses on mailnews.

I can vouch for him.

Comment 7

16 years ago
Your first bug should be bug 148043 instead of 148083.
(Reporter)

Comment 8

16 years ago
Sorry for the type. My first bug is bug 148043. Thanks Anto & David & Henry & all!
(Assignee)

Updated

16 years ago
Summary: Applying for a CVS write access → Applying for a CVS write access - Philip Zhao
listing all philips bugs as depending on this bug (so we can easily look at them
all)

he's doing good work, and he understands the checkin policy

just two more sr's to go.

voucher=henry.jia
sr=sspitzer
sr=?
sr=?
(Reporter)

Comment 10

16 years ago
Hi, Sspitzer and Knous, Can we see my voucher and SRs like this:

voucher: Antonio Xu ---> comment 3
sr 1   : David bienvenu ---> comment 4
sr 2   : Henry Jia ---> comment 6
sr 3   : sspitzer ---> comment 9

Then I get the CVS write access! Yeh! ^_^ Thankss!!
(Assignee)

Comment 11

16 years ago
Based on bienvenu's comment that he is vouching and the fact that Henry is an
SR, looks like Philip has all three SRs that he needs. Account activated.   
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

16 years ago
Thanks Antonio,David,Henry,sspitzer,Knous & all!
You need to log in before you can comment on or make changes to this bug.