Selecting "Mark As" causes Quick Search not to work on "m" and "r"

RESOLVED FIXED

Status

SeaMonkey
MailNews: Message Display
RESOLVED FIXED
15 years ago
12 years ago

People

(Reporter: Ninoschka Baca, Assigned: stefanh)

Tracking

({fixed1.8})

Trunk
PowerPC
Mac OS X
fixed1.8

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

15 years ago
Trunk build 2003-02-19: Mac 10.2

Overview: You can get into a state where a Quick Search using the letters "m" or
"r" won't work and don't even appear in the Quick Search text box. Instead the
Message menu flashes.

Steps to reproduce:
1. Select a message in the thread pane
2. Select Message|Mark|As Read
3. Type "m" (or "r") in the Quick Search text box

Actual Results: The Message menu flashes and the text you just entered does not
appear in the Quick Search text box therefore you cannot search on items that
include an "m" or an "r".

In Step 2 you can actually choose any item within the Message|Mark and the same
problem will occur (i.e. Thread as Read, All Read, Flag etc...).

Interesting that the letters that are effected also appear in the Message menu
and are the only ones that have accelerators that require a shift (looks lilke
an up arrow)
- Message|New Message has Shift+Ctrl+M 
- Message|Reply to All has Shift+Ctrl+R 

Workaround: Select the Message menu, now "m" and "r" will work.

Expected Results: Quick Search on any letter should perform as expected.
Selecting a menu item should not disable this function.
(Reporter)

Comment 1

15 years ago
Marking nsbeta1.

But I just checked and it was also a problem in Netscape 7.01.

Comment 2

15 years ago
Mail triage team: nsbeta1-
Keywords: nsbeta1 → nsbeta1-
see also bug 195830, where something similar happens with ' and / (for find as
you type) after you view the Edit menu.

i'd say both this and 195830 are blocked by 195979.
Depends on: 195979
Keywords: nsbeta1- → nsbeta1

Comment 4

15 years ago
This problem happens because 'M' and 'R' are used as unmodified menu shortcuts
in the Message->Mark submenu. The menus on Mac always get first crack at events.

Comment 5

15 years ago
Mail triage team: nsbeta1-
Keywords: nsbeta1 → nsbeta1-

Comment 6

15 years ago
This an incredibly frustrating bug and really should be addressed.

Can we at least release note a workaround for Mac users?
Keywords: relnote
should we do the same thing as aaronl did for bug #195830?

see http://bugzilla.mozilla.org/attachment.cgi?id=116833&action=view

or should we wait for bug #195979 to be fixed?
Product: Browser → Seamonkey

Comment 8

13 years ago
I can confirm this with Thunderbird 1.0 Release NL and EN-US.

Typing 'k' in the search box issues 'ignore thread' command. The same happens
with all one key commands.

(Workaround: always use command key modifier. That would also make TB more Aqua
HIG compliant.)

Seems to be very similar to Bug #199019

(please set the severity to major or critical, as this bug really disables the
search box)

Updated

12 years ago
Assignee: sspitzer → mail
(Assignee)

Comment 9

12 years ago
Created attachment 201172 [details] [diff] [review]
Don't display single commandkeys in mac menuitems

I hate this, but i suppose this is the only way of fixing the issue right now. Just remove any single key from its menuitem. The keys will still work, but you won't see them in the menu. mcscott did this for Thunderbird a while ago.
Attachment #201172 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #201172 - Flags: review?(neil.parkwaycc.co.uk)

Comment 10

12 years ago
Comment on attachment 201172 [details] [diff] [review]
Don't display single commandkeys in mac menuitems

Fine, except you missed a bunch of keys; firstly, all six label keys (0-5) and secondly, three captial letters - not Junk, not Scam, show Remote content.
Attachment #201172 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #201172 - Flags: superreview-
Attachment #201172 - Flags: review?(neil.parkwaycc.co.uk)
Attachment #201172 - Flags: review-
(Assignee)

Comment 11

12 years ago
(In reply to comment #10)
> (From update of attachment 201172 [details] [diff] [review] [edit])
> Fine, except you missed a bunch of keys; firstly, all six label keys (0-5)

We don't need to remove  those. Typing those numbers in the search box doesn't trigger the bug.

> and
> secondly, three captial letters - not Junk, not Scam, show Remote content.
>

To trigger the bug with those ones the user needs to enter both "Shift" and the relevant key (j, r, p) in the search box. I thought that was a rare case.

 
(Assignee)

Comment 12

12 years ago
Comment on attachment 201172 [details] [diff] [review]
Don't display single commandkeys in mac menuitems

(In reply to comment #11)
> (In reply to comment #10)
> > (From update of attachment 201172 [details] [diff] [review] [edit] [edit])
> > Fine, except you missed a bunch of keys; firstly, all six label keys (0-5)
> 
> We don't need to remove  those. Typing those numbers in the search box doesn't
> trigger the bug.
We don't even show the keys on mac ;)

Comment 13

12 years ago
Comment on attachment 201172 [details] [diff] [review]
Don't display single commandkeys in mac menuitems

D'oh, I was confusing accesskeys with accelerators :-[
I'm not convinced about the upper case keys though.
Attachment #201172 - Flags: superreview-
Attachment #201172 - Flags: superreview+
Attachment #201172 - Flags: review-
Attachment #201172 - Flags: review+
(Assignee)

Comment 14

12 years ago
Created attachment 203018 [details] [diff] [review]
Remove Shift+key combos in Mark submenu as well

New version that also removes Shift+key in the "Mark" submenu on Mac (per irc discussion with Neil)
Attachment #201172 - Attachment is obsolete: true
Attachment #203018 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #203018 - Flags: review?(neil.parkwaycc.co.uk)

Comment 15

12 years ago
Comment on attachment 203018 [details] [diff] [review]
Remove Shift+key combos in Mark submenu as well

Nit: 8-space indentation is probably wrong for the win version. And if you're going to fix the VK_DELETE indentation, please fix it in the unix version too.
Attachment #203018 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #203018 - Flags: superreview+
Attachment #203018 - Flags: review?(neil.parkwaycc.co.uk)
Attachment #203018 - Flags: review+
(Assignee)

Comment 16

12 years ago
Created attachment 203114 [details] [diff] [review]
Updated version, carrying over flags (checked in on trunk/branch)

Updated version: Fixed indentation in win file (also added one empty line under the delete key section) and VK_DELETE key indentation in unix file. Carrying over flags and asking approval 1.8rc2 for a seamonkey-only change.
Attachment #203018 - Attachment is obsolete: true
Attachment #203114 - Flags: superreview+
Attachment #203114 - Flags: review+
Attachment #203114 - Flags: approval1.8rc2?
(Assignee)

Comment 17

12 years ago
Comment on attachment 203114 [details] [diff] [review]
Updated version, carrying over flags (checked in on trunk/branch)

Low risk, SeaMonkey only...
Attachment #203114 - Flags: approval1.8rc2? → approval1.8.0.1?
(Assignee)

Comment 18

12 years ago
Comment on attachment 203114 [details] [diff] [review]
Updated version, carrying over flags (checked in on trunk/branch)

Checked in on trunk, waiting for branch approval.
Attachment #203114 - Attachment description: Updated version, carrying over flags → Updated version, carrying over flags (checked in on trunk)
(Assignee)

Comment 19

12 years ago
Comment on attachment 203114 [details] [diff] [review]
Updated version, carrying over flags (checked in on trunk/branch)

This works around a long-time standing mac issue, has baked on trunk for a  while...
Attachment #203114 - Flags: approval1.8.0.1? → approval-seamonkey1.0?

Comment 20

12 years ago
Comment on attachment 203114 [details] [diff] [review]
Updated version, carrying over flags (checked in on trunk/branch)

a=me, one more needed...

Updated

12 years ago
Attachment #203114 - Flags: approval-seamonkey1.0? → approval-seamonkey1.0+
I checked the patch in on branch.  Since you didn't mark the bug as fixed, I'm not setting fixed1.8 - you can do that if it is in fact fixed.
(Assignee)

Updated

12 years ago
Attachment #203114 - Attachment description: Updated version, carrying over flags (checked in on trunk) → Updated version, carrying over flags (checked in on trunk/branch)
(Assignee)

Comment 22

12 years ago
I'm going to mark this as fixed. The root problem is not fixed, but Search works as expected now. Once bug 195979 is fixed, we can put the keys back.
Assignee: mail → stefan_h
(Assignee)

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: relnote → fixed1.8
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.