Mac menu items don't update disabled state until they're displayed

RESOLVED WORKSFORME

Status

()

P2
normal
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: aaronlev, Unassigned)

Tracking

Trunk
Future
PowerPC
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2])

(Reporter)

Description

16 years ago
Sometimes a menu item can get activated by it's keystroke, even when the menu
item should be disabled.

To reproduce:
1. Select some text in a web page
2. Click on the edit menu to show it - "Copy" should be enabled
3. Close the edit menu
4. Click in the URL bar to get a caret (collapsed selection)
5. Hit Cmd+C, and notice the edit menu flashes
6. Click on the edit menu to show it, notice the menu item is disabled
7. Click back in the URL bar to get a caret again
8. Hit Cmd+C, and notice the edit menu does not flash this time

This shows that the menu has to be displayed before the disabled state of menu
items takes effect.
need to see how this affects embedded apps, like Camino, once nightly trunk
builds are available.
Keywords: nsbeta1
QA Contact: shrir → sairuh

Comment 2

16 years ago
There won't be any impact on embedders, since they don't use our menu code.

Comment 3

16 years ago
Mail triage team: nsbeta1+/adt3
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt3]

Comment 4

16 years ago
Ummm, Mail triage team: nsbeta1+/adt2
Whiteboard: [adt3] → [adt2]

Comment 5

16 years ago
This bug does seem to affect embedded apps. See bug 195830.

Comment 6

16 years ago
No it doesn't.

Updated

16 years ago
Priority: -- → P2
Target Milestone: --- → Future

Updated

14 years ago
Blocks: 199019
Assignee: sfraser_bugs → nobody
QA Contact: bugzilla

Updated

11 years ago
Blocks: 410164

Comment 7

11 years ago
Comment #0, step 5 now(?) fails for current SM trunk builds like Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b3pre) Gecko/2007121918 SeaMonkey/2.0a1pre => WFM.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.