Crash if I try to select a large amount of (quoted) text using the keyboard

RESOLVED WORKSFORME

Status

MailNews Core
Composition
--
critical
RESOLVED WORKSFORME
15 years ago
4 years ago

People

(Reporter: Antonio M. D'souza, Assigned: Bienvenu)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.3b) Gecko/20030211
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.3b) Gecko/20030211

I have a message with a 134K text file attached, so it is automatically
displayed inline. I hit Reply & the Compose window appears with the entire text
file quoted inline and the cursor ready below all this text. I want to delete
most of the quoted text so I hold down shift & keep hitting pgup to select a
large portion of the text. After I have hit pgup the 14th time, Mozilla crashes. 

Reproducible: Always

Steps to Reproduce:
1. Send yourself a message with a large (>130K) text file attached.
2. Ensure that your MailNews settings will automatically quote the contents of
this text file inline when you reply & place the cursor below the quoted text.
3. Select the message & hit Reply.
4. Hold down shift & keep hitting pgup, trying to select all but the 1st
paragraph of the quoted text.

Actual Results:  
After hitting pgup several (in my case, 14) times, Mozilla should crash. 

Expected Results:  
Mozilla should let me select as much text as I want.

Comment 1

15 years ago
Can you please add a Talkback ID from that crash ?
(Reporter)

Comment 2

15 years ago
There is no talkback build available for Mozilla 1.3b on Redhat 8.0 so I cannot
do this :-(

Comment 3

15 years ago
worksforme with linux trunk 20030226.  are you using an XFT/gtk2 RPM?
Keywords: crash
(Reporter)

Comment 4

15 years ago
Yes (GTK2).

Comment 5

15 years ago
ok, can you attach a stacktrace for the crash from gdb?
(Reporter)

Comment 6

15 years ago
No, I cannot because I do not know how to do this. 
I tried: `gdb mozilla` but gdb said that it was not a binary.
I also tried `gdb /usr/lib/mozilla-1.3b/mozilla-bin` but it complained that it
couldn't find libmozjs.so & refused to run. 

Any suggestions?

Comment 7

15 years ago
% mozilla &
[mozilla starts up]
% gdb _pid_of_mozilla_
(gdb) b exit
(gdb) b abort
(gdb) cont
[make mozilla crash]
(gdb) bt
(Reporter)

Comment 8

15 years ago
Created attachment 115875 [details]
The backtrace requested of me.

BTW, when invoking gdb, it is vital to specify the location ofthe binary as
well, not just the pid.
(Reporter)

Updated

15 years ago
Blocks: 172768
Can you try to get that stack trace while running the browser with the --sync
flag?  That might give a better location for the actual crash.
Blocks: 92033
No longer blocks: 172768

Comment 10

14 years ago
I'm getting a crash or wild behaviour from Mozilla Mail when I try to hit return
in the middle of quoted text (to start a fresh line for my reply to that text).

This has only happened since I downloaded 1.8a2. 1.8a was fine.

(WinXP, Mozilla build ID: 2004052407)
(Assignee)

Comment 11

14 years ago
the crash has been fixed in today's build - now it just doesn't insert a new
blank line :-(
Assignee: ducarroz → bienvenu
Status: UNCONFIRMED → NEW
Ever confirmed: true
Product: MailNews → Core

Comment 12

10 years ago
WFM per comment 11.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.