autocomplete screws up URLs starting with a 't'

RESOLVED DUPLICATE of bug 122862

Status

RESOLVED DUPLICATE of bug 122862
16 years ago
14 years ago

People

(Reporter: szo, Assigned: hewitt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

Suppose you visited a site whose url starts with a 't' (http://tilos.hu), then
you want to go back by using the url bar autocomplete, it works incorrectly:
you enter a 't' and this is what you get: "ttp://tilos.hu/".


Reproducible: Always

Steps to Reproduce:
0. (clear your history)
1. go to http://tilos.hu/
2. go to somewhere else
3. press ctrl+l, press 't'.

Actual Results:  
"ttp://tilos.hu/" was displayed in the url bar.

Expected Results:  
tilos.hu should be displayed, or http://tilos.hu/ should be displayed. Either
case, when I hit enter, I should be taken to somewhere meaningful.

Comment 1

16 years ago
seeing this on Linux too, two day old CVS.
(Another site autocompleted, but same bug - ttp://telenor.no)
OS: Windows 2000 → All

Comment 2

16 years ago
i can't find a dup -> New
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
I'm not sure, if it's really bug. I entered "ttp://themes.mozilla.org" to URL
bar several days before and now, when I was trying to reproduce, history brings
me this broken URL.

I try to reproduce this bug on clear profile with empty history and I'm unable
to reproduce (with 20030308/pre1.3/W2K).

WFM or INVALID.
Summary: autocomplete screws up url's starting with a 't'. → autocomplete screws up URLs starting with a 't'

Comment 4

16 years ago
No, there's a bug here.

Do this to repro:
1: delete all history (in prefs)
2: delete urlbar history (in prefs)
3: restart thr browser to make sure all is gone
4: open a new tab
5: write this in urlbar: http://www.telenor.no 
6: hit enter in urlbar
7: now clear the urlbar with telenor in it and paste in http://http://tilos.hu
8: tilos loads. Then clear the urlbar and type one single t

Result: ttp://www.telenor.no/ will display in urlbar
Write this in the urlbar:

Comment 5

16 years ago
Okay, I'm able to reproduce (2003031408/trunk/W2K), but only with these
Autocomplete preferences setting:
 [x] Autocomplete best ...
 [ ] Show list ...
With "show list" it doesn't "screw up".

(BTW shouldn't be this bug in XP Apps: Autocomplete?)

Comment 6

16 years ago
I have these checked:

Under Navigator/Smart Browsing: Automatically complete... etc
Under the Advanced button:

V Autocomplete best match as you type
V Show list of matching results (and the typo is not in the list btw)
V Match only websites you've type prevously
Component: URL Bar → XP Apps: Autocomplete

Comment 7

16 years ago
*** Bug 202992 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
Bug 202992 is the same bug but for Firebird.

Comment 9

15 years ago
*** Bug 162228 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
"T" is cursed; see http://bugzilla.mozilla.org/show_bug.cgi?id=83205#c19 :)
Seriously: a simple Ctrl-L t <wait> <enter> is enough for me to reproduce this.
I have 
browser.urlbar.autoFill = true
browser.urlbar.clickAtEndSelects = false
browser.tabs.opentabfor.urlbar = true
other urlbar settings are defaults (per about:config)

Comment 11

15 years ago
the bug alsp affects sites beginning with a "p"

Put http://pub.tv2.no/nettavisen/ in the location bar - hit enter
Remove the url there and type a p
Result: It autocompletes to p://pub.tv2.no/nettavisen

Comment 12

15 years ago
I can't reproduce this in 1.6.  Is it now fixed?
(Reporter)

Comment 13

15 years ago
It's still in 1.6 on linux: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040413 Debian/1.6-5

Comment 14

14 years ago
Related to/duplicate of bug 122862?

Updated

14 years ago
Blocks: 266763
Product: Core → Mozilla Application Suite

*** This bug has been marked as a duplicate of 122862 ***
No longer blocks: 266763
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.