Last Comment Bug 198247 - In (Stub-)Installer builds, Download Manager "Del" key is not working (anymore)
: In (Stub-)Installer builds, Download Manager "Del" key is not working (anymore)
Status: VERIFIED FIXED
: fixed1.8, regression
Product: SeaMonkey
Classification: Client Software
Component: Download & File Handling (show other bugs)
: Trunk
: x86 Windows 98
: -- minor with 1 vote (vote)
: seamonkey1.0alpha
Assigned To: Andrew Schultz
:
:
Mentors:
http://lxr.mozilla.org/seamonkey/sour...
: 200663 209158 241748 244354 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-19 09:49 PST by Serge Gautherie (:sgautherie)
Modified: 2005-09-28 13:27 PDT (History)
10 users (show)
csthomas: blocking‑seamonkey1.0b-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch (3.09 KB, patch)
2005-09-18 07:38 PDT, Andrew Schultz
csthomas: review+
dveditz: superreview+
asa: approval1.8b5+
Details | Diff | Splinter Review

Description User image Serge Gautherie (:sgautherie) 2003-03-19 09:49:01 PST
User-Agent:       Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.3) Gecko/20030312

Remembering my bug 166059 description "remove it, by keyboard ou menu button";
I would say that this bug is a _regression_, which happened after v1.1 and
before v1.3. (I would guess nearer to v1.3, but I can't verify it myself.)


Reproducible: Always

Steps to Reproduce:
1. Open any page/file/URL, <about:> for example
2. 'Use Save Page As' on it
3a. The Download Manager opens [assuming you use it]
3b. The saved/downloaded file is highlighted

Actual Results:  
The 'Del' key does not do anything;
while the 'Remove from List' button does work. (== Workaround)


Expected Results:  
'Del' key should do the same job as the 'Remove from List' button.
Comment 1 User image Alexander Opitz 2003-06-04 05:22:32 PDT
@reporter
Can you try a newer build ... does it have the same problem?
Comment 2 User image Serge Gautherie (:sgautherie) 2003-06-04 07:17:08 PDT
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030529]

Bug still there, with v1.4rc1 and on W2K.
Comment 3 User image Jeff D. Hanson 2003-06-06 14:59:38 PDT
WFM:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030604
Comment 4 User image Christian Franke 2003-08-06 05:52:57 PDT
Does not WFM:
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5a) Gecko/20030718

Possibly related: key_copy does not work with patch (attachment 129276 [details] [diff] [review]) from Bug
142798 comment 5.
Comment 5 User image Joe Infla 2003-09-02 12:16:16 PDT
confirming
Comment 6 User image Jo Hermans 2003-12-29 05:16:21 PST
*** Bug 209158 has been marked as a duplicate of this bug. ***
Comment 7 User image Ian Neal 2003-12-29 08:47:23 PST
WFM on WinXP using BuildID 2003122208
I'm using a zipped version rather than an installer version, reporter (Serge),
what sort of version are you using and on which platforms have you tested it?
Same question to Jeff, Christian and Joe.

Comment 8 User image José Jeria 2003-12-29 08:49:49 PST
Was this bug valid before the new Download Manager perhaps?
WFM also, with build 20031226, installer builds (0.8  branch).
Comment 9 User image Joe Infla 2003-12-29 09:03:47 PST
Please note that this bug is in the Browser component, not Firebird.  So yes, it
was before the new Download manager.  The Build ID from the original bug report
says 1.3.  I tested in 1.4 when I confirmed, and again just now in 1.6b.  The
bug exists.
Comment 10 User image Serge Gautherie (:sgautherie) 2003-12-29 11:04:41 PST
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031208] (W98SE)

Bug still there.

Updating:
*(OS) W95 -> W98, as I upgraded since :->

Re comment 7:
Installed from <mozilla-win32-1.6b-installer.exe>.
Comment 11 User image Jo Hermans 2004-04-26 08:36:54 PDT
*** Bug 241748 has been marked as a duplicate of this bug. ***
Comment 12 User image Benedikt Kantus 2004-05-22 09:52:08 PDT
*** Bug 244354 has been marked as a duplicate of this bug. ***
Comment 13 User image Troodon 2004-11-26 19:35:10 PST
Can reproduce with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a5)
Gecko/20041125.
Comment 14 User image neil@parkwaycc.co.uk 2004-11-27 15:42:49 PST
Sorry, I don't see this either in my Linux trunk self-build or my Windows 2000
1.8a5 self-build; they both correctly delete the entry when I press Delete.
Comment 15 User image Serge Gautherie (:sgautherie) 2004-11-28 01:40:46 PST
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.3) Gecko/20040910] (release) (W98SE)
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a5) Gecko/20041122] (release) (W98SE)

Bug still there: tested again with a new profile from each too.

Installed from <mozilla-win32-1.7.3-installer.exe> and
<mozilla-win32-1.8a5-installer.exe>.

Note: (confirming my initial comment)
Using the menu (Alt-R or mouse) works,
'Del' key only has no effect: nothing in JS.C. nor in (Windows) Console.
Comment 16 User image Serge Gautherie (:sgautherie) 2004-11-28 06:15:28 PST
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a5) Gecko/20041122] (release) (W98SE)

Neil:

I tried using VenkMan (with 2 breakpoints in <downloadmanager.js>):
Alt-R works fine; Del seems to be ignored :-/

Then I tried to replace the line which you pointed out by
{{
<key id="key_remove" key="Z" command="cmd_remove"/>
}}
hoping pressing the 'Z' key could work: ignored too.

I'm clueless on how to debug this.
Comment 17 User image Ian Neal 2004-11-28 10:18:54 PST
When you say 'Del' key, which 'Del' key do you mean? The one on the numeric
keypad or the 'Delete' key above the cursor keys?

When you tried 'Z' key did you try 'Shift' and 'z'?
Comment 18 User image neil@parkwaycc.co.uk 2004-11-28 16:20:23 PST
(In reply to comment #17)
>When you tried 'Z' key did you try 'Shift' and 'z'?
Or you might need caps lock and z...
Comment 19 User image Troodon 2004-12-08 02:46:51 PST
Alsro reproduced with Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.7.3)
Gecko/20040910.
Comment 20 User image OstGote! 2005-01-25 02:35:01 PST
*** Bug 200663 has been marked as a duplicate of this bug. ***
Comment 21 User image Troodon 2005-03-18 14:52:52 PST
(In reply to comment #17)
> When you say 'Del' key, which 'Del' key do you mean? The one on the numeric
> keypad or the 'Delete' key above the cursor keys?

For me neither of them works (of course, the one of the num pad with num lock
disabled). I also tried to change the keyboard language to english (I usually
use es-ES) to see if it's related, but it doesn't seem to be as it didn't worked.

Bug still here with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2)
Gecko/20050316.
Comment 22 User image Troodon 2005-09-16 14:53:16 PDT
Still here - Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4)
Gecko/20050910 SeaMonkey/1.0a
Comment 23 User image Troodon 2005-09-16 14:58:07 PDT
Sorry for the previous comment (and the spam), it was incorrect and incomplete.

The bug was not fixed with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.8b2) Gecko/20050625 but with Mozilla/5.0 (Windows; U; Windows NT 5.0;
en-US; rv:1.8b4) Gecko/20050910 SeaMonkey/1.0a it seems to be fixed.
Comment 24 User image Serge Gautherie (:sgautherie) 2005-09-16 15:54:20 PDT
(In reply to comment #23)
> Mozilla/5.0 (Windows; U; Windows NT 5.0;
> en-US; rv:1.8b4) Gecko/20050910 SeaMonkey/1.0a it seems to be fixed.

Maybe on your W2K, but not on my W98SE :-/

[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b4) Gecko/20050910 SeaMonkey/1.0a]
(release) (W98SE)
Comment 25 User image Serge Gautherie (:sgautherie) 2005-09-16 16:19:48 PDT
(In reply to comment #24)
> Maybe on your W2K, but not on my W98SE :-/

Well, I was 50% true only:

[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b4) Gecko/20050910 SeaMonkey/1.0a]
(release) (W98SE)

Stub-Installer, SMv1.0a-release: bug present.

[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20050915 SeaMonkey/1.1a]
(nightly) (W98SE)

Zip, SMv1.0a-release or SMv1.1a-nighly: no bug (= "fixed").

Then this may be "installer" related, as Ian asked before...
Comment 26 User image Serge Gautherie (:sgautherie) 2005-09-16 16:36:45 PDT
(In reply to comment #25)
> Then this may be "installer" related, as Ian asked before...

I compared Stub-I and Zip SMv1.0a, and was lucky enough to find the cause right
away:
the Stub-I installed bits miss
{{
  <RDF:Seq
RDF:about="chrome://communicator/content/downloadmanager/downloadmanager.xul">
    <RDF:li>chrome://communicator/content/tasksOverlay.xul</RDF:li>
    <RDF:li>chrome://communicator/content/utilityOverlay.xul</RDF:li>
  </RDF:Seq>
}}
in <overlays.rdf> !
(which explains everything :->)

Who knows how to fix this ? Neil !? ;-)
Comment 27 User image Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com] 2005-09-16 16:40:45 PDT
Apparently Mozilla shipped with this based on its age, so not blocking.
Comment 28 User image Serge Gautherie (:sgautherie) 2005-09-17 15:32:06 PDT
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b4) Gecko/20050910 SeaMonkey/1.0a]
(release) (W98SE)

Same bug in Full-I and Stub-I versions.
Comment 29 User image Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com] 2005-09-17 17:01:04 PDT
  <RDF:Seq
RDF:about="chrome://communicator/content/downloadmanager/downloadmanager.xul">
    <RDF:li>chrome://communicator/content/tasksOverlay.xul</RDF:li>
    <RDF:li>chrome://communicator/content/utilityOverlay.xul</RDF:li>
  </RDF:Seq>

This appears only in the zip's overlays.rdf.  The zip vs installer overlays.rdf
are otherwise identical (after you undo the different ordering).
Comment 30 User image Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com] 2005-09-17 17:07:20 PDT
Pointing the installer build at the zip build's profile (I kept them separate)
did not make the installer build work.

Deleting the overlays.rdf caused both the zip build and the installer build to
not do anything when I pressed delete.  No overlays.rdf was regenerated in the
install directories.  Putting the overlays.rdf files back caused the zip build
to work again.
Comment 31 User image neil@parkwaycc.co.uk 2005-09-18 07:04:13 PDT
I think I can guess what's going on here now - browser.jst isn't registering the
downloadmanager chrome, so it probably needs an extra line like this:
registerChrome(CONTENT | DELAYED_CHROME,
getFolder("Chrome","comm.jar"),"content/communicator/downloadmanager");
Comment 32 User image Andrew Schultz 2005-09-18 07:38:27 PDT
Created attachment 196534 [details] [diff] [review]
patch

patch based on comment 31.  I can't verify that this helps because the bug
doesn't affect linux.  The installer just runs regchrome when it's done
installing files.
Comment 33 User image Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com] 2005-09-18 11:14:09 PDT
I don't think the patch helped.
Comment 34 User image Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com] 2005-09-18 11:28:10 PDT
Comment on attachment 196534 [details] [diff] [review]
patch

As far as I can tell, this had no effect (or had a negative effect?).  After
install, there is no overlays.rdf until the browser runs once, at which point
it's autogenerated but still doesn't have anything download-related.
Comment 35 User image Serge Gautherie (:sgautherie) 2005-09-18 13:06:15 PDT
I just wanted to quote this, without knowing which browser.jst does what...

<http://lxr.mozilla.org/mozilla/find?string=browser.jst>
{{
/browser/installer/windows/browser.jst
/browser/installer/unix/browser.jst
/calendar/installer/windows/browser.jst
/xpinstall/packager/build/win/mozilla/XPI_JSTs/browser.jst
/xpinstall/packager/mac/browser.jst
/xpinstall/packager/os2/browser.jst
/xpinstall/packager/unix/browser.jst
/xpinstall/packager/windows/browser.jst
}}
Comment 36 User image Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com] 2005-09-18 14:35:52 PDT
Comment on attachment 196534 [details] [diff] [review]
patch

+    registerChrome(CONTENT | DELAYED_CHROME,
getFolder("Chrome","comm.jar"),"content/communicator/downloadmanager");

r=me with trailing slash
Comment 37 User image Daniel Veditz [:dveditz] 2005-09-26 12:34:09 PDT
Comment on attachment 196534 [details] [diff] [review]
patch

sr=dveditz
As cst noted, the windows version needs a trailing slash
Comment 38 User image Andrew Schultz 2005-09-26 20:46:19 PDT
landed on trunk.
Can someone verify this fixed the problem with tomorrow's build and I'll request
approval.
Comment 39 User image Stephen Donner [:stephend] 2005-09-27 09:13:12 PDT
(In reply to comment #38)
> landed on trunk.
> Can someone verify this fixed the problem with tomorrow's build and I'll request
> approval.

Verified FIXED using trunk SeaMonkey 1.1a

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050927 Mozilla/1.0
Comment 40 User image Andrew Schultz 2005-09-27 15:47:48 PDT
Comment on attachment 196534 [details] [diff] [review]
patch

super-low risk, SeaMonkey-only.
Comment 41 User image Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com] 2005-09-27 22:02:31 PDT
Checked in on branch, if my previous change didn't make that obvious :).
Comment 42 User image Serge Gautherie (:sgautherie) 2005-09-28 13:27:09 PDT
(In reply to comment #39)
> Verified FIXED using trunk SeaMonkey 1.1a

[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20050928 SeaMonkey/1.1a]
(nightly) (W98SE)

Confirming (with Full Installer), as bug reporter.

Note You need to log in before you can comment on or make changes to this bug.