Op, Voice & Nick settings not remembered

RESOLVED FIXED

Status

--
enhancement
RESOLVED FIXED
16 years ago
15 years ago

People

(Reporter: mrmazda, Assigned: rginda)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: cz-patch)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
Problem found prior to OS/2 2003032412, confirmed in Linux 2003032416.

In mailnews header pane the column headings can be turned off and selected for
sort key and order. In Chatzilla left pane, nothing is remembered across
sessions. When voice off and sort descending op are set, those settings should
be remembered for the start of the next session, paralleling behavior in the
mailnews header pane.

Comment 1

16 years ago
The order is even not maintained during current session.
Marking as dependent of bug 133014
Depends on: 133014

Comment 2

16 years ago
Posted patch patch v1 (obsolete) — Splinter Review

Updated

16 years ago
Attachment #118617 - Flags: review?(rginda)

Comment 3

16 years ago
Posted patch patch v2Splinter Review
Included the fix for bug 155186.
Attachment #118617 - Attachment is obsolete: true

Updated

16 years ago
Attachment #118635 - Flags: review?(rginda)
(Assignee)

Comment 4

16 years ago
Comment on attachment 118635 [details] [diff] [review]
patch v2

r=rginda
Attachment #118635 - Flags: review?(rginda) → review+
(Assignee)

Updated

16 years ago
Whiteboard: cz-patch

Comment 5

16 years ago
checked in
Blocks: 133014, 155186
Status: NEW → RESOLVED
Last Resolved: 16 years ago
No longer depends on: 133014
Resolution: --- → FIXED
Whiteboard: cz-patch

Updated

16 years ago
Attachment #118617 - Flags: review?(rginda)

Comment 6

16 years ago
Hiho, I have manually patched my ChatZilla 0.8.24 with patch v2 and it works
well in general. One problem I have found so far: Whenever the userlist is
sorted and somebody joins the channel the new nick is being put at the end of
the list and one must manually resort it again (by clicking on it).

bye, daniel :)
I have another issue: when you reopen Chatzilla the list isn't sorted.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Some cleanup crept in while I was figuring out the problem :-)

Updated

16 years ago
Attachment #120195 - Flags: review?(rginda)
(Assignee)

Comment 9

16 years ago
Comment on attachment 120195 [details] [diff] [review]
Persist some more sort settings

r=rginda
Attachment #120195 - Flags: review?(rginda) → review+

Updated

16 years ago
Blocks: 201324

Updated

16 years ago
Whiteboard: cz-patch
Fix checked in.

Comment 11

16 years ago
*** Bug 150318 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
-> FIXED
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.