unable to search/find on initial opening of view source tab

RESOLVED FIXED

Status

Core Graveyard
View Source
--
minor
RESOLVED FIXED
15 years ago
8 years ago

People

(Reporter: jon moses, Assigned: Doron Rosenberg (IBM))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3; MultiZilla v1.4.0.3e) Gecko/20030319 Debian/1.3-3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3; MultiZilla v1.4.0.3e) Gecko/20030319 Debian/1.3-3

After opening the a pages source 'View' -> 'Page Source', I'm unable to search
in the tab that opens with the source unless I switch tabs, and then switch
back.  I have multizilla installed, so I don't know if that's the problem.  I'll
test it, and comment again.

Reproducible: Always

Steps to Reproduce:
1. View source
2. Try and 'Find in page...'
3. Menu item is unaccessable
4. Switch tabs
5. Switch back
6. Search works

Actual Results:  
Search works only after reactivating tab

Expected Results:  
Search should have work w/o switching tabs

Comment 1

15 years ago
I see the same thing. I am using Mozilla 1.3 with Multizilla on windows 2k.

Comment 2

15 years ago
Sounds like bug 80598 is back?  If I click inside the window then the search 
works fine, so it's just the content window that doesn't have focus.  Arrow 
keys don't work either.

I'm using build 20030507.

Comment 3

15 years ago
Mine (2003042808, Mac OS X) fails differently.  The menu command is enabled, and
the find dialog box appears fine, but I always get "The text you entered was not
found" until I actually click in the source and try again.

At first I thought the reason was that it started the invisible cursor at the
end of the source.  But now I see that even with "Search backwards" it always
finds nothing initially.
Neil, didn't you just fix this?

Comment 5

15 years ago
the tab that opens with source?
there was a real view source bug that bryner fixed, otherwise bug HJ.

Comment 6

15 years ago
Looks like that was bug 203117.  Funny how that didn't show up in any searches 
(I did five or six <g>).

Comment 7

15 years ago
OK, this looks fixed in the latest nightly (build 20030523).  Reporter, can you
try testing this build as well?
(Reporter)

Comment 8

15 years ago
Tried with 

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3; MultiZilla v1.4.0.3e) Gecko/20030526

And it worked fine.  View source -> 'opens in new tab' -> ctrl+f -> search box
pops up -> 'search' -> term highlighted.

Comment 9

15 years ago
Great, looks like the bug is fixed.  Can you mark this bug as Resolved & Works 
For Me?

Comment 10

15 years ago
I could, but it would be wrong since it didn't work for either of us at the time
when this was an issue.  FIXED is the appropriate resolution.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey

Updated

8 years ago
Component: View Source → View Source
Product: SeaMonkey → Core Graveyard
You need to log in before you can comment on or make changes to this bug.