unable to scroll View Source window with keyboard (View Source window does not get focus)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: bugzilla, Assigned: bryner)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
unable to scroll the View Source window with the keyboard (spacebar, arrow keys,
pageUp/Down). this seems to be a regression from brian's checkin for bug 170811,
since this works with the 2003.04.02.08 build, but is broken with 2003.04.03.05.

1. go to a page whose source would be long (ie, scrollable), such as
http://mozilla.org
2. open the source window (i used accel+U).
3. hit spacebar, arrow keys or pageDown/Up to scroll through the window.

results: no scrolling occurs. interestingly, accel+W works to close the window,
and manual find as you type (using / ) both still work.

brian mentioned he's working on a patch --and from a brief glance over his
shoulder, it look like this issue would be fixed. pls do add this bug to the
dependency list for that bug (i don't know the number offhand).

Comment 1

16 years ago
Bah, someone keeps resetting the focused window to chrome, rather than content,
no matter how hard I try (well, the following hack works...)
<window onfocus="document.commandDispatcher.focusedWindow = content;">

Comment 2

16 years ago
It turns out that nsPresShell::CheckForFocus is resetting the focus.
I'm blaming fallout from bug 170811 here, so I'll CC some folks...

Comment 3

16 years ago
Then it's probably the same as bug 201996.

Comment 4

16 years ago
*** Bug 203335 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
Well, I've given up trying to figure out what CheckForFocus does.
It never finds a windowless document.
(Reporter)

Comment 6

16 years ago
this appears fixed with some test builds brian whipped up y'day.

Comment 7

16 years ago
I just tried 1.4beta (2003050714) and it turnes out that I cannot scroll in the browser using 'Page Up' and 'Page Down' and I cannot use the Cursor Keys in form like this one. (Tried with Linux).

Trying the same in the Mail-System, I can scroll using the Keyboard in the folder list, the email list (the subjects), but not in the displayed email-text.

I hope, this is useful information.

This is a really annoying bug - I have to revert to 1.4alpha

Frank
Blocks: 204867
Flags: blocking1.4?
(Assignee)

Comment 8

16 years ago
Fix checked in (from bug 201996).
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Updated

16 years ago
No longer blocks: 204867
(Reporter)

Comment 9

16 years ago
*** Bug 204867 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 10

16 years ago
vrfy'd fixed with 2003.05.12 comm builds.
Status: RESOLVED → VERIFIED

Comment 11

16 years ago
*** Bug 205367 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Flags: blocking1.4?
(Reporter)

Comment 12

16 years ago
oh, re comment 7: that sounds similar to bug 202157. (not sure if it has the
same root cause.)

Comment 13

16 years ago
*** Bug 209579 has been marked as a duplicate of this bug. ***

Comment 14

15 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20030924

It is back. I cannot scroll or use type ahead find in view source before
clicking in that window.

pi
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 15

15 years ago
Is this still a problem for you, Pi?  I don't see the symptom with 1.6 Final or 
with
  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a2) Gecko/20040604

Comment 16

15 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040514

Yes, if I press ctrl-u to open the source windows, neither the scroll keys work
nor typeaheadsearch.

pi

Comment 17

15 years ago
*** Bug 229070 has been marked as a duplicate of this bug. ***

Comment 18

15 years ago
Maybe the summary should say: View Source window does not get focus.

pi

Updated

15 years ago
Summary: unable to scroll View Source window with keyboard → unable to scroll View Source window with keyboard (View Source window does not get focus)

Comment 19

15 years ago
*** Bug 250076 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 20

14 years ago
hm, this is working for me using 2004111808-trunk moz1.8 bits on linux fc2. is
this still an issue for anyone else with recent builds?

Comment 21

14 years ago
Cool, works for me too.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago14 years ago
Resolution: --- → WORKSFORME

Comment 22

14 years ago
I should say WFM on Mozilla 1.8a5
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041107

Comment 23

14 years ago
Confirming on Win98SE

pi
You need to log in before you can comment on or make changes to this bug.