account hub: Unable to finish new email account setup due to wizard interface bug
Categories
(Thunderbird :: Untriaged, defect)
Tracking
(Not tracked)
People
(Reporter: ciprian333, Unassigned)
References
(Blocks 1 open bug)
Details
Attachments
(2 files)
Steps to reproduce:
On a 140.3.0esr (RPM from Fedora Workstation x86_64) with existing accounts:
- implement the network.security.ports.banned.override hack in order to be able to import your self-signed certificate
- import the certificate
- try to add a NEW IMAP account (for a server with a self-signed certificate).
Actual results:
After a successful confirmation of the setup ("Configuration found in Mozilla ISPDB ") the wizard will stop working right at the last step (after the password was inserted) with the error message:
can't access property "cleanup", this[#configVerifier] is undefined
Expected results:
The wizard should have accepted my password and created the account.
The issue looks similar to https://bugzilla.mozilla.org/show_bug.cgi?id=1971303 (but pressing ESC won't help) or https://bugzilla.mozilla.org/show_bug.cgi?id=1975814 but I'm on 140.3esr while the bug claims the fix was ported to 140.2 already
Tried going "Back" and then the "Advanced Config" way but clicking on the link gives "Error Creating Account" instead of the usual "This will create a new account even though the settings are incorrect... "
I do get a red text warning though for SMTP:
"Warning: Insecure mail server detected. This server lacks encryption, exposing your password and data. Contact your administrator to secure the connection or proceed at your own risk."
Yes, I know it's insecure: It's a setup in an isolated network trying to reproduce another (networking related most likely) bug.
Comment 2•11 months ago
|
||
Can you retry with "Create accounts in the new Account Hub" disabled in settings?
Comment 3•11 months ago
|
||
Or upgrade to 140.4.0esr where this it should be disabled already.
(In reply to Corey Bryant from comment #2)
Can you retry with "Create accounts in the new Account Hub" disabled in settings?
That was the magic incantation, thank you.
Comment 5•11 months ago
|
||
Cip, can you try v144 (or v145beta) with account hub enabled, to see if it's fixed there?
Comment 6•11 months ago
|
||
Cip, can you try v144 (or v145beta) with account hub enabled, to see if it's fixed there?
OK, I tested with the latest from download (some 144... something, the years old bug is still there: you are allowed to select elements from interface but you are forbidden from COPYING them) and:
First time setup did not work; the message was not at all useful so I can only assume that it was unable to establish a connection due to the CA not being trusted; fortunately the first time account creation's "Advanced settings" took me to the account(s) page with the account details already filled in. There was also this option to import the server's (self signed) SSL cert. Once the SSL cert was imported I deleted the account and tried again from start. This time the account hub worked.
An option to open "Advanced logging" or something like that where to clearly specify in technical terms what the problem was (not trusting the CA in this case) would have been nice, probably solved tons of support tickets.
Comment 8•11 months ago
|
||
It should not be necessary to go into advanced settings for that. If an exception is needed, a dialog will pop up.
Good to hear "it should not be necessary" but I'm telling you the first time setup did not present a dialog to enable cert import.
| Reporter | ||
Comment 10•11 months ago
|
||
OK, tried something closer to reality.
Deleted the arch, untarred again and setup another email account with an older (also self-signed) server so that the new email setup is perfomed like in the real situation meaning with an already existing account but no certificate from the new server.
To my surprise, while setting up the older server account, the initial setup dialog DID show the pop-up with security exceptions and all that jazz. So I clicked my way through the setup process accepted the risks and got an email account.
Then I tried adding another email account; got the accounts hub and it would as if 144 will in fact pop-up the import cert dialog but it will only do so for servers presenting themselves with self-signed certs via STARTLS on 143! If the IMAP server responds with SSL/TLS on 993 I don't get an option to import the cert and the hub fails; at least we have a good error message: still not technically informative but at least not a JS error.
The bad news is that if I try "Advanced settings" (while going the SSL/TLS 993 way), the error message is an empty box!
| Reporter | ||
Comment 11•11 months ago
|
||
Updated•6 months ago
|
Description
•