Personal Toolbar Folder created in Personal Toolbar

VERIFIED DUPLICATE of bug 197291

Status

VERIFIED DUPLICATE of bug 197291
16 years ago
14 years ago

People

(Reporter: kabal, Assigned: bugs)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

I accidentally created a Personal Toolbar Folder (PTF) in the Personal Toolbar. 
The folder <a href="http://www.thegreekgod.net/images/ptf1.gif">appears to be
empty</a> when it is selected from the toolbar. This folder cannot be deleted
through normal bookmarking deletion practices. I had to remove it manually from
the bookmarks.html file in my profile.

This has an 
<a href="http://www.thegreekgod.net/images/ptf2.gif">interesting effect</a> 
when going through the main Bookmarks. An unending chain of PTF folders is created. 

This new PTF folder also appears when Manage Bookmarks is opened, and weird
things start to happen when the folder are opened/closed.

1) Select Manage Bookmarks... - <a
href="http://www.thegreekgod.net/images/ptf3.gif">Image</a>
2) Close the fake PTF within the existing, "real" PTF, and it's name disappears.
Other folder names also disappear if they are selected at this point (not
bookmarks, just the folders) - <a
href="http://www.thegreekgod.net/images/ptf4.gif">Image</a>
3) If you try to close the actual PTF (i.e. click on the black arrow), multiple
copies of the same folder appear. <a
href="http://www.thegreekgod.net/images/ptf5.gif">Image</a>
4) Click on the arrow again, the PTF closes. Click again, and everything appears
to be normal (and the fake PTF is gone - even though it is still in the toolbar)
- <a href="http://www.thegreekgod.net/images/ptf6.gif">Image</a>

Reproducible: Always

Steps to Reproduce:
1. I click and hold down between 2 folders (or bookmarks) in the Personal Toolbar.
2. I drag "something" off of the toolbar.
3. I place "it" back on the toolbar.

Actual Results:  
A "fake" PTF is created in the Personal Toolbar.

Expected Results:  
No PTF should have appeared in the Personal Toolbar. This shouldn't be possible.

This may be distantly related to Bug 191888.
(Reporter)

Comment 1

16 years ago
Two other notes:

1) The following line of code is added to bookmarks.html when this bug occurs:

        &lt;DT&gt;&lt;H3 ADD_DATE="907702403" LAST_MODIFIED="1048787639"
PERSONAL_TOOLBAR_FOLDER="true" ID="NC:PersonalToolbarFolder"&gt;Personal Toolbar
Folder&lt;/H3&gt;
        &lt;DL&gt;&lt;p&gt;
        &lt;/DL&gt;&lt;p&gt;

2) If the process of creating these fake PTFs is done multiple times, only one
instance of it will show up in the Personal Toolbar, but all of the fake PTFs
appear in bookmarks.html. When one instance is removed from bookmarks.html and
mozilla is relaunched, the next instance appears.

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 197291 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.