Closed Bug 199608 Opened 22 years ago Closed 21 years ago

"Check for new messages at startup" only checks Inbox, not other mail folders

Categories

(MailNews Core :: Backend, defect)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 186894

People

(Reporter: david.rasmussen, Assigned: mscott)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

Even though I've enabled the "Check for new messages at startup" for my pop3
account, mails are never begin fetched at startup.

Reproducible: Always

Steps to Reproduce:
1. Enable "Check for new messages at startup"
2. Close mozilla entirely
3. Startup mozilla and watch the mails _not_ rolling in :)

Actual Results:  
Nothing :)

Expected Results:  
Mail should be fetched
that's because there's no standalone notificiation agent yet...

*** This bug has been marked as a duplicate of 11056 ***
Status: UNCONFIRMED → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
Summary: "Check for new messages at startup" doesn't work in 1.3 → "Check for new messages at startup" doesn't work if Mozilla is closed
David, to make it clearer: At the moment this option works as expected only if
you open the Mail&News component. The browser component alone does not check for
e-mails. You have to read the option as "check ... at Mail&News startup".
Confirming with Mozilla 1.4a build 2003032508 on WinNT4.

from reporter per e-mail:
> But I _am_ talking about starting the mail&news client!!
> When I have enabled this option, and I start the m&n client, nothing
> gets fetched!

Ok, I have enabled "check for new messages on startup". If I open M&N nothing
happens. In Netscape 7.02 it works as aspected (connect to POP3 server ...).

So the summary should be changed and the bug reopened. I can't do that.
The problem, as I mentioned in
<news://news.mozilla.org:119/b5vsu8$7d71@ripley.netscape.com>, is that *only the
Inbox* gets checked on start-up. Other mail folders that have "Check for new
messages" checked *don't* get checked on start-up. They *do* get checked on the
repeating checks, though.

Someone needs to check if this is the case when *all* mail folders get checked
on start-up by default.

This has been happening for a while, and started maybe a month before 1.3, I think.
Severity: normal → major
Status: RESOLVED → UNCONFIRMED
Component: Networking: POP → Mail Back End
Flags: blocking1.4a?
OS: Windows XP → All
Hardware: PC → All
Resolution: DUPLICATE → ---
Summary: "Check for new messages at startup" doesn't work if Mozilla is closed → "Check for new messages at startup" only checks Inbox, not other mail folders
Confirmed using FizzillaMach/2003032609. 
Assignee: naving → mscott
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.4a? → blocking1.4a-
WFM with Moz 1.4a build 2003032508 & Moz 1.4b build 2003040808 on Win NT4

Sorry, I have to revoke my comment 3.

I have 3 mail accounts in Mail&News. I tested with the following settings for
all accounts (under server settings).
pref1: check for new messages at startup
pref2: automatically download new messages

1) pref1 and pref2 are enabled
At startup of Mail&News Mozilla connects to the POP3 servers and tries to
download new messages. You can see the status info in the status bar (the user
can see Mozilla is doing something).

2) pref1 enabled and pref2 disabled
At startup of Mail&News Mozilla connects to the POP3 servers for checking. I
verified this with TDIMon. But in this case there is no status info (I guess
because nothing is downloaded). So a normal user cannot see this (except
notification for new mail). That's the reason why I misinterpreted this in my
last comment.


@ Greg:
I guess you meant with "Inbox" your default mail account and with "other mail
folders" your other mail accounts. Therefore the summary is somewhat misleading.
Actually, no, I meant other mail folders for my IMAP account. This bug probably
doesn't apply to POP accounts since they have only one "folder" on the server.
okay, it seems to me that in order to get mozilla to check other IMAP folders
than inbox for new mail you have to set it to be checked.  right click on the
folder in question, pick properties and then click on check this folder for new
messages.

you probably already have this all set up, but i think it brings up another UI
point, (should be a seperate bug maybe?), there are three usual places where i
need to pick from a list of all my folders

subsrcibe to folders -> currently in a contextual drop down from the account
heading in the folders list

select folder for message download -> mail and news prefs, offline/diskspace
section OR from the properties option in the contextual drop down for the folder
in the folders list

check folder for new messages -> from the properties option in the contextual
drop down for the folder in the folders list

The check folder for new mail seems in need of a central list interface for
selection and it would be cool if these three tasks were more similar in their
UI implimentaions.

michael
Even with folders set to check for new messages, they fail to indicate new
messages on start-up.
*** Bug 139245 has been marked as a duplicate of this bug. ***
I am having this same problem on 1.5 Release for Linux.  Folders are selected
for download mail on startup yet only the Inbox for the first profile actually
downloads mail on startup.  I have manually click on each folder in order to
download mail.  1.5 seems to be a very buggy release.
This should be marked as a duplicate of this:
http://bugzilla.mozilla.org/show_bug.cgi?id=186894
bug.

*** This bug has been marked as a duplicate of 186894 ***
Status: NEW → RESOLVED
Closed: 22 years ago21 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.