Only INBOX checked for new mail at startup, not subfolders

RESOLVED FIXED

Status

MailNews Core
Networking: IMAP
RESOLVED FIXED
16 years ago
10 years ago

People

(Reporter: Peter Runestig, Assigned: Bienvenu)

Tracking

(Blocks: 1 bug, {regression, verified1.7})

Trunk
regression, verified1.7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20021226
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20021226

Sometime after 20021119, MailNews stopped checking my IMAP accounts _subfolders_
for mail at application startup. I have it configured to check for new mail
every minute, and after a minute, all folders are checked for mail. I.e. it's
only at startup that the inbox subfolders isn't checked (the INBOX itself is
checked though). If I fire up my 20021119 build, it all works as expected. Also,
if I manually "Get New Messages", the subfolders are checked.

Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago
i get the same behaviour with thunderbird 0.2 20030829 (not shure wether i
should create a seperate bug report for thunderbird...) and i have 

// Download mail from all accounts on startup
user_pref("mail.check_all_imap_folders_for_new", true);

in my user.js
(Assignee)

Comment 2

15 years ago
you might try the next version  of Thunderbird, .3, when it comes out, and see
if it helps. Have you set the online server directory for your imap server, or
left it blank?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

15 years ago
has anyone tried 1.5 final build, or a recent thunderbird build? I believe this
might be fixed.
(Reporter)

Comment 4

15 years ago
I've just tried out 1.5rc1, and it's actually behaving a bit worse:
- Starting up Mozilla MailNews.
- Only INBOX "root" is checked for new mail.
- Clicking on "Get Msgs" button.
- Only INBOX "root" is checked for new mail (!).
- Clicking on a INBOX subfolder.
- MailNews starts checking subfolders for new mail.

The "worse" part being "hesitating" to check subfolders for new mail when "Get
Msgs" is clicked.

Comment 5

15 years ago
Confirming in the final 1.5 release

Comment 6

15 years ago
Not only do subfolders not check mail, only the first inbox checks mail on 1.5
release.

Comment 7

15 years ago
I have confirmed this as well. I upgraded from Mozilla 1.4 to Mozilla 1.5 and
have performed NO configuration changes. However, now only my *first* IMAP
account is checked for new mail and only the INBOX folder. At M&N startup I
believe it actually checks all accounts and folders properly (I have each
individual folder set option "Check this folder for new messages" enabled) but
on the subsequent checks it does not. I have my other IMAP accounts set at a 10
minute check interval yet the NEVER check for new mail (except at startup)
unless I click on them. This all worked fine in Mozilla 1.4.
(Assignee)

Comment 8

15 years ago
has anyone tried a 1.6 build or a recent tbird build?
(Reporter)

Comment 9

15 years ago
Mozilla 1.6a behaves the same.

Comment 10

15 years ago
I just wanted to confirm that on M&N 5.0 startup it does actually check all my
folders in all my accounts like it is supposed to (though it seems to take a bit
longer to check non-inbox folders than it used to).

However during subsequent scheduled checks only the INBOX of my first account
and it appears sometimes the folders of my first account are checked. My other
accounts are not automatically checking for new mail.

I can't yet verify whether it is the first account in the list that works or
whether it is just the active account, because they are both the same for me.

Comment 11

15 years ago
I can confirm with: Mozilla Thunderbird 0.4 (20031205) and Cyrus imap 2.1.12.
Only the first message in my inbox will give a notification. With every next new
message the folder status gets updated but no notification is send. For Inbox
subfolders (Option: "Check this folder for new messages" Enabled) not even the
first message gets a notification but also here to folder status gets updated.
It doesn't matter how many new messages are in my inbox or subfolders the icon
in my systray always shows "accound name has 1 new message".
Ones you select a folder in which new messages are recieved the message
notification will show. I know for sure that with previous versions of
thunderbird (don't know which ones exactly) this feature worked for subfolders
(I am not sure about the behaviour of a second mail in the inbox).

Comment 12

15 years ago
Confimed with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b)
Gecko/20031208.

Server: courier-0.44.2

Additional info: The additional folders -do- get checked if I switch the
'focused' folder. It doesn't matter what folder I switch to, merely the act of
switching will cause Mozilla to check all folders again. This isn't a
workaround, however, since Mozilla won't ever report new mail unless I intervene
personally, which sort of defeats the purpose of having Mozilla check for new mail.

To reproduce a scenario, I select a subfolder ("Check for new mail"), make sure
I'm subscribed to it, and then focus on the top folder (INBOX in my case). Then
I arrange for a new mail to appear in the subfolder. Now, no matter how many
times I click "Get new messages", Mozilla will repeat "No new messages". Then,
if I select another folder on the server (no matter which one), Mozilla will
then (at new-mail-checking-time) correctly check the subfolder and see that
there is indeed new mail there.


Comment 13

15 years ago
I'm seeing parts of the behaviors mentioned here when using Mozilla 1.6b on
Linux & Courier-Imap 2.1.2.

The only time that I see the expected behavior, that the message counts for the
expected folders are updated when new mail arrives, is when:
1) I'm subscribed to a subfolder
2) I've clicked 'Check folder for new messages' under the Properties dialog for
that foler
3) I click the 'Get Messages' when the toplevel Inbox is selected

When I changed the account to check the messages every other minute, the folder
counts still did not get updated until I clicked on 'Get Messages'.
I don't use notifications so I didn't test their behavior.  Strangely enough,
the IMAP_CHECK_ALL_FOLDERS setting in the imapd config file does not affect the
observed behavior.

Why is it necessary to enable each folder for checking for new mail once you've
subscribed to the folder?  I would have expected subscribing & checking new mail
to go hand in hand as they do with nntp.  I haven't tested the
mail.check_all_imap_folders_for_new pref yet.  Is there a way to enable that in
the gui? 
 
OS: Windows XP → All
Hardware: PC → All

Comment 14

15 years ago
*** Bug 199608 has been marked as a duplicate of this bug. ***

Comment 15

15 years ago
Is there somebody working on this?

Updated

15 years ago
Blocks: 36011

Comment 16

14 years ago
*** Bug 238751 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 17

14 years ago
Can someone having these problems attach a protocol log? Also, please do this
with 1.7

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap

Re Seawood's question, the reason we don't check all imap folders for new
messages by default is that the vast majority of users don't have messages
arriving in any folder besides the inbox, so it would be a waste of client and
server cpu, not to mention network bandwidth.

Comment 18

14 years ago
> Re Seawood's question, the reason we don't check all imap folders for new
> messages by default is that the vast majority of users don't have messages
> arriving in any folder besides the inbox, so it would be a waste of client and
> server cpu, not to mention network bandwidth.

Of course, but this is a reason why only Inbox is selected for checking new
messages in the default configuration. I absolutely agrree. 
But, if I select other folders to check for new messages, they SHOULD be checked
at Mozilla startup!

Comment 19

14 years ago
Created attachment 145008 [details]
IMAP protocol log from build 2004031616

> Can someone having these problems attach a protocol log? Also, please do this

> with 1.7

Here is the protocol log you've requested. I used the newest beta build
{2004031616}.
I added a comment to the log file at the point when Mozilla startup finished.
The next part of the log is after I pressed the Get Msgs button in Mozilla. The
folders selected for checking new mail were checked then...
This used to work back in 1.4 (well, at least in NS 7.1)
Keywords: regression

Comment 21

14 years ago
*** Bug 240475 has been marked as a duplicate of this bug. ***

Comment 22

14 years ago
*** Bug 241857 has been marked as a duplicate of this bug. ***

Comment 23

14 years ago
*** Bug 242173 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 24

14 years ago
Created attachment 147566 [details] [diff] [review]
proposed fix

do perform biff on imap server as well, because it might check folders other
than inbox for new messages. Set m_runningUrl in nsImapMailFolder in update
folder, so we eon't have the double select problem.
(Assignee)

Updated

14 years ago
Attachment #147566 - Flags: superreview?(mscott)

Updated

14 years ago
Attachment #147566 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 25

14 years ago
fixed, in thunderbird too.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 26

14 years ago
IT WORKS!!! (tested with Build ID: 2004050509)
Thanks for this great piece of work!
(Assignee)

Comment 27

14 years ago
Comment on attachment 147566 [details] [diff] [review]
proposed fix

this is a highly requested bug fix...I get a lot of dups on it. Fix is pretty
safe...
Attachment #147566 - Flags: approval1.7?

Comment 28

14 years ago
Comment on attachment 147566 [details] [diff] [review]
proposed fix

a=mkaply for 1.7
Attachment #147566 - Flags: approval1.7? → approval1.7+
(Assignee)

Updated

14 years ago
Keywords: fixed1.7
(Assignee)

Comment 29

14 years ago
*** Bug 221792 has been marked as a duplicate of this bug. ***

Comment 30

14 years ago
Verified as fix on latest 1.7 branch 06-24 builds.
Changing keywords from fixed1.7 to verified1.7.
Leave this bug status "as is" until this bug be verified on trunk again...
Keywords: fixed1.7 → verified1.7
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.