Carets in every address bar

VERIFIED FIXED in M14

Status

()

Core
XUL
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Steven Lyons, Assigned: saari (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+]linux only, depends on 12051 2/14)

(Reporter)

Description

18 years ago
I'm not sure if this is a a dup of bug 9305, or maybe it is supposed to be this
way but...

When there are multiple windows open, each address bar has a blinking caret.
This can make it confusing as to which window has the focus.

Updated

18 years ago
Assignee: trudelle → saari

Comment 1

18 years ago
Shouldn't be too confusing, it is the only one with a blue titlebar. reassigning
to saari in case it is related to
http://bugzilla.mozilla.org/show_bug.cgi?id=18983
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 2

18 years ago
fixed

Updated

18 years ago
Status: RESOLVED → REOPENED

Comment 3

18 years ago
I still see this in the 2000011408 build on WinNT.

Updated

18 years ago
Resolution: FIXED → ---

Comment 4

18 years ago
Clearing FIXED resolution due to reopen.
(Assignee)

Updated

18 years ago
Status: REOPENED → ASSIGNED
Target Milestone: M14

Comment 5

18 years ago
On Linux, even in a single window, you can see carets blinking in every text
field/area that has ever had focus.
OS: Windows 98 → All
Hardware: PC → All
(Assignee)

Comment 6

18 years ago
I'm going to limit this bug to carets between windows (shaver reopened another 
one for the problem of multiple carets within a window).

Have fixes waiting for Mac and Win, working on Linux still.
Keywords: beta1
(Assignee)

Comment 7

18 years ago
Fixed on Mac and windows. Linux isn't quite happy yet
Whiteboard: linux only

Comment 8

18 years ago
Putting on pdt+ radar for beta1.
Whiteboard: linux only → [PDT+]linux only

Comment 9

18 years ago
*** Bug 25673 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Blocks: 25824

Comment 10

18 years ago
*** Bug 26684 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 11

18 years ago
Need focus memory to fix this, since linux has a different event order than other 
platforms.
(Assignee)

Updated

18 years ago
Whiteboard: [PDT+]linux only → [PDT+]linux only, depends on 12051
(Assignee)

Comment 12

18 years ago
2/14, same estimate as focus memory
Whiteboard: [PDT+]linux only, depends on 12051 → [PDT+]linux only, depends on 12051 2/14
(Assignee)

Comment 13

18 years ago
Fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Updated

18 years ago
No longer blocks: 25824

Comment 14

18 years ago
VERIFIED fixed on all platforms with the 2000021509 builds
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.