document.referrer is empty

RESOLVED FIXED

Status

()

Core
DOM: Core & HTML
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: HARUNAGA Hirotoshi, Assigned: Harshal Pradhan)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 obsolete attachment)

(Reporter)

Description

15 years ago
document.referrer is empty on recent build.

Steps:
Click this link.
http://bugzilla.mozilla.gr.jp/attachment.cgi?id=1566&action=view

Confirming with FreeBSD 03-28-08 CVS build and 2003032808/WinNT.

1.3 does't have this problem.
A tester says that this does't occur on 2003032014/Win98.

Comment 1

15 years ago
WFM 2003032003 OS X
Broke in 2003032609 OS X

--> All/All
Hardware: PC → All

Comment 2

15 years ago
a quick check on my local copy of apache shows that referrer is being sent via
HTTP headers. For validation click on "HTTP Request Viewer" on this page:
http://www.delorie.com/web/
The same happens in 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030327

Comment 4

15 years ago
A few more builds tested -

This works in
2003032503 / OS X next build i have here is 
2003032609 / OS X which i previously stated is broken

Setting blocking 1.4a? flag because this may turn out to break many sites & is a
very recent regression - right at the freeze (although I don't know how
practical getting a fix in is at this point)
Flags: blocking1.4a?
Keywords: regression
(Reporter)

Comment 5

15 years ago
caused by Bug 124412?

Comment 6

15 years ago
Chris, can you test 2003032609 again?

With 2003032604 on Win2k it *is* broken for me!
And WFM with 2003032510.
Narrow window but lots of checkins. But I have to admit that Bug 124412 is also
one of my favourites...

Comment 7

15 years ago
I support blocking1.4a? - it seems to get its first duplicate already: bug 199891.

Comment 8

15 years ago
*** Bug 199891 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

15 years ago
Yes this is a fallout of the checkin for bug 124412. Unless I am reading things
completely incorrectly. It appears to be a last minute merge error after
peterl's plugin changes.

From the final diff in bug 122412.... 

@@ -753,31 +758,22 @@ nsHTMLDocument::RetrieveRelevantHeaders(
 {
   nsAutoString lastModified;
   mHttpChannel = do_QueryInterface(aChannel);
+  nsresult rv;
 
   if (mHttpChannel) {
     nsCAutoString lastModHeader;
-    nsresult rv =
mHttpChannel->GetResponseHeader(NS_LITERAL_CSTRING("last-modified"),
-                                                  lastModHeader);
+    rv = mHttpChannel->GetResponseHeader(NS_LITERAL_CSTRING("last-modified"),
+                                         lastModHeader);
  
     if (NS_SUCCEEDED(rv)) {
       CopyASCIItoUCS2(lastModHeader, lastModified);
       SetLastModified(lastModified);
     }
-
-    nsCAutoString referrerHeader;
-    // The misspelled key 'referer' is as per the HTTP spec
-    rv = mHttpChannel->GetRequestHeader(NS_LITERAL_CSTRING("referer"),
-                                        referrerHeader);
-
-    if (NS_SUCCEEDED(rv)) {
-      SetReferrer(NS_ConvertASCIItoUCS2(referrerHeader));
-    }
   }


(Assignee)

Comment 10

15 years ago
Created attachment 118926 [details] [diff] [review]
Restore the code to set referrer and hopefully a little bit better string foo
(Assignee)

Updated

15 years ago
Attachment #118926 - Flags: superreview?(jst)
Attachment #118926 - Flags: review?(bugmail)
Comment on attachment 118926 [details] [diff] [review]
Restore the code to set referrer and hopefully a little bit better string foo

r=sicking. Thanks!
Attachment #118926 - Flags: review?(bugmail) → review+
Comment on attachment 118926 [details] [diff] [review]
Restore the code to set referrer and hopefully a little bit better string foo

actually, you could loose the |header.Truncate()|,
mHttpChannel->GetRequestHeader should reset the string properly upon success
Comment on attachment 118926 [details] [diff] [review]
Restore the code to set referrer and hopefully a little bit better string foo

What sicking said.
Attachment #118926 - Flags: superreview?(jst) → superreview+
(Assignee)

Comment 14

15 years ago
Comment on attachment 118926 [details] [diff] [review]
Restore the code to set referrer and hopefully a little bit better string foo

Ok. |header.Truncate();| removed locally.

Requesting 1.4a approval. This is a regression that may end up breaking a
number of sites.
Attachment #118926 - Flags: approval1.4a?
(Assignee)

Comment 15

15 years ago
-> To me.
Assignee: dom_bugs → keeda

Comment 16

15 years ago
Comment on attachment 118926 [details] [diff] [review]
Restore the code to set referrer and hopefully a little bit better string foo

a=asa (on behalf of drivers) for checkin to 1.4a. Time is short so this needs
to land asap if it's gonna make it.
Attachment #118926 - Flags: approval1.4a? → approval1.4a+

Comment 17

15 years ago
*** Bug 199919 has been marked as a duplicate of this bug. ***

Comment 18

15 years ago
Comment on attachment 118926 [details] [diff] [review]
Restore the code to set referrer and hopefully a little bit better string foo

checked in
Attachment #118926 - Attachment is obsolete: true
(Assignee)

Comment 19

15 years ago
Thanks for checking this in timeless.

-> Fixed.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Updated

15 years ago
Flags: blocking1.4a?
You need to log in before you can comment on or make changes to this bug.