Scroll step for up/down arrow keys is too small (especially with smoothscroll on); should scroll multiple lines

RESOLVED DUPLICATE of bug 635645

Status

()

Core
XUL
--
enhancement
RESOLVED DUPLICATE of bug 635645
15 years ago
7 years ago

People

(Reporter: Cyd, Unassigned)

Tracking

Trunk
Points:
---
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030329
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030329

When the "up" and "down" keys are pressed or when the "up" and "down" buttons on
the scrollbar are pressed, the content scrolls up or down by one line. Without
smoothscroll, this was necessary to allow the user to keep track of the content.
With smoothscroll, the scroll step seems too short. There should be an option to
tweak the number of lines by which to scroll; the default should be around 3
lines if smoothscroll is on, I think.

Reproducible: Always

Steps to Reproduce:
1. Turn smoothScroll on.
2. Open the browser and go to any webpage longer than 1 page.
3. Press the "down" key.

Actual Results:  
The content area scrolls down by 1 line

Expected Results:  
The content area should scroll down by about 3 lines.
I don't plan on changing this anytime soon. I'll leave this bug here to collect
comments. In general I'll resist doing UI design via Bugzilla; UI design can't
be as reactionary as that.
Assignee: jaggernaut → nobody
Severity: minor → enhancement
OS: Linux → All
Hardware: PC → All
While I agree that it would be nice to have some more real feedback, I also have
to say that arrow-based scrolling feels oddly slow. I would be happier with a
two or three fold increase.
Actually I take that back. If feels slow during testing but during actual use it
is fine, and making it faster would hurt usability for me.

Comment 4

15 years ago
It definately feels a little slow for me with smooth scrolling enabled.

Comment 5

15 years ago
I also think the default scroll step is too small, but I don't think the scroll
step should depend on whether smooth scrolling is enabled.
Summary: Scroll step too small with smoothscroll on → Scroll step for up/down arrow keys is too small with smoothscroll on

Comment 6

15 years ago
Yes, I do also think the default one is too small.
The scroll lines of keyboard lack harmony with mouse wheel scroll. 
So, it would be nice having an option to use "mousewheel.withnokey.numlines"
value as keyboard arrow scroll steps.

Comment 7

15 years ago
*** Bug 207992 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
*** Bug 256525 has been marked as a duplicate of this bug. ***

Comment 9

14 years ago
IE seems to scroll based on a percentage of the window size or content area
height.  Maximized at 800x600, IE scrolls 3 lines.  Maximized at 1024x768, IE
scrolls 4 lines.  Maximized 1600x1200, IE scrolls about 7 lines (not a whole
number).  We should do something similar.
Flags: blocking-aviary1.0?

Comment 10

14 years ago
smoothscroll isn't the default setting. I imagine we'd consider a reviewed
patch, but not going to block the release for this. 
Flags: blocking-aviary1.0? → blocking-aviary1.0-

Comment 11

12 years ago
See also bug 334098 for making it a pref.

See also bug 332582 for Minimo.
Summary: Scroll step for up/down arrow keys is too small with smoothscroll on → Scroll step for up/down arrow keys is too small (especially with smoothscroll on); should scroll multiple lines
*** Bug 334098 has been marked as a duplicate of this bug. ***

Updated

10 years ago
Keywords: mobile

Updated

9 years ago
Keywords: mobile

Updated

7 years ago
QA Contact: jrgmorrison → xptoolkit.widgets

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 635645
You need to log in before you can comment on or make changes to this bug.