when open a new tab it doesnt focus anymore on url bar - cursor isn't in address bar

RESOLVED WORKSFORME

Status

SeaMonkey
Tabbed Browser
--
minor
RESOLVED WORKSFORME
15 years ago
5 years ago

People

(Reporter: Roberto Bertó, Assigned: jag (Peter Annema))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401

On the 1.3 version when I open a new tab it shows a blank page AND focus on the
main URL field of the browser.

Now, on 1.4, a nice thing happened: when we open a new tab it open the first
page of my bookmark group BUT it doesnt focus on the URL field anymore.

I do not think this is a bug, but a feature remove that decrease usabillity.

When someone open a new tab, she/he want to:
- open his/her home page
- OR, open another page URL

So, it's better just type the new page URL than need to click on the URL bar.

Until you do not fix (if) this problem, can you tell me which hotkey can be used
to access the URL bar? On Internet Explorer F4 is the howkey to go to URL bar.


Thank you!

Reproducible: Always

Steps to Reproduce:
1. open a new tab (ctrl+t)

Actual Results:  
the url bar doesnt get focus.

Expected Results:  
url bar get focus
ctrl+L 
.
Assignee: asa → jaggernaut
Component: Browser-General → Tabbed Browser
QA Contact: asa → pmac
Whiteboard: DUPEME

Comment 3

15 years ago
*** Bug 201341 has been marked as a duplicate of this bug. ***

Comment 4

15 years ago
Tweaking summary and confirming.  (Although a dupe may still be found.)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: when open a new tab it doesnt focus anymore on url bar → when open a new tab it doesnt focus anymore on url bar - cursor isn't in address bar

Comment 5

15 years ago
(Status of URL focus may depend on what a new tab shows, if bug 197671 is
implemented.)

Comment 6

14 years ago
WFM, Linux 2.4.24 / Debian Sarge
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312 MultiZilla/1.6.2.0c

Comment 7

14 years ago
I have now the same problem with Mozilla 1.7 on Windows (Mozilla/5.0 (Windows;
U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616). In Mozilla 1.6 everything
worked fine.

(Maybe I should open a new bug because it is a newer version.)

Comment 8

14 years ago
*** Bug 218216 has been marked as a duplicate of this bug. ***

Comment 9

13 years ago
Confirming on:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050412
Firefox/1.0+

When you double click the tab bar to open a new tab, the location bar isn't
focus, when it should focus it (it's logical..)

I hope this gets fixed before 1.1!

Comment 10

13 years ago
This is similar to bug 230401 I think. Mozilla 1.7.8 focuses on the address bar,
but Firefox 1.0.4 doesn't. Very annoying!

Comment 11

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050812 Firefox/1.0+
ID:2005081219

WFM. Please reopen if you can reproduce in the latest builds.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Error: selectedNode.parent has no properties
Source file: chrome://browser/content/places/controller.js
Line: 924

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060717 Minefield/3.0a1 ID:2006071723 [cairo]
Product: Core → SeaMonkey

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.