Closed Bug 200698 Opened 20 years ago Closed 20 years ago

HTTP header is sometimes displayed in window

Categories

(Core :: Networking: HTTP, defect)

x86
Windows NT
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 197426

People

(Reporter: apang, Assigned: darin.moz)

References

()

Details

Attachments

(2 files, 1 obsolete file)

38.92 KB, image/png
Details
40.53 KB, application/octet-stream
Details
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3) Gecko/20030312

Seems to be more likely when visiting a page for the first time.  Viewing the
page source, the header is not present in the text.  Reloading the page cleans
up the display.  No pipelining.  I thought it might be related to link prefetch
being enabled, but I wasn't able to reproduce after clearing the cache and
restarting Mozilla.

The HTTP header appears to be malformed, i.e., leading "0", eg,

0 HTTP/1.1 200 OK Age: 0 Transfer-Encoding: chunked Date: Fri, 04 Apr 2003
18:24:53 GMT Content-Type: text/html X-Pad: work around browser bug Server:
Apache/1.3.19 (Unix) mod_perl/1.25 Last-Modified: Fri, 04 Apr 2003 14:45:52 GMT
Via: 1.1 nwmrbc01wc03 (NetCache NetApp/5.3.1R2D2) 8451


Reproducible: Couldn't Reproduce

Steps to Reproduce:
1.
2.
3.
Attached image Screen capture (obsolete) —
Related to (duplicate of?) bug 184528 and bug 194642.
sounds like a duplicate of bug 195746.  please try out moz 1.4 alpha.

*** This bug has been marked as a duplicate of 195746 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
reopening based on bug 195746 comment #38
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
i wonder if this has anything to do with the proxy server mentioned in this header:

  Via: 1.1 nwmrbc01wc03 (NetCache NetApp/5.3.1R2D2)

reporter: can you try browsing without the proxy server?  is that an option for you?
I can't bypass it -- I'm on ADSL and my browser proxy preference is already set
to "Direct connection to the Internet".

Apparently my telco/ISP uses these net appliances upstream (ref:
http://www.netapp.com/products/netcache/software_specs.html).  I've deduced that
the netapp name "nwmrbc01wc03" refers to "New Westminster, British Columbia",
while something like "vancbc01wc02" refers to "Vancouver, British Columbia".

I've started running WinPCap and Ethereal to see if I can shed more light on
this, but it's plausible that NetCache is contributing to the observed problem.
if you could enable mozilla's HTTP logging that would be best.  here's what to do:

open up a DOS prompt and type:

C:\> set NSPR_LOG_MODULES=nsHttp:5
C:\> set NSPR_LOG_FILE=C:\log.txt

then run mozilla from the DOS prompt like so:

C:\> cd \path\to\mozilla
C:\path\to\mozilla\> .\mozilla.exe

now try to reproduce the problem.  once you have exit mozilla and either upload
log.txt to this bug report or send it directly to me via email.  thx in advance!

NOTE: the log file may grow very large.
Attached image Screen capture
Attachment #119470 - Attachment is obsolete: true
Attached file Mozilla http log
The last URL accessed in the log corresponds to the screen capture.

*** This bug has been marked as a duplicate of 197426 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.