Crash on exit after using WMP 9.0 control

RESOLVED DUPLICATE of bug 244713

Status

()

Core
Plug-ins
--
critical
RESOLVED DUPLICATE of bug 244713
15 years ago
13 years ago

People

(Reporter: Michael Hendy (Hendikins), Assigned: Peter Lubczynski)

Tracking

({crash, qawanted, stackwanted})

Trunk
x86
Windows 2000
crash, qawanted, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
This behaviour has previously been mentioned in bug 193883, but I couldn't find
a seperate bug for it filed anywhere.

Steps to reproduce:

1. Install WMP9
2. Use workaround in bug 193883 to make Mozilla use the WMP9 control
3. View WMP content using WMP9 control
4. Exit
5. Crash

I had heard that this was Phoenix-specific, but I'm able to consistantly
reproduce with trunk build 2003041208 on Win2k, and with some random earlier
build that was on the system. Clean profiles, clean installation, etc.
(Reporter)

Updated

15 years ago
Keywords: qawanted
(Reporter)

Comment 1

15 years ago
Seems that Java is the catalyst here.

I've tested on a clean Win2k install (with only SP3, WMP9 and VMware tools) and
Moz 1.3 with the following Java setups:

1.4.2 Beta
1.4.1_02
1.4.0
1.3.1_07
1.3.1
1.3.0_05
1.3.0_01
No JRE Installed

The only time I didn't get a crash on exit was without any JRE installed. Anyone
on an OS other than Win2k, and/or able to tell me if there's anything I can do
with windbg that might help work out what's going on?

Comment 2

15 years ago
This seems to be a random problem, since I have not had any problems using the
WMP9 control with any Phoenix builds after applying the workaround from bug
193883. I have java installed and everything works fine.

Comment 3

15 years ago
I can reproduce this problem consistently
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030504 Mozilla
Firebird/0.6

Comment 4

15 years ago
I also added the workaround in bug 193883 to add MP 9 in Firebird 0.6.1. I crash
every time i load a page that contains a windows media player stream.

Also, isn't this bug Firebird specific? This didnt happend when I used Mozilla
before.
Severity: major → critical
Keywords: crash
Whiteboard: TB22397438X, TB22397418Z

Comment 5

15 years ago
same one my systen with [Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT;
rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1] and (sorry extracted form German
runtime) 
JAVA (TM) Runtime Environment, Standard Edition 1.4.2_01
Standardversion dieser virtuellen Maschine 1.4.2_01-b06
Java(TM)Plug-in 1.4.2_01

Comment 6

15 years ago
fwiw, still crashing on exit using FB 20031231 + WMP9 + JRE 1.4.2_03 on Win2k.
I can't run any debugger on this PC, anyone to get a stack ?
I removed the TB IDs as they're probably outdated now.
Keywords: stackwanted
Whiteboard: TB22397438X, TB22397418Z
To bug reporter and all comment posters who experienced this bug :
 
What is version/time-stamp of WMP9 plugins?
I clean installed Win-2K and installed all windows update(SP4) and many programs
including Mozilla 1.6(release version) and WMP9 and Sun Java 1.4.2_03 last week
and updated WMP9 modules yesterday.
So followings are latest versions of WMP9 plugin on Win-2K, I believe.
> npdsplay.dll Version: 3.0.2.628 Time-stamp: 2003/06/20 04:05:04
> npdrmv2.dll Version: 9.0.0.2980 Time-stamp: 2002/12/11 17:34:48
> npwmsdrm.dll  Version: 9.0.0.2980  Time-stamp: 2002/12/11 17:34:42
npdsplay.dll was updated after open of this bug.

If old npdsplay.dll is used, will updating WMP9 modules from standalone Windows
Media Player resolve the problem? 

Note: I'm not experiencing this bug both before and after re-install of Win-2K.

Comment 8

15 years ago
Experienced the problem while using Mozilla 1.6 (20040113), WMP (9.00.00.3075), 
and Java Plugin 1.4.2_03 on W2K.

Comment 9

15 years ago
still experiencing this crash when exiting FF, using FF 20040310 on Win2k + WMP9
+ JRE 1.5.0b (thought it may improve things since 1.4.2 but it did not).
This is worrying because the FF installer now make WMP9 the default as per bug
193883 comment 50.
The stack I got:

 	00720054()	
 	wmp.dll!079af2a5() 	
 	wmp.dll!079af7cd() 	
 	wmp.dll!079af2c9() 	
 	wmp.dll!078fe3df() 	
 	wmp.dll!07729785() 	
 	wmp.dll!078b1525() 	
 	wmp.dll!0793a450() 	
 	wmp.dll!07933e86() 	
 	wmp.dll!07933e5d() 	
 	wmp.dll!07933e4f() 	
 	jscript.dll!6b705b7b() 	
 	jscript.dll!6b705d1f() 	
 	jscript.dll!6b705c4b() 	
 	jscript.dll!6b705a54() 	
 	jscript.dll!6b72268b() 	
 	jscript.dll!6b723484() 	
 	OLE32.DLL!77abc8e3() 	
 	OLE32.DLL!77abddf7() 	
 	OLE32.DLL!77a98864() 	
 	OLE32.DLL!77a7ea47() 	
 	OLE32.DLL!77a7e656() 	
>	gkwidget.dll!OleRegisterMgr::~OleRegisterMgr()  Line 185	C++
 	gkwidget.dll!$E4()  + 0xd	C++
 	gkwidget.dll!_CRT_INIT(void * hDllHandle=0x02dd0000, unsigned long dwReason=0,
void * lpreserved=0x00000001)  Line 234	C
 	gkwidget.dll!_DllMainCRTStartup(void * hDllHandle=0x02dd0000, unsigned long
dwReason=0, void * lpreserved=0x00000001)  Line 288 + 0x11	C
 	NTDLL.DLL!77f86215() 	
 	NTDLL.DLL!77f8de7c() 	
 	NTDLL.DLL!77f81d79() 	
 	KERNEL32.DLL!7c59686d() 	
 	gklayout.dll!nsXULTreeBuilder::SortSubtree(nsTreeRows::Subtree *
aSubtree=0xc0000135)  Line 2027 + 0xe	C++
 	NTDLL.DLL!77f8d04a() 	
 	KERNEL32.DLL!7c57822c() 	
 	KERNEL32.DLL!7c590a6d() 	
 	NTDLL.DLL!77f91508() 	
 	KERNEL32.DLL!7c590b04() 	
 	msvcr71d.dll!__crtExitProcess(int status=0)  Line 464	C
 	msvcr71d.dll!doexit(int code=0, int quick=0, int retcaller=0)  Line 414 + 0x9	C
 	msvcr71d.dll!exit(int code=0)  Line 303 + 0xd	C
 	mozilla.exe!mainCRTStartup()  Line 406	C
 	KERNEL32.DLL!7c5987e7() 

Comment 11

14 years ago
unable to reproduce with windows Mozilla 1.7 beta. Is this still a problem?
(Reporter)

Comment 12

14 years ago
Just reproduced with Firefox 20040330 on my father's Win2k machine, so this
appears to still be a problem.

Comment 13

14 years ago
I am using Mozilla 1.4 and have WMP 9.0 installed and every time I exit out of
Mozilla it crashes. And web sites that require a WMP plugin say that it isn't
installed nor does the plugin list say that it is installed. Also installed is
Java 1.4.2_02. Have had this version installed for a while on both Mozilla 1.4 &
1.6a and never occurred before. Using Win 98SE and Win XP Pro. With a clean
install on Win98SE and Java 1.4.2_02 it starts up.

Comment 14

14 years ago
I get this crash everytime, when I play a WMP video from the following website:
http://portal.omroep.nl/uitzendinggemist

I'm using Mozilla 1.7 on 2 different machines, same problem.

I believe they wrote an own player based on WMP (in Java?). If I can help you
with the Dutch language or in another way, please contact me.

Comment 15

14 years ago
I get this crash everytime too!
when I play a WMV from the folloing.
http://www.tenki.jp/syoh/index.html
 
I use Mozilla 1.7 on W2K SP4.
My CPU is VIA Nehemiah 1GHz.

Updated

14 years ago
Flags: blocking-aviary1.0RC1?
this is a dup of the WMP9.0 bug that jst has. Someone, please find it for me! :D

Clearing blocking flag since the other bug has the flag set. 
Flags: blocking-aviary1.0RC1?

Comment 17

14 years ago
(In reply to comment #16)
> this is a dup of the WMP9.0 bug that jst has. Someone, please find it for me! :D

I think this is the one you were talking about

*** This bug has been marked as a duplicate of 244713 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 18

14 years ago
TB2718196Q *could* be related to this. Mozilla 1.8a5.
Actually I had other errors ("Windows Media Player Plug-in Dynamic Link Library
- The plugin performed an illegal operation. You are strongly advised to restart
Navigator"), but it crashed only on exit.
You need to log in before you can comment on or make changes to this bug.