Offline: Pref No "ask me at startup" checkbox for offline (if Mail/News not installed)

NEW
Unassigned

Status

SeaMonkey
Preferences
14 years ago
7 years ago

People

(Reporter: Joerg Steinigans-Hillemann, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.3) Gecko/20030312

When I open the preferences I don't have the checkbox to set that mozilla asks
me at startup if I want work offline.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
I'm sorry, I don't think I understand your problem..

When you open the preferences panel, you want to have a setting there that lets
you toggle whether Mozilla should prompt you for offline browsing on startup ?

You can toggle this by going to File->Work Offline... or by opening
'about:config' and playing with the 'offline.startup_state' preference.
(Reporter)

Comment 2

14 years ago
yes, e.g. in Netscape 4.7, in the offline preferences I can set that the
navigator or the email client asks if they shall dial or not. 
I also saw this feature in an older mozilla version (but I don't remember which
version it was)

*** This bug has been marked as a duplicate of 82487 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 4

14 years ago
Offline was moved under MailNew prefs... See bug 127423.

I think this patch also removed the "set the startup mode", it only supports
"ask or don't ask me".

Status: RESOLVED → UNCONFIRMED
Component: Browser-General → Networking
QA Contact: asa → benc
Resolution: DUPLICATE → ---
Summary: No "ask me at startup" checkbox for offline startup available → Offline: Pref No "ask me at startup" checkbox for offline

Comment 5

14 years ago
I confirm this bug : 
I just upgraded from 1.5 to release 1.6
I do not use startup accelerator
I do not use multiple profiles.

Upgrade was performed by : uninstall old version (keep some plugins though),
install new version with custom. Old profile data was preserved.

Now Mozilla _ALWAYS_ asks me at startup wheather I want to work online or
offline (behaviour changed since 1.5). 
This has quickly become _horribly_ annoying. (I have LAN access)

I looked all through the preferences dialog and found nothing that would allow
me to configure this new behaviour.
Then, I looked at my profile and found in prefs.js : 
user_pref("offline.startup_state", 1);
which I set to 0 and now Mozilla no longer asks me about work online/offline. 

I suggest that this behaviour be configurable somewhere in the preferences
dialog (because _MOST_ people are not that skilled to look for such settings as
I described above) and this behaviour be OFF by default (as up to 1.5 included)
I confirm this bug.
It is a problem when you do not install mail/news with the browser.
I suggest to change the summary to reflect this fact.

Comment 7

14 years ago
Why do we have a "ask me at startup" option for online status? Can we remove it
all together?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Offline: Pref No "ask me at startup" checkbox for offline → Offline: Pref No "ask me at startup" checkbox for offline (if Mail/News not installed)

Comment 8

14 years ago
I have this bug too, and I have mail installed.
This behaviour has changed since 1.5 and I agree with Andrei Boros, it's very
annoying!

Comment 9

13 years ago
(In reply to comment #8)
> I have this bug too, and I have mail installed.
> This behaviour has changed since 1.5 and I agree with Andrei Boros, it's very
> annoying!
It's annoying to a lot of people.  There's a whole thread in the support forum
(http://forums.mozillazine.org/viewtopic.php?p=416093#416093) about the rather
obscure way to fix this.

Comment 10

13 years ago
Offline used to be a the top level Pref UI but was moved to MailNews Pref UI
(possibly because it didn't work, then MailNews made it work so they took
control of it). 

I've found the related bugs, and I think they are going to be updated soon and
we can get to fixing this bug.
Assignee: asa → darin

Updated

13 years ago
OS: Windows 98 → All
Hardware: PC → All

Comment 11

13 years ago
+cc: Diego

I've added this to the networking prefs docs:
http://www.mozilla.org/quality/networking/docs/netprefs.html

Andrei: you can fix the setting by editing the prefs in "about:config". Email me
if you need help.

Updated

13 years ago
Blocks: 61689

Comment 12

13 years ago
*** Bug 239724 has been marked as a duplicate of this bug. ***

Updated

11 years ago
Assignee: darin → nobody
QA Contact: benc → networking
The checkbox isn't in Firefox, but is in SeaMonkey and Thunderbird... SeaMonkey is the only one where you can choose not to install mail/news. Therefore moving to SeaMonkey product.
Component: Networking → General
Product: Core → SeaMonkey
QA Contact: networking → general

Comment 14

7 years ago
We also have pref-offline.xul around that is unused and a useless commented-out item in preferences.xul about this. We should do something about that - either move it to a more global place like requested here or remove the unused references.
Component: General → Preferences
QA Contact: general → preferences

Comment 15

7 years ago
Bug 577514 Removed the redundant pref-offline UI which was commented out since 2001.
You need to log in before you can comment on or make changes to this bug.