Switching to Inbox folder while mail is downloading gets pointer stuck as hourglass

VERIFIED FIXED

Status

VERIFIED FIXED
16 years ago
7 years ago

People

(Reporter: sb1023, Assigned: Bienvenu)

Tracking

Bug Flags:
blocking1.6b +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

I've noticed this bug throughout the entire time of Using Mozilla, since 1.01.
If, while messages are being downloaded into the Inbox for an account and the
user selects that Inbox from the folder list, coming from a folder in another
account, the pointer will change to an hourglass when it is over the folder list
and message list areas and will not change back to the standard pointer even
after the messages are done downloading. It remains "stuck' as the hourglass.
The only way to get the standard pointer back is to select another folder and
then select the Inbox again. 
This only happens if the Inbox is selected while the messages are being
downloaded into it and only when switching to that folder from a folder in
another account. If the user switches to the Inbox from another folder within
that same account the bug doesn't happen. If the user selects the Inbox while
Mozilla is still connecting or logging on to the mail server the problem does
not occur. It only happens when switching to the receiving account's Inbox from
a folder in another account and only when doing so during the receiving of new
messages.

Reproducible: Always

Steps to Reproduce:
1. Select a folder from the folder list that is in an email account different
from the one fow which you are going to be downloading messages.
2. Click the "Get Msgs" dropdown to retrieve new mail from an account other than
the one in which you are active.
3. After Mozilla has contacted and logged onto the server and once mail has
started downloading select the Inbox folder of the account receiving the mail.
4. The pointer should change to the hourglass. 
5. Wait for mail to finish downloading. Pointer remains the hourglass. Moving
the pointer over the message list it will remain the hourglass. Using the
scrollbar to scroll through the message list, it will remain the hourglass.
Using the scrollbar to scroll through the folder list, it will remain the hourglass.
6. Select a message from the message list (old or new message, it does not
matter) and DO NOT MOVE THE MOUSE AFTER CLICKING ON THE MESSAGE.  The pointer
temporarily changes back to the standard pointer.
7. Move the mouse/pointer, even slightly. It changes back to the hourglass.
5. Select any another folder in any email account.
6. The pointer is now back to the standard pointer.
7. Select the Inbox folder again. Pointer remains the standard pointer.



Expected Results:  
I think the desired action should be that the pointer changes to the hourglass
while messages are being downloaded but should change back to the standard
pointer once downloading of messages in complete.
(Reporter)

Comment 1

15 years ago
I submitted this back in April and it hasn't been touched, commented on, or even
confirmed by anyone. It is still an issue in Mozilla Mail and is also an issue
with Thunderbird 0.2 as well. Is anyone going to do anything about this?
Not only that, but the mail folders go completely blank so that Mail has to be
closed and reopened to view the messages that were downloaded.

   Mozilla 1.5 RC1
   Mac OS X
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
Not only that, but the mail folders go completely blank so that Mail has to be
closed and reopened to view the messages that were downloaded.

   Mozilla 1.5 RC1
   Mac OS X
Status: NEW → ASSIGNED

Comment 4

15 years ago
*** Bug 223756 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
*** Bug 220279 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
Scott's gone, or so says his nickname.

I can confirm this is still present in Moz 2003102504.
Assignee: mscott → sspitzer
Status: ASSIGNED → NEW

Comment 7

15 years ago
-> Mail Window Front End
Component: Networking: MailNews General → Mail Window Front End

Comment 8

15 years ago
*** Bug 223025 has been marked as a duplicate of this bug. ***

Comment 9

15 years ago
Bug 219996 is the same issue, but for Thunderbird.

Updated

15 years ago
Blocks: 219996
(Reporter)

Comment 10

15 years ago
Jason, sorry for not keeping up with this bug. I've switched to Thunderbird, and
you're right, its there as well. I hope they get this fixed soon. Its very annoying.

Updated

15 years ago
Flags: blocking1.6b?

Comment 11

15 years ago
Scott, is this important for Thunderbird (or SeaMonkey) enough to hold 1.6beta
to get a fix?

Comment 12

15 years ago
Imap or POP? 

Comment 13

15 years ago
I see this with a current Linux CVS trunk build and an IMAP account.

Comment 14

15 years ago
I see it with POP on WinXP.
I see this too.  David, any ideas?

/be
(Assignee)

Comment 16

15 years ago
yes, I know what's going on here. We think the db is out of sync with the mail
folder  - this is because we're in the middle of writing messages to the inbox
and haven't updated the db timestamp/size yet. Fixing it is the hard part. I'll
try to find a safe fix.
Assignee: sspitzer → bienvenu
(Assignee)

Comment 17

15 years ago
Created attachment 136603 [details] [diff] [review]
proposed fix

this should fix this - I also removed an unused variable.
(Assignee)

Updated

15 years ago
Attachment #136603 - Flags: superreview?(mscott)
Let's get this fixed in 1.6b, today if possible.

/be
Flags: blocking1.6b? → blocking1.6b+

Updated

15 years ago
Attachment #136603 - Flags: superreview?(mscott) → superreview+
Comment on attachment 136603 [details] [diff] [review]
proposed fix

r/a=sspitzer for 1.6b
Attachment #136603 - Flags: review+
Attachment #136603 - Flags: approval1.6b+
(Assignee)

Comment 20

15 years ago
fix checked in.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Assignee)

Comment 21

15 years ago
*** Bug 217851 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.