Toolbar bookmarks fail to work after activating opening a new window when no windows where open

RESOLVED DUPLICATE of bug 206752

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 206752
15 years ago
12 years ago

People

(Reporter: Shoshannah Forbes, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030510 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030510 Mozilla Firebird/0.6

on mac, an application can be running with no windows open.
with fb, when you open a window after no window was open, bookmarks in the
bookmarks toolbar fail to work

Reproducible: Always

Steps to Reproduce:
1. click on a bookmark in the bookmark toolbar- verify that it works
2. close all open fb windows, leave the application running
3. file--> new window
4. click on a bookmar in the bookmark toolbar

Actual Results:  
the bookmark fails to work- nothing happens

Expected Results:  
the bookmark should work

re-starting fb clear the situation, and the bookmarks work again (until the next
time the user closes all the windows while leaving the application running- a
common thing on the mac)

Comment 1

15 years ago
I can confirm this bug still using:
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030513
Mozilla Firebird/0.6

If one is not careful they can end up with a plethora of windows open in Mozilla
Firebird. Of course, this uses up precious resources.

Comment 2

15 years ago
This should be set to Hardware / OS = "All" since we have a similar bug reported
on PC/Windows:

if all Mozilla Firebird (Browser) Windows has been closed and a new window gets
spawned (either by bookmark manager or by Mac's File -> new window) the new
browser window's toolbar fails...

=> changing hardware & OS and duping bug #206101 because of this one as the
cause for both bugs seems to be the same
OS: MacOS X → All
Hardware: Macintosh → All

Comment 3

15 years ago
*** Bug 206101 has been marked as a duplicate of this bug. ***
taking QA contact, sorry about the bugspam
QA Contact: asa → mconnor

Comment 5

15 years ago
Can also confirm behavior exists in 0.7:

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031007
Firebird/0.7

Seems more likely that bug will show up on Mac as it is a common situation to
have an app running with no active windows; this is a much less common situation
on a PC.

Comment 6

15 years ago
This seems related to bug #206752.
reverting changes to this bug to OS X-specific bug, duping to bug 206752 since
it has a lot more dupes and cc's.  Thanks for pointing this out Charles

re comment 2, the opening from bookmarks manager issue is bug 195636

*** This bug has been marked as a duplicate of 206752 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
OS: All → MacOS X
Hardware: All → Macintosh
Resolution: --- → DUPLICATE
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.