Neither Blackdown nor Sun java plugin will load: _ZdlPv undefined

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
16 years ago
8 years ago

People

(Reporter: marcjw53, Assigned: yuanyi21)

Tracking

({qawanted})

Trunk
x86
Linux
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPME])

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4b) Gecko/20030510
Build Identifier: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4b) Gecko/20030510

After installing both 1.4b and the nightly build of same, neither the latest
Blackdown java plugin (1.4.1) nor the latest Sun java 1.4.2(beta) plugin will
load.  With my previous Moz, 1.3, I was required to use Blackdown because Sun
didn't have a version at that time that was compiled with gcc3.2.  The Blackdown
version worked fine.  Now that Sun has apparently made a version that supposedly
works with the latest Mozilla, I tried it also.  Neither one works.  Here is the
command line error:<br>
LoadPlugin: failed to initialize shared library
/usr/j2re1.4.2/plugin/i386/ns610-gcc32/libjavaplugin_oji.so
[/usr/j2re1.4.2/plugin/i386/ns610-gcc32/libjavaplugin_oji.so: undefined symbol:
_ZdlPv]

Reproducible: Always

Steps to Reproduce:
1. Install Browser
2. Install java plugin
3. Start browser

Actual Results:  
Java Plugin is not loaded but instead gives an error when trying

Expected Results:  
Java plugin gets loaded

All my other plugins seem to load and function fine.

Comment 1

16 years ago
After upgrading from 1.2.1 to 1.4b my Java plugin (1.4.1-02b) does not work any
longer. It does not get loaded:

LoadPlugin: failed to initialize shared library
/usr/java/j2sdk1.4.1_02/jre/plugin/i386/ns610/libjavaplugin_oji.so
[/usr/java/j2sdk1.4.1_02/jre/plugin/i386/ns610/libjavaplugin_oji.so: undefined
symbol: GetGlobalServiceManager__16nsServiceManagerPP17nsIServiceManager]

This is on Linux RH 9.

Comment 2

16 years ago
Ok, I investigated a little bit further. It looks like I have to get a
gcc3-compiled version of the plugin. It looks like there is one available form
Blackdown.

Comment 3

15 years ago
There is also one available from Sun, in a subdirectory of the JRE's plugins
directory. This is actually a duplicate of another bug, but I can't find it at
the moment.

-M
Keywords: qawanted
Whiteboard: [DUPME]

Comment 4

15 years ago
*** Bug 227867 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
*** Bug 227955 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
added errormessage to summary for better search results
Summary: Neither Blackdown nor Sun java plugin will load → Neither Blackdown nor Sun java plugin will load: _ZdlPv undefined
-> Oji
Assignee: peterlubczynski-bugs → kyle.yuan
Component: Plug-ins → Java: OJI

Comment 8

15 years ago
This is happening for me with Moz 2003120915 (Linux) and the gcc32 plugin from
jre 1.4.2_03. The exact error on bootup is:

LoadPlugin: failed to initialize shared library
/usr/local/java.sun/j2sdk1.4.2_02/jre/plugin/i386/ns610-gcc32/libjavaplugin_oji.so
[/usr/local/java.sun/j2sdk1.4.2_02/jre/plugin/i386/ns610-gcc32/libjavaplugin_oji.so:
undefined symbol: _ZdlPv]

and whilst java shows up in about:plugins it doesn't work and isn't even
recognised as present when I load a page that uses it. Instead of the usual java
stuff I get a requester asking me if I wish to download it.

Suckage.

Comment 9

15 years ago
Found out what it was in my case. 

about:buildconfig

c++  gcc version 2.96
gcc  gcc version 3.2.3

Whoever does the compiles started doing them with 2.x again and I was using the
3.x plugin as normal.

Most annoying.

Comment 10

15 years ago
During the 1.4 release cycle mozilla started using a new compiler revision for
its binary releases. You must use a compatible version of the java plugin, as
noted in comment #2. This issue is described in the 1.4 release notes; see
<http://www.mozilla.org/releases/mozilla1.4/installation-extras.html>.

The bugs duped in comments 3 and 4 and the later comments are actually about a
new and different issue. I've unduped them; further commentary on that issue
should go to bug 227867.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Assignee)

Comment 11

15 years ago
*** Bug 228350 has been marked as a duplicate of this bug. ***

Comment 12

15 years ago
ln -s /usr/lib/java2/jre/plugin/i386/ns610/libjavaplugin_oji.so javaplugin_oji.so
fixes it, the one in /usr/lib/java2/jre/plugin/i386/ns610-gcc32 is not the one
to use.
(Assignee)

Comment 13

15 years ago
Sid, please don't switch the java plug-in library back, this is just a temporary
error. see bug 227867 comment 12.

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.