Toggle and retention window needed for Download Manager History prefs

VERIFIED FIXED in Firebird0.8

Status

()

Firefox
Preferences
--
enhancement
VERIFIED FIXED
15 years ago
11 years ago

People

(Reporter: Robert Parenton, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

unspecified
Firebird0.8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030504 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030504 Mozilla Firebird/0.6

Moved 'XXXben - blake, we need at the very least a toggle here, probably a
retention window as well' comment to this bug from the Download Manager History
to fix Bug 204134.  Since this was added by Ben, I created this bug to let the
developers decide if they want to implement this functionality.

Reproducible: Always

Steps to Reproduce:
1. Open the prefs window and go to Privacy
2. Select Download Manager History


Expected Results:  
Options to toggle Download Manager History and set a retention window should be
available.

Comment 1

15 years ago
A bit of a no-brainer bug. We should have reported this ages ago guys :)

Confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

15 years ago
Blocks: 204134
--> ben as part of duping 204134 against this bug
Assignee: blakeross → ben
Blocks: 191524
No longer blocks: 204134
*** Bug 204134 has been marked as a duplicate of this bug. ***
target from 204134 carried over -> 0.7
Target Milestone: --- → Firebird0.7
taking QA contact, sorry about the bugspam
QA Contact: asa → mconnor
-> 0.8
Status: NEW → ASSIGNED
Target Milestone: Firebird0.7 → Firebird0.8

Comment 7

14 years ago
After Hyatt's "The Mother Of All Download Landings, Phase I" it now reads,
instead of XXXBen: "THESE OPTIONS DO NOT WORK YET.
Remove files from the Download Manager:
-Upon successful download
-When Firebird exits
-Manually".

Comment 8

14 years ago
The options are gone. There's no comment either.

Comment 9

14 years ago
*** Bug 218611 has been marked as a duplicate of this bug. ***
Fixed. To turn off the download manager's tracking of your download history,
change the retention option to "Upon successful download". (Canceled downloads
remain, just use the Clean Up button to get rid of those). 
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.