web page continues to scroll up / down with mouse movement even if one is not dragging the scroll bar (at right margin)

RESOLVED DUPLICATE of bug 48037

Status

()

RESOLVED DUPLICATE of bug 48037
16 years ago
14 years ago

People

(Reporter: satyaki_sharma, Assigned: jag-mozilla)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4a) Gecko/20030401

This works on any web-page. Open the web page, and left-click and drag the
scroll bar at the right margin (or bottom margin as case may be). 
Now while holding the left button down, hit alt+tab with left hand, and move the
mouse a bit so that it moves off the scroll bar location (as in the previous
window). 
Now hit alt-tab again, you are back to the web-page you started on. 

Find the web-page scrolling up and down with your mouse movement, even though
you are not dragging the scroll bar. 

(this works even if you keep holding the left-button through-out, though then
the web-page movement isn't that surprising)

I chanced upon this bug due to some web-pages making their window (notably, msn)
active once the page is completely loaded. So when I go back to the window I was
already using (and scrolling down on), I find the afore-mentioned behaviour.

Reproducible: Always

Steps to Reproduce:
1. Go to webpage(any which features a vertical / horizontal scroll bar due to size)
2. Hold down scroll bar and drag to move web-page up and down
3. Hit Alt+Tab and change to another window. 
4. Hit Alt+Tab and change back to first page. 

Actual Results:  
the web-page scrolls up-down / left-right even if I am not holding down the
scroll button. 

Expected Results:  
The web-page should not have scrolled.

I haven't been able to use Linux for a while (damn my office and job, am living
away from home). So if you can please confirm this behavior on linux. 

I have been meaning to file this bug for a long time, havn't done so for 
a) fear of duplicity
b) minor nature

Also, sometimes I think this is a cool feature of Mozilla, I often end up using
mice which do not have scroll wheels (yes!) .. then I can do this intentionally
:) You might want to make this a 'feature' of Mozilla somehow

Comment 1

15 years ago
-> XP Toolkit/Widgets

I can confirm slightly different behavior on Win 2000 in recent Firebird and
SeaMonkey nightlies. To clarify, here are the steps I took.

1. Begin scrolling down by cliking and holding the down-arrow at the bottom of
vertical scroll bar.
2. While page is scrolling, alt-tab to a non-maximized window so that Mozilla is
still visible (but not the active application) and the scrollbar is uncovered by
the new window.
3. As long as you hold down the mouse button over the down arrow, the page will
continue to scroll even though Mozilla is not the active application.

The above obviously works for scrolling up and horizontally too.
Assignee: general → jag
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Toolkit/Widgets
Ever confirmed: true
QA Contact: general → jrgmorrison
Summary: web page continues to scroll up / down with mouse movement even if one is not dragging the scroll bar (at right margin) → web page continues to scroll up / down with mouse movement even if one is not dragging the scroll bar (at right margin)

Comment 2

15 years ago
There is also a bug filed about same behaviour after following steps:
1) move scrollbar with mouse
2) while keeping left mouse button pressed leave the moz window
3) right-click and THEN release also the left button
-> Moz will scroll as soon as you hover the window again (without mouse button
pressed)

As I said: that is an OTHER bug, I just don't know the number off-head.
But they might be related.
(In reply to comment #2)
> As I said: that is an OTHER bug, I just don't know the number off-head.
> But they might be related.

Bug 243900 may be !?
{{
Vertical scroll an iframe without pressing the mouse button
}}

Comment 4

14 years ago
> Bug 243900 may be !?

No, I meant bug 125301 & Co. (maybe also bug 125375 and bug 156942). 
That one names ESC as a way to abort scrolling, this bug here Alt+Tab, but the
underlying problem is the same (OnDragExit not called).
But yes, bug 243900 also looks quite similar.

Updated

14 years ago
Blocks: 67277

*** This bug has been marked as a duplicate of 48037 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.