[Mac] Missing PrintPDE.plugin: can't print background colors, selection or frames

VERIFIED FIXED

Status

()

Firefox
Build Config
--
trivial
VERIFIED FIXED
15 years ago
13 years ago

People

(Reporter: HARUNAGA Hirotoshi, Assigned: Brian Ryner (not reading))

Tracking

({fixed-aviary1.0, polish, pp})

1.0 Branch
PowerPC
Mac OS X
fixed-aviary1.0, polish, pp
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

836 bytes, patch
Conrad Carlen (not reading bugmail)
: review+
Details | Diff | Splinter Review
(Reporter)

Description

15 years ago
Mac Mozilla Firebird cannot "Print Background Colors" and "Print Background
Images".

Steps:
Open Menu File -> Print

Result:
There is no "Print Background Colors" or "Print Background Images" option.

Confirming with Mozilla Firebird 20030515 on MacOS 10.2.5.
Mozilla trunk has "Mozilla" dialog in "Print" dialog.

And there is PrintPDE.plugin in Mozilla.app/Contents/Plug-Ins/ on Mozilla,
but Firebird doesn't have "Mozilla Firebird.app/Contents/Plug-Ins" directory.

If I copy Mozilla.app/Contents/Plug-Ins to "Mozilla Firebird.app/Contents",
"Mozilla Firebird" dialog becomes to appear in "Print" dialog.

Related to Bug 202340 and Bug 188508.

Comment 1

14 years ago
Taking QA Contact as designated owner of Firebird-Menus. Sorry for bugspam.
QA Contact: asa → bugzilla

Comment 2

14 years ago
reassigning mac bugs, sorry for the spam.
Assignee: blake → nobody
--> hyatt
Assignee: nobody → hyatt
Severity: normal → minor
(Reporter)

Comment 4

14 years ago
Created attachment 130772 [details] [diff] [review]
patch

Comment 5

14 years ago
This patch is required for Thunderbird similarly.

Comment 6

14 years ago
Although tried also on Firefox and Thunderbird which were created by
AVIARY_1_0_20040515_BRANCH, the background-color-etc.-extended printing property
is working.
(Reporter)

Comment 7

14 years ago
I can't find that property. Where?
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040611
Firefox/0.8.0+
Summary: [Mac FB] Can't "Print Background Colors" (missing PrintPDE.plugin) → [Mac] Can't "Print Background Colors" (missing PrintPDE.plugin)

Comment 8

14 years ago
(In reply to comment #6)
> Although tried also on Firefox and Thunderbird which were created by
> AVIARY_1_0_20040515_BRANCH, the background-color-etc.-extended printing property
> is working.

Oops...
The patch was applied by the manual...
(Reporter)

Comment 9

14 years ago
Over to Build Config.
Assignee: hyatt → bryner
Component: Menus → Build Config
QA Contact: bugzilla → asa

Comment 10

14 years ago
*** Bug 250403 has been marked as a duplicate of this bug. ***

Comment 11

14 years ago
Nominating for 1.0.

This plugin (a Mac OS X printer-plugin, not a browser plugin) is missing from
Firefox and Thunderbird builds, but it present in Seamonkey. This causes a
special 'Mozilla' or 'Firefox' tab to appear in the print dialog box, with
options to print selections, background colors and frames. It's generic for all
gecko apps.

It's a super easy checkin, we only have to copy the plugin in the build. In
fact, you can also copy the Contents/Plug-ins folder from Mozilla into the
Firefox package yourself (when you've opened both applications with 'Show
Package Contents'). The plugin even automatically assumes the correct name of
the application (Mozilla/Firefox/Mozilla Tunderbird).

Don't forget to check it in Thunderbird too.
Flags: blocking1.0mac?
Summary: [Mac] Can't "Print Background Colors" (missing PrintPDE.plugin) → [Mac] Missing PrintPDE.plugin: can't print background colors, selection or frames

Comment 12

14 years ago
*** Bug 250816 has been marked as a duplicate of this bug. ***
Comment on attachment 130772 [details] [diff] [review]
patch

r=ccarlen.
Attachment #130772 - Flags: review+

Updated

13 years ago
Severity: minor → trivial
Keywords: polish, pp

Updated

13 years ago
Blocks: 261216

Updated

13 years ago
Flags: blocking-aviary1.0?

Comment 14

13 years ago
Thunderbird bug is bug 261216
Whiteboard: [have patch]
Version: unspecified → 1.0 Branch

Comment 15

13 years ago
Bryner, Chase, is this a simple packaging change? Is it worth considering for
Firefox 1.0

Comment 16

13 years ago
Comment on attachment 130772 [details] [diff] [review]
patch

a=asa for aviary checkin.
Attachment #130772 - Flags: approval-aviary+
(Assignee)

Comment 17

13 years ago
checked into trunk and branch.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed-aviary1.0
Resolution: --- → FIXED
Flags: blocking-aviary1.0mac?
Flags: blocking-aviary1.0?
Whiteboard: [have patch]
vrfy'd fixed with 2004110711-0.11 on mac os x 10.3.5. able to print selection
and frames.
Status: RESOLVED → VERIFIED

Comment 19

13 years ago
Can the strings in English.lproj/PrintPDE.nib/objects.xib be localized somehow
or should I open a new bug about this? The Mac print dialog currently displays
in English even on our sv-SE builds.
(In reply to comment #19)
> Can the strings in English.lproj/PrintPDE.nib/objects.xib be localized somehow
> or should I open a new bug about this? The Mac print dialog currently displays
> in English even on our sv-SE builds.

yes, a separate bug would be good for that issue.

Comment 21

13 years ago
Print Selection is greyed out for me on 11-07 build.
(Assignee)

Comment 22

13 years ago
I just tested today's es-ES localized build.  Only the newly-added print options
are in English, so it's not really a regression.  I think that to address this
fully, localizers would need to translate the Localizable.strings file in
English.lproj and place it in a <Language>.lproj directory.  (I'm not 100% sure
about that)  At any rate, it's too late to require localizers to translate this
file, but I think having this functionality there in English is better than not
having it at all.

Also, print selection works fine here, just make sure you actually have some
text selected.

Comment 23

13 years ago
See bug 268309 for the localization issue.

Comment 24

13 years ago
To elaborate on my earlier post, I realized that if your printer Presets is
something other than "Standard", the print selection and the frames options will
be greyed out.  Reproducible by simply saving a profile.
You need to log in before you can comment on or make changes to this bug.