Closed Bug 206176 Opened 20 years ago Closed 15 years ago

view source of frame containing only image shows image-binary-code

Categories

(Toolkit :: View Source, defect)

x86
All
defect
Not set
minor

Tracking

()

VERIFIED FIXED

People

(Reporter: kriskelvin, Assigned: bugs)

References

(Depends on 1 open bug)

Details

(Keywords: qawanted)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

If a window or frame contains only an image. Chosing to view the source of the
frame shows the image-binary-code in source-window

Reproducible: Always

Steps to Reproduce:
1.open an image with mozilla-firebird
2.rightclick into frame but outside the image and chose view source


Actual Results:  
image binary shown

Expected Results:  
view source option disabled

I found bug 84542 and bug 152706 most probably related.
Confirming bug. I see this also on Mozilla/5.0 (Windows 2000; en-US; rv:1.4b)
Gecko/20030518 Mozilla Firebird/0.6, but not on Mozilla Navigator using
Mozilla/5.0 (Windows 2000; en-US; rv:1.4b) Gecko/20030512 

It seems, that Firebird and Navigator code differ in this matter.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Severity: normal → trivial
QA Contact: asa
QA Contact: bugzilla
-> view source.
Assignee: firefox → bugs
Component: General → View Source
QA Contact: bugzilla → firefox.view-source
I'd like to fix this but I'm stuck trying to figure out how to do it. View
Source for the page has to be enabled/disabled on every page load and on every
tab change. Page loads are easy enough: just add code to nsBrowserStatusHandler
in browser.js. But tab changes are in updateCurrentBrowser in tabbrowser.xml, a
part of the toolkit, and the toolkit doesn't include the view source menu
options, so we can't assume that those options are there, let alone what their
ids are. The patches for Seamonkey in bug 84542 don't have this problem, because
XPFE *does* include the menu options in navigatorOverlay.xul.

We also can't enable/disable view source when the View menu or the context menu
are displayed, because this wouldn't enable/disable keyboard shortcuts.

A possible solution would be to add a feature to tabbrowser where consumers
could define a callback function to be called on a tab change. Is this desirable?
Severity: trivial → minor
Status: NEW → ASSIGNED
Keywords: qawanted
*** Bug 257065 has been marked as a duplicate of this bug. ***
*** Bug 294383 has been marked as a duplicate of this bug. ***
Duplicate of this bug: 369718
Depends on: 384854
I guess the checkin for bug 384854 fixes this problem, because it makes the view source command disabled for frames containing only images.

I'm marking this as fixed.  Feel free to re-open if there are more issues in this regard.
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Version: unspecified → Trunk
Product: Firefox → Toolkit
Verified Fixed.

Is there anything else that requires the qawanted keyword for this bug?

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20100114 Minefield/3.7a1pre (.NET CLR 3.5.30729) ID:20100114042800
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.